Sign in with
Sign up | Sign in
Your question
Solved

Starcraft 2 Performance problems

Last response: in Video Games
Share
August 22, 2012 2:54:05 AM

Hello, i am currently getting low frames on most of SC2's maps. Nothing on screen has to be happening to cause this. And it gets jumpy and drops when i pan. My settings are on Ultra. I shouldn't be having this problem because i have 2 gtx 570's in SLI and an I5 2500K. Is it the game or me? (The frame rate drops to the 30's, using MSI afterburner)

EDIT: I also get this error occasionally saying that my pc has ran out of paged pool memory and that graphical settings may be affected also Windows then promptly tells me to turn off Aero because it detected my PC running slow.
August 22, 2012 10:43:21 AM

I'm guessing he's in Windows 7 due to the mention of Aero.

Are you playing the campaign or multiplayer/co-op/custom? Is the fps the same at the start and mid-game?
m
0
l
Related resources
August 22, 2012 11:22:52 AM

8GB RAM (as per sig)? W7 x64? Latest drivers? Tried with SLI disabled?
m
0
l
August 22, 2012 1:29:55 PM

what is your paged memory size set to? if you're running out, it's probably too low (typically you want to set it to 1.5x of your total ram)

if windows offers you to disable aero while you're running the game full screen, you can ignore windows because it's being silly. If you're running in windowed mode, then you should probably consider it.
m
0
l
August 22, 2012 4:15:09 PM

Set paged memory size at 10 GB, but not on your SSD, where space is precious, but on your HDD.
m
0
l
August 22, 2012 4:20:35 PM

You have 8gb of memory, that should be more than enough for Starcraft 2.

Go to:

// Control Panel\System and Security\System
// Open "Advanced System Settings"
// Click Settings
// Click Advanced Tab
// Click Change
// Make sure it's set to automatically manage page file size for all drives.

You should check task manager to see if something is eating up all your memory, click memory tab to sort.

You can also try a Starcraft 2 game repair, it should be in the game directory or program files in start menu.
m
0
l
August 22, 2012 10:25:32 PM

The fps is indeed the same at the start and end of the game. I am on windows 7. I have tried SLI disabled and enabled...no difference. I am on the latest NVIDIA drivers. My paged pool memory is at 8GB for my ssd which is what SC2 is on and 16 GB for my HDD. I have re installed SC2 several times and i get the same errors. I also never have any other windows open when playing games i make sure all programs that are unnecessary are closed. When i play the game its a mixture of CO-OP, multiplayer and campaign. Performance is the same across all modes. When I turn shadows, lighting, and shaders to low my fps is always 60+. I am starting to get annoyed because I am having the same problem in Shogun 2 (low fps) when clearly my system meets the specs required to play on ultra. Also i read that sc2 only uses 1 core so that it may be bottlenecking but that doesn't sound like it would bring my fps down to 30 fps. Thnx for the replies. I am still having problems though.
m
0
l
August 23, 2012 12:00:23 AM

This sounds like a video card issue.

Remove drivers and software for video card via device manager; reboot and reinstall drivers. You card might be overheating and under-clocking to prevent damage; you might have overclocked to high if you did.
m
0
l
August 23, 2012 12:03:57 AM

simon12 said:
Read this and see if anything helps https://support.steampowered.com/kb_article.php?p_faqid...` If not try running Memtest to check your RAM is fine and run a benchmark like 3dMark to check you get around the score you should.


Also a good idea to try this, how much memory do you have free when running SCII? If you ran out of memory I doubt you would would be able to even play SCII at all though.

I've ran out of memory before, while using a RAMDISK, and computer became so sluggish; have 16gb.
m
0
l
August 23, 2012 3:02:24 AM

So i checked how much memory (RAM) is being used during fps drops...3.33 GB on average also my CPU is running at 1-5% when at task manager while playing SC2. My paging memory is auto-managed. I also have a VERY well managed and clean PC i have no unnecessary programs and keep my HDDs clean. I don't think anything is wrong with my video cards because they run the Witcher 2 on ultra (ubersampling off) @60 fps 97% o fthe time @1080p. I am gonna run 3dmark 11 and ill post my score (i dont know what to look for score wise)
m
0
l
August 23, 2012 3:17:28 AM

So I ran the test with performance preset (nothing else touched) and with my I5 2500k I got a CPU score of 7296, On the graphics side I got a score of 10426
m
0
l
August 23, 2012 1:33:57 PM

If you have not read through the whole 9 page forum link I posted some people found that disabling there antivirus worked, its worth a try.
m
0
l
August 23, 2012 7:03:14 PM

Thanks for the replies guys. I have done everything you said (finally read the 9 paged post) and realized that i will just have to deal with it. The paged pool memory error occurs infrequently and i don't have it nearly as badly as other people. I am gonna update my bios (its still at 1.0) and hopefully that will increase overall performance. I will set game priority to high when playing and close most of my background programs. I will manually modify my virtual memory to 1.5 times my ram. Hopefully this will yield some results. If not i will have to deal with it (I guess it is not the end of the world). Thanks again.
m
0
l
August 23, 2012 9:34:28 PM

your virtual ram should always be 1.5 times your actual ram so yeah setting it manually is the correct thing to do... sorry i didnt get to see this quickker or it would have been the first thing i suggested you do...
m
0
l
August 25, 2012 1:45:23 AM

I FIXED my problem!!! Yays. My game now runs smoothly at 60 fps on 8x game speed replay that gave me 30 fps on normal speed before. I re-downloaded Nvidia's 296.10 WQHL driver installed it and bam everything was fixed. Thnx for the replies guys!
m
0
l

Best solution

August 25, 2012 8:02:31 AM

lol typical driver issues... pfft.
Share
September 5, 2012 10:57:53 PM

Best answer selected by 0absolutezero.
m
0
l
!