Sign in with
Sign up | Sign in
Your question

Black Ops - textures flashing with GTX670

Last response: in Video Games
Share
August 28, 2012 3:15:11 AM

Hello all,

I recently purchased a GTX670 for my system upgrading from my HD6850. It's an awesome card - and I love it. Only thing I've noticed that's a bit odd is that I tend to get random flashing textures in Black Ops (yes, I know it's an old game now, but I love it).

I've tried changing around all of the graphics settings both in the game and the NVidia menu as well as resetting everything back to default, and nothing seems to work. My nVidia driver version is 301.42.

Can anyone shed any light on this for me? It's nothing major just a bit of a nuisance that'd be nice to get rid of. Below is a screenshot that hopefully explains what I mean - if you can see the yellow and black texture on the rear left side, half of it is missing as I just caught it in mid-flicker. As soon as I walk forwards or backwards, it reappears.



Cheers

Graham.
August 28, 2012 8:02:34 AM

normally its a driver issue what that happens either that or your suffering texture pop because of a slow or fragmented hard drive.
use ccleaner to clean the registry when you remove the gfx drivers. then reboot and install fresh 1s. either newer or older than the current 1 you have. it wont matter because black ops is over a year old so there wont have been much tweaking lately. but it may have had an issue because of a new edition to the driver your currently using so swap it out...
after that consider defragging your hdd and if its a slow green drive move the gasme to the outer tracks with something like ultimate defrag.
doing so will speed up your machines ability to fetch textures and reduce the texture pop.
sometimes turning off physx will help with cod games they did use it in cod 4 but i think they dropped it or reduced the effect of it in subsequent games. because it would leave huge black polygons all over the screen when an avatar would get blown across the map so like i say try disabling it from the nvidia panel.
m
0
l
August 28, 2012 9:07:12 AM

I haven't actually run ccleaner since I installed my new graphics card. Thanks HeXit. I'll give that a try and do a defrag as well.

Edit: I don't think I need to do a defrag. I'm showing up as 0% fragmented. My hard drive is also only about a year and a half old so I doubt it'd be too slow?
m
0
l
Related resources
August 28, 2012 1:09:50 PM

Are you running Lucid Virtu software by any chance? Have noticed a lot of people getting texture problems while this is running.
m
0
l
August 28, 2012 2:14:01 PM

1. Win7 has an automated defrag task, so if you didn't disable it, you disk is defragged automatically
2. this typically is a driver issue as hexit pointed out, latest drivers are a few versions ahead of what you're using, so try them out.

frankly speaking I don't see anything wrong with that screenshot
m
0
l
August 29, 2012 1:33:59 AM

Not running Lucid Virtu. I'm using the latest drivers from nVidia, the 304.79 BETA drivers. Will keep checking the site for updates.

The screenshot doesn't really capture it too well but if you see it in a full motion video you'll get what I mean. The texture appears and disappears so fast that it appears to flash and flicker. Can be quite annoying at times.
m
0
l
August 29, 2012 1:32:41 PM

you posted on 28th, you should have no excuse to not have the driver that came out on the 27th. 306.02.

does your game have any mods? (I'm not sure if they exist even, but just humor me)

Are you forcing any settings through the GPU control panel?

The only other thing I can think of is there's a bug with rendering engine for nvidia as opposed to amd card that you switched from.

Most likely this has something to do with it being a new card and new architecture, and they haven't gotten around to testing out games like COD:BO. If latest drivers don't help, submit a bug report to nvidia or make a post on their support forum.
m
0
l
August 30, 2012 3:09:36 AM

Interesting.... I'm not sure why those drivers didn't show up when I looked at the nVidia site last, thanks for pointing those out to me. I will download and give them a try.

No mods on Black Ops, I'm forcing a few settings on control panel such as Ambient Occlusion, Texture Filtering, Triple Buffering but everything else is set at "Use the 3d application setting". I've tried tweaking with those a bit and no change.

I'll give these newer drivers a go and get back to you.
m
0
l
August 30, 2012 8:35:40 PM

reset all of them settings in the nvidia panel. the game doesnt support some of them.
forcing tripple buffer only work on opengl its not directly supported with direct x. it will only help if your running with vsync on in most cases.
texture filtering should be set to app controlled, or balanced, which ever option it gives and in game set the textures to native.. ambient occlusion is only partly supported so put that on app controlled as well or it will cause issues.
m
0
l
September 1, 2012 11:50:35 PM

Thanks for the advice everyone. I've tried resetting all of the settings etc and nothing has worked. I'm in communications with nVidia at present and the most recent email I had with them advised me to do a clean install of drivers 301.34 and try that which hasn't worked either, so just waiting to hear back from them now.
m
0
l
September 2, 2012 12:05:22 AM

i had a go myself as i still have it installed , went to that map and its not a problem with the game. maybe you should check the file integrity via steam...
m
0
l
September 2, 2012 12:36:58 AM

I tried that, didn't work. :( 
m
0
l
September 2, 2012 1:48:20 AM

The only thing that I thought might be the issue is that the HD6850 I had in before was an AMD card. When I switched to the GTX670 I uninstalled all of the AMD software and ran ccleaner to clear out what's left of the AMD software before I installed the GTX670 and downloaded the nVidia drivers. Is there something I may have missed in this process and perhaps there are old AMD drivers there that are messing with it somehow?
m
0
l
September 3, 2012 8:28:43 PM

yeah the hardware abstraction layer... its unlikely the problem will go away till you at the very least repair install windows.
preferably fresh install.
you can reset the HAL but its quite complex. Google is your friend if you want to try and take that approach... its to complex to get into here.
m
0
l
September 4, 2012 1:01:11 AM

I'll try and do a fresh install of Windows 7. Thanks Hexit.
m
0
l
September 4, 2012 5:18:41 AM

I've tried reinstalling Windows, updating my drivers and reinstalling the game. Nothing has worked. I guess it's just a bug that I'll have to get used to, unfortunately. I'm all out of ideas now. Thanks for your help everyone, much appreciated.
m
0
l
!