Sign in with
Sign up | Sign in
Your question

Low FPS and CPU usage Borderlands 2

Last response: in Video Games
Share
September 19, 2012 1:00:52 AM

I'm getting considerable FPS drops in certain areas in Borderlands 2 which leads me to believe that my CPU is bottlenecking me.
Majority of the time I stay at 60 w/ Vsync (or 100+ w/o) but it sometimes drops to 35-45 range which is really annoying.
CPU usage is ~50% when it drops.

So why would my frames drop when none of my hardware is being stressed?




Here are my specs:

Phenom II 955 @ 3.7Ghz
Asus M4n82 Deluxe Mobo
4GB DDR2 800Mhz
Gigabyte GTX 670 Windforce
Ultra LSP-650W PSU
September 19, 2012 2:49:42 AM

I am getting the same exact thing on my PC i have the 7970 and i play all my games maxxed without a single error borderlands 2 at max settings runs perfectly smooth 60 FPS with vsync than all of a sudden in random zones i get frame drops and it stays low in the 25-30 than it randomly shoots back up when it feels like it and its annoying the hell out of me and i play skyrim, crysis 2, call of duty, battlefield all at perfect 60 frames so idk whats going on with this game......



stweedo said:
I'm getting considerable FPS drops in certain areas in Borderlands 2 which leads me to believe that my CPU is bottlenecking me.
Majority of the time I stay at 60 w/ Vsync (or 100+ w/o) but it sometimes drops to 35-45 range which is really annoying.
CPU usage is ~50% when it drops.

So why would my frames drop when none of my hardware is being stressed?




Here are my specs:

Phenom II 955 @ 3.7Ghz
Asus M4n82 Deluxe Mobo
4GB DDR2 800Mhz
Gigabyte GTX 670 Windforce
Ultra LSP-650W PSU

September 19, 2012 4:17:34 AM

For me it's not random, it happens when viewing the first town from a distance and a little in the town itself. Maybe the buildings are causing it? Idk

Kinda seems like the game needs a patch to fully utilize AMD processors, but I'm not sure.
What is your CPU usage when it slows down?
Related resources
September 19, 2012 4:37:54 PM

I have the same thing with my system and it's an intel i5 with XFX 6970..
Have no problems with other games,this game decides to go from 80/90 fps with vsync off to 25 fps at random spots and it comes back after a minute and it rises again to 60-70-80...

This is really weird.
September 19, 2012 4:49:27 PM

gamniac said:
I have the same thing with my system and it's an intel i5 with XFX 6970..
Have no problems with other games,this game decides to go from 80/90 fps with vsync off to 25 fps at random spots and it comes back after a minute and it rises again to 60-70-80...

This is really weird.



Does this happen without moving your character at all?
When I walk and look around to somewhere without lots of buildings it jumps back up to 60+

Also can you check your cpu usage when your framerate drops and post back?
September 19, 2012 5:01:19 PM

My cpu usage is about 40%..
Believe me this game isn't stressing my system.. there's some issues software side.
September 19, 2012 5:05:15 PM

stweedo said:
Does this happen without moving your character at all?
When I walk and look around to somewhere without lots of buildings it jumps back up to 60+

Also can you check your cpu usage when your framerate drops and post back?



Yes.. no matter if i move or not it stays low up to a certain point,and then all of sudden it climbs again..
Not the whole though it start right after you cleared the pond section,and when you're suppose to find some audio log when approaching the section after you go under the gate and walk up to those few that are walking around up ahead.
In that section it's totally biscuit.

September 20, 2012 11:27:01 AM

My RiG:
CPU: AMD 1100T 6core O.C'd to 4.0GHz
RAM: Patriot Gamer 2 Series 16GB 1600MHz DDR3
MB: Sabertooth 990FX
GPU: Crossfired XFX 6870 1GB BE Double D
PSU: Thermaltake 775W

Same thing even with the new CAP 3 from AMD for Catalyst which has BL2 in the list. I can look at a city for years and get 60fps but as soon as I shoot to attract enemies BOOM 11fps :o  I had to quit after that.

Edit: I've tried disabling xfire no dice. Also after the 11fps when I quit and went to the main menu it said 22fps!
September 20, 2012 1:34:06 PM

I find it hard to find a constructive indication of what the problem can be,it seems people have various frame rate issues in certain situations.

I can't even say if it's AMD/Intel or ATI(AMD)/Nvidia related.. it seems this game again suffers from frame rate issues,sometimes games have problems with Xfire or SLI configurations,but now this is not the case when various configurations show problems in a single card configuration.


This has to be on the software side.. and this what you get when games are build for a system that has one configuration across the board.(consoles obviously)













Pseudo_Soldier said:
My RiG:
CPU: AMD 1100T 6core O.C'd to 4.0GHz
RAM: Patriot Gamer 2 Series 16GB 1600MHz DDR3
MB: Sabertooth 990FX
GPU: Crossfired XFX 6870 1GB BE Double D
PSU: Thermaltake 775W

Same thing even with the new CAP 3 from AMD for Catalyst which has BL2 in the list. I can look at a city for years and get 60fps but as soon as I shoot to attract enemies BOOM 11fps :o  I had to quit after that.

Edit: I've tried disabling xfire no dice. Also after the 11fps when I quit and went to the main menu it said 22fps!

September 21, 2012 2:47:26 AM

Do this, I found it somewhere

Go to Documents/My Games/Borderlands 2/WillowGame/Config

Open willowengine.ini in notepad and search for DynamicShadows under [SystemSettings]. Change it to false will give you your 60 fps back. Had the same with the annoying drops to 30 but this pretty much eliminated it. Smooth as butter.
September 22, 2012 6:10:46 AM

shinte122305 said:
I am getting the same exact thing on my PC i have the 7970 and i play all my games maxxed without a single error borderlands 2 at max settings runs perfectly smooth 60 FPS with vsync than all of a sudden in random zones i get frame drops and it stays low in the 25-30 than it randomly shoots back up when it feels like it and its annoying the hell out of me and i play skyrim, crysis 2, call of duty, battlefield all at perfect 60 frames so idk whats going on with this game......


I don't think it's an AMD issue.
i7 980 @ 4.67ghz
12g Kingston HyperX
GTX 590

I easily surpass the specs to run on ultra.
I'll run 100+ without vsync or frame locks.
Constant 60-62 with frame locks or vsync.
The strange thing is, some of the least graphical challenging areas (well, what appears to be) will cause a drop down to 25-40 for no apparent reason, then boost back up again when I walk away. I believe it's a software issue or a coding issue. Hopefully it will be fixed soon.
September 22, 2012 2:09:53 PM

Quote:
Open willowengine.ini in notepad and search for DynamicShadows under [SystemSettings]. Change it to false will give you your 60 fps back. Had the same with the annoying drops to 30 but this pretty much eliminated it. Smooth as butter.


I did it but the framerate problem isn't solved with it.
Changing other settings or lowering the video doesn't help.
It's annoying as hell since i have to quit the game and restart it.

My Pc:
940 BE
8 GB
AMD 7870
September 24, 2012 8:25:46 AM

Same problem, Settings all on high (AA x4), don't see any reason why this game would decide to decrease so dramatically during battles.

Sys specs

Intel i7 950@3.06ghz
Corsair Vengeance DDR3 16GB
1x Gigabyte Radeon 6970
1x Gigabyte Radeon 6950 flashed
Mobo: Asus P6X58D-E
PSU: Corsair HX850w

Have not experienced this with BF3
September 24, 2012 10:46:22 AM

have the same issue:

My Laptop
Intel Core i7 980x (desktop CPU)
12 GB RAM
2x Nvidia GTX 580m SLI enabled
September 24, 2012 5:28:30 PM

Well, I replaced my phenom ii with a 3570k and my problems with borderlands 2 went away. Same thing with prototype 2. Steady 60fps with no drops.

Not sure if it was the recent update or the hardware change, but I no longer have my original problem.



Thank you to all the people who tried to help me with this problem.
September 24, 2012 5:51:32 PM

These were my old specs:

Phenom II 955 @ 3.7Ghz
Asus M4n82 Deluxe Mobo
4GB DDR2 800Mhz
Gigabyte GTX 670 Windforce
Ultra LSP-650W PSU

New specs should be in sig
September 24, 2012 6:37:05 PM

Hmmm. Those processors, along with those high end cards make me suspect of a combination of two issues:
CPU bottleneck and game issue. Phantom CPUs do quite some bottleneck to the 670, so OCing it would be a parcial solution. Substituting the CPU would be ideal. And about the game, that can't be solved until new drivers and/or a new version of the game comes out that solves this.

Just my two cents.
September 24, 2012 8:52:56 PM

Rise and Shine said:
Hmmm. Those processors, along with those high end cards make me suspect of a combination of two issues:
CPU bottleneck and game issue. Phantom CPUs do quite some bottleneck to the 670, so OCing it would be a parcial solution. Substituting the CPU would be ideal. And about the game, that can't be solved until new drivers and/or a new version of the game comes out that solves this.

Just my two cents.



There's no doubt in my mind that my old phenom was bottlenecking my 670, what's wierd is that the cpu wasnt being fully utilized in game (only %50).
October 1, 2012 6:00:02 AM

If you shoot and your fps drops, try to set PhysX settings to "low". PhsyX is a Nvidia feature.

System: i5 2500k, 8gb 1600, 7970 OC

Runs perfectly. It only drops some fps if PhysX set to high^^

Hope it helps you :D 

Greetings
October 5, 2012 1:35:43 AM

Hi,
Im having the same problem and although my system is a bit older EVERYTHING RAN SMOOTH until a day ago. I could run everything at max and still happily get 30-60 fps.
Now for some random reason framerates just start dropping like crazy never to return... I overclocked my 9800 GT a tad trying to compensate and was getting 100+ FPS but as soon as combat started framerates would drop to unplayability and even in the menu would hover around 22 FPS which is garbage. Not sure what has happened to the game but even with everything lowered its still doing it. :pt1cable: 

Phenom II 955 @ 3.5
16gb 1600 ddr3
MSI Nvidia 9800GT
MSI NF980-G65
everything is up to date drivers etc just updated a week ago.

I AM BAFFLED BC IT JUST STARTED DOING THIS YESTERDAY!!!!! WTFFFF!!!!!!!!
October 6, 2012 5:29:51 AM

Try software orochi-ceg.Google it, but use it at your own risk. it has helped a few...
October 6, 2012 4:06:44 PM

vintech82 said:
Do this, I found it somewhere

Go to Documents/My Games/Borderlands 2/WillowGame/Config

Open willowengine.ini in notepad and search for DynamicShadows under [SystemSettings]. Change it to false will give you your 60 fps back. Had the same with the annoying drops to 30 but this pretty much eliminated it. Smooth as butter.



i will try this..


* Edit:

In first instance this didn't do so much, so what i did was to make the vield of view smaller capped the FPS at 60 and turned off a lot of wistle and bells and this seems to make a difference.

Weird thing is i have no issues with other games when i turn these whistles and bells.
Anyway thanks man,you made investigate my issue further, haven't been playing much games lately so no biggie i will play it now to see if i can get into it.

Cheers.
October 7, 2012 12:36:41 AM

After research on this topic i have found that thousands of people are having the exact same problem and the same fps (25-30) problems. alot of people have found its a bug with the view distance setting in the video settings of the game. a quick fix for this is to go into settings (while your having the problem) and change the view settings to low go back to your game run around for 3 seconds and change the view settings back to your normal configuration. I guess this is something that we alll will just have to wait for 2k games to patch. good luck and i hope this helps!

~Peacekid2
October 7, 2012 5:27:11 PM

I get FPS drops when looking in certain directions in certain parts of the world. CPU usage never goes higher than 50% so I'm guessing the game only takes advantage of 2 cores? Is the game just not optimized well or is my i5 3570 not powerful enough?
October 10, 2012 5:08:10 PM

This seems to happen when you have multiple objects in both short and long distances. It does not have much to do with GPUs, especially those from AMD. Lowering PhyX from HIGH to LOW helps a bit but really not much. On my platform, overclocking the CPU seems to be more effective in reducing this problem than overclocking the video cards.

CPU: Intel i7-980
Motherboard: Asus Rampage III Formula
RAM: Corsair Vengeance 4GB * 3 1600 MHz
GPU: eVGA GTX 570 HD SC * 3-way SLI

The default clock of my CPU is 3.3 GHz. As I crank it up to 4.6 GHz, a lot of the lag problems are gone. But that's not to say that they are forever gone. During intense battle with many robots with objects at far distances the FPS still drops to around 30. It's probably an issue of the game or the engine.
December 28, 2012 7:55:31 AM

I had run into an issue with BL2 running pretty bad. I had been playing BL2 on my laptop for a while using XP 64-bit and everything was running fine. I moved my game to my "D:\" drive and my saved game data so I could move it back out when I went to try Windows 7. When I was in WIN7x64 it was running a bit better, but I decided to go back to XP for a few reasons. When I copied my save game from when I was playing in 7, it started running really bad in XP64. I couldn't figure out for the life of me what the heck happened between Win7 and going back to XP.

When I found this forum and I saw people talking about editing the config files I got an idea. It's possible if the game sees a change it will alter the config for newer specs, but does not revert them back in an opposite situation causing the game to then run slow. I simply deleted ALL of my config files obviously keeping my save game status and entering back into the game. The only thing I had to do was reset my graphics settings. It even kept my controls which was awesome!!! After doing this my framerate issues went away and I played for 2 hours straight! I also use an Nvidia Quadro FX1600M and if I leave Physx on it runs bad from that as well. I go into my Nvidia control panel and set all physx to CPU as though to disable it and the game runs great for me!

So bottom line, my solution was to disable physx or set it purely to CPU in the Nvidia control panel and delete all of the config files in "My Documents\My Games\Borderlands 2\WillowGame\Config\*.*"
January 26, 2013 9:08:22 PM

i have the same issue when running this specific game, borderlands 2. Ive tried lowering game settings and changing nvidia driver settings but it doesnt seem to go away.

Here are my specs.

amd fx-8350
asus m5a97 R2.0
MSI nvidia gtx 670
corsiar hydro series h55
intel 330 120gb solid state drive
kingston hyperx blu 1600mhz 4x2=8gb 16total
wd hard drive 1tb
January 27, 2013 7:08:13 PM

I find when I run Fraps that my FPS doesn't drop AT ALL! Without fraps I got 60 frames but randomly I would get 30 and it got annoying...With fraps it runs fine with no drops. Maybe it stops the bottleneck in the Cpu or something.
!