Really strange PC problems

So I have a custom build PC (I built it about a year ago), and recently, I've been having some odd problems.

-When the PC is asleep, and the monitor is off, if any program starts to do something, there is a loud grinding noise. if I let the noise persist without waking the computer, eventually, the PC will not wake, and I need to reboot manually.

-I get pretty bad framerates for my hardware. For example, I can't even run WoW on medium, or games like Torchlight, a game that requires basically no power to run.

-Sometimes, while playing games, either colored stripes fill the screen needing a reboot, or the game crashes and an error pops up about how the graphics driver crashed.

My build:

AMD A8-3850 overclocked using AMD's integrated tool to 3.2GHz
XFX HD 7850 Double Dissipation GPU overclocked to 975/1250 using AMD's integrated tool
A75F-A Black Edition Mobo
2 HDDs, both sata, 7200RPM, one is 300GB and one is 700GB
4GB RAM (I think Corsair Vengeance)
Windows 7-32 Bit
Hec Zephyr MX750, 750W
6 answers Last reply
More about really strange problems
  1. Try removing both overclocks and see if it fixes it.
  2. also check the fan on the gpu, because the glitchy graphics hints to that.
  3. Removing the overclocks doesn't do anything, and the fans are fine, I manually changed the fan speed to 100% and it ran fine, however the FPS issues did not get fixed that way.
  4. it is suggesting driver issue or gpu problem....whts ur ver of catalyst??.7850 is new one have u using any other gpu before that???
  5. My Catalyst version is 12.8. I WAS using a different gpu before this one, however I completely reinstalled the drivers for the new one. Also, yesterday, I found something really strange; the GPU usage levels stay around 20%, leading me to believe it isn't even close to performing how it could.
  6. Amadeus said:
    My Catalyst version is 12.8. I WAS using a different gpu before this one, however I completely reinstalled the drivers for the new one. Also, yesterday, I found something really strange; the GPU usage levels stay around 20%, leading me to believe it isn't even close to performing how it could.


    the former gpu, was that of nvidia???
    ok what i want to tell u that there is a chance that your former driver wasn't installed properly so u can try following steps and can do clean install of catalyst ...and if u r worried about registry then u can backup registry files...follow steps..they surely help u..


    Start>control panel>uninstall a program>click on Amd catalyst install manager>click uninstall ALL amd sofware>follow the steps.reboot it ..

    then start ur pc in safe mode...
    run driver sweeper software in administrative mode....u can download it from following link
    http://www.guru3d.com/content-page [...] eeper.html

    run this software...(in safe mode with run as administrator)
    it allows u to remove all left over driver files..which might be interfere with new driver installation so remove the files which u wanted...
    so now u r clear of all old driver files .now start it and do fresh installation of latest amd driver...at present it is catalyst 12.8...
    then tell me if it works or not....
Ask a new question

Read More

PC gaming Games Video Games