Low FPS in Saints Row: The Third on a decent PC.

Hey, Mike2012 just bought Saints Row: The Third. Have to say I'm disappointed in the performance. Seriously though.

This is my setup:
Microsoft® Windows® 7
Dual Core
4GB System RAM or more
HD 7750
DirectX® 11
10 GB HDD space
100% DirectX® 9.0C compliant sound card or equivalent onboard sound
Online Steam Account
DVD ROM (for physical copy only)

Here are the recommended settings:
Microsoft® Windows® 7
Any Quad Core Processor (Intel® Core i5 or AMD Phenom™ II X4) or 3.0+ Dual Core CPU
4GB System RAM or more
1GB Video RAM GPU w/ Shader Model 4.0 support (NVIDIA® GeForce® GTX 400 series or better, ATI Radeon™ HD5000 series or better)
DirectX® 11
10 GB HDD space
100% DirectX® 9.0C compliant sound card or equivalent onboard sound
Online Steam Account
DVD ROM (for physical copy only)

Now, I know I don't have a Quad Core, but should I really be getting such a crap FPS?

No matter if I turn the graphics settings on low or ultra, I get pretty much the same FPS. 30fps most of the time and it'll even drop into the 20's when skydiving. I could put it at 1600x900 ultra, 1280x720 lowest settings, it's still the same.

This is in DX11 mode.

I mean I know I have a Dual Core, but I'm disappointed I can't even get 60fps on low.

Low or ultra, doesn't matter, it'll dip into the 20's occasionally.
3 answers Last reply
More about saints decent
  1. Saints Row the Third has issues with pretty much all AMD cards made in the past four years (4000, 5000, 6000, and even some 7000 series cards) Regardless of settings the game dips to 30 FPS or lower when outdoors. There has thus far been no fix for it from either AMD or Volition. At this point, I doubt there will be. If you really want good performance in this particular game, you're probably going to have to get an nvidia card.

    It is a horrible mess, and Volition should have just outright stated they weren't supporting AMD at all, rather than selling a game that is broken for half the PC audience.
  2. I f'n hate that ****. This happens all the time and it's related to the game being a console port. It's nothing to do with your hardware, basically the game is doing a vsync at 30fps because it's not properly QAed for a PC. This is a common problem you will come across in many games. This problem gets worse if you use a television as a monitor, as 1080p will often trigger a 24hz vsync. Here's a few different things you can try:
    1. Use a refresh locking program (ati tray tools has one, rivatuner has one called d3doverider, MSI afterburner has Rivatuner in it) These are the first choice since they work for many titles.
    2. Try making a custom resolution in CCC like 1920x1072 @ 60hz. This may throw off the mis-detection of refresh rate.
    3. Try turning off vsync in CCC and in the game. If you have tearing after that then try to control that with a refresh locker instead.
    4. Try changing the DX mode to something lower like 9 or 10 instead of 11. I have seen that affect it too.
    4. Google is your friend, I am sure other people are having the same problem, I am sure there's a good answer out there.
  3. sorry this is a bit late of reply..

    i have hd7750 1 gig ddr5 video card..

    i played the game, high, highest, and lowest settings, noticed there was no improvement in gameplay or fps.. then i noticed i was opening the directx 10 launcher of saints row 3..

    then i tried the directx 11 launcher, made all the video settings at highest, only did OFF the HDR/motion blur option, coz motion blur is not good anyway...

    i now had 30-40 fps even in cities and explosions, and game is very smooth compared to before.

    also important, make the VSYNC option OFF
Ask a new question

Read More

PC gaming Video Games