Remote Assistance won't open

It has always worked before, a couple of weeks ago it stopped.

When I am requested remote assistance I can accept, it shows it as accepted, my friends remote assistance has loaded up though nothing happens on mine. I check task manager, look at processes and see that the Windows Remote Assistance has actually been started, though nothing comes up.

I have disabled my firewall and anti virus while doing it to no avail.

This happened both on my old windows messenger, and the new Windows Live Essentials 2011 Messenger (which by the way, is absolutely horrid).

Is there any way to find an installer for remote assistance to remove the component then reinstall it? Or any other way I can fix this problem?

Please ask if any more information is required.

Thanks for the help :-)
2 answers Last reply
More about remote assistance open
  1. Any chance you changed something with your Internet connection configuration?
    (router/ISP) you have second computer on the network that you can test on?
    Any way try "teamviewer" it is much better.
    http://www.teamviewer.com/index.aspx
  2. arkadi said:
    Any chance you changed something with your Internet connection configuration?
    (router/ISP) you have second computer on the network that you can test on?
    Any way try "teamviewer" it is much better.
    http://www.teamviewer.com/index.aspx


    No I haven't and it works on my laptops. Thanks but I'm not asking for an alternate program, I'd rather not have to have someone download software every time I need to give them a couple of minutes of help.
Ask a new question

Read More

Windows 7