Sign in with
Sign up | Sign in
Your question

Low fps, good rig

Last response: in Video Games
Share
October 3, 2012 3:58:07 AM

Hey all,

So I run BF3 and Skryim on ultra settings with good 35-60fps, high settings like 50-60fps. But for some reason when I run Borderlands 2, my fps is 60 when there is no fighting, but as soon as a battle starts it can drop to like 18. I tried putting all the settings on low, and that made it drop to only about 23 instead. There is not much difference between ultra settings and low settings. What could possibly be causing this issue? I deleted all my temp files, messed around with the settings in game, etc. I also had an fps issue with GW2, but I overclocked my cpu to 3.5ghz and upgraded my RAM and that helped out a lot.

Long story short, I believe my rig should KILL borderlands 2 but it actually sucks. Could it be their software blows since it is multiplatform? Does AMD just suck? Any advice on how I can fix this issue?

I heard some stuff about hard drives and how it may slow games down, but if that was an issue it would affect all my other games right? And as I said I run those games on ultra settings just fine

I would really appreciate any advice

Motherboard: ASUS M4A78T-E
CPU: AMD Phenom xII 945 3.0Ghz (OC to 3.5)
GPU: AMD Radeon HD 6970 2.0Ghz
RAM: 8g of DDR3 running at 783Mhz due to OC

More about : low fps good rig

October 3, 2012 8:44:19 AM

I don't think its you, I think it BL2, it runs the worse on mine and my mates PC's too.

Try turning the network status to offline, worked wonders for me.

Also you can allter the willow file, I think dynamic shadows is a big drain.
m
0
l
October 3, 2012 9:58:26 AM

Well AMD does suck, but not to the extent that it would cause that kind of performance hit... there is a setting for framerate smoothing that you can access from the launcher. I don't entirely understand it, seems like some kind of V-sync style function. I just set mine to 60fps (to mirror V-sync) and it seems fine. Default setting was something strange like 22-62fps.
m
0
l
Related resources
October 3, 2012 5:54:02 PM

The simplified explanation with Vsync FPS jumping is that when enabled, duplicate frames are not counted when calculating FPS. Only unique frames are counted.

Example, 60 FPS simply means 60 frames were created by the GPU over a 1 second timespand. That does not indicate how many frames were actually sent to the display. Its possible you could see somthing like this really happening:

GPU creates frame #1 (time: ~8ms)
GPU creates frame #2 (time: ~8ms)
Display fetches latest created image
(~16ms - no new frame created)
Display fetches latest created image

Expand this to 1 second, and you get 60 FPS, when only 30 would be actually sent to the display. But FRAPS records 60 FPS, but when you enable Vsync, you wonder why you lost half your FPS. The only thing changing if whether or not you count duplicate frames.


So in short: Is the game smooth or not? FPS is a horrid benchmark...
m
0
l
October 3, 2012 6:12:17 PM

Blimey... and I thought it was just as simple as frames/sec! We need a new benchmark then. I'd agree at the end there - if it isn't jerky and unresponsive, there's not really a problem.
m
0
l
October 4, 2012 12:25:43 AM

It's Physx. It's broken. Turn the physics to low/off, and you'll be fine.
m
0
l
October 4, 2012 3:01:43 AM

Hey guys,

Thanks for all the responses and support. A lot of great suggestions here....

I already uninstalled physx, tried playing without it, and still had the same issues. Then, I installed the new version, same problem.

I will try the Vsync solution but I don't think it will work :( 

Thanks again for all the help, and any other suggestions are always welcome!
m
0
l
October 4, 2012 3:10:25 AM

Wait a minute guys: I think my problem was I failed to restart borderlands 2 when I made adjustments to PhysX. I am playing now at the same spot that was kill FPS last night and everything is MUCH better. Either that, or the Vsync and 60 fps cap worked. I turned off Vsync and there seemed to be no change, so I think it must be the physx. Thanks again for all the help
m
0
l
!