Sign in with
Sign up | Sign in
Your question

GTA IV won't run on a good rig

Last response: in Video Games
Share
October 13, 2012 5:29:32 PM

Hello! So, I build my new PC a few days ago. Before that I had a Quad Core Q660 2.4 GHz, a Nvidia 9800 GT and 4 GB of RAM. The game ran "smooth" enough on almost maximum settings. When I say smooth I mean about 20-30 FPS with a lag spike now and then, but it was playable.

So, my current rig is: i7-3770 3.4 GHz, Radeon HD 6950 2GB and 8GB of RAM. Maxed out, it runs at barely 5-10 FPS. When I put everything on minimum (which uses 200MB of my 2GB of VRAM) my counter shows above 100 FPS but drops to 10 FPS every 2 seconds making it unplayable.

I'm not sure if this is my hardware problem or not because I just built this system yesterday and I didn't play any other games on it yet, and decided to use GTA IV to test it out (didn't go as planned as you can see).

So, what's the deal?

More about : gta run good rig

October 19, 2012 7:27:18 AM

Driver sweeper. Remove the nvidia drivers and install the latest radeon drivers
October 19, 2012 7:48:01 AM

You misunderstood me. It's a new system. I don't have any nvidia drivers to uninstall. I was just telling you how GTA IV ran good on my old system, but it will barely run on my new, much better, system.
Related resources
October 19, 2012 9:04:05 AM

Maybe your new system is overheating. Getting more cooling fans might fix the problem, but before that check the temperature of some components while you are gaming to be sure overheating is the problem. Hope this helps. :sol: 
October 19, 2012 9:55:27 AM

Did you install at least 1.0.4.0 patch for the game? If not, there's your issue.
October 19, 2012 11:21:27 AM

It's not overheating (at least according to SpeedFan), and I did install the latest patch :p 
October 19, 2012 4:47:11 PM

have you gone into bios and disabled your igpu? that could be the issue
October 20, 2012 5:22:01 AM

Flint, nice idea, haven't thought about that. What are you connecting the monitor to: your motherboard or your graphics card?
October 20, 2012 7:15:38 AM

The monitor is connected directly to the graphics card.

And uh, I'm not sure I can find the iGPU option in my BIOS settings. I have a Gigabyte Z77X-D3H motherboard.
October 21, 2012 1:45:50 AM

its mostly to do with unsupported hardware... theres have a similar problem with crysis in that it often runs worse on a quad core than a dual. even though it was designed for a quad and uses 3 threads. but put it on an 8 thread 4core cpu and it crumples perfomance wise. turn off hyperthreading and performance comes back... you may want to try that with GTA4...
October 21, 2012 2:03:17 AM

definitely get the patch 1.0.4.0
it'll fix your problem..my friend played gta 4 on lowest possible settings with 800*600 resolution on a GTX 680 at frame rate of 10-20...he doesn't consider graphics while gaming but i thought it as a serious issue.....so after a lot of research i made him apply the patch and then everything went smooth onwards....
Remember...gta 4 is the worst console port i have ever seen....
hell lot of problems.....
October 21, 2012 2:45:53 AM

Hexit may be onto something it might be the hyper threading needs to be disabled in BIOS
October 22, 2012 10:36:04 PM

Well, (completely accidently) I fixed it!

I gave up on the bloody thing a while ago, but today I was having some issues with Mass Effect 2. My game was crashing and I googled for solutions and the solution was to uninstall ASUS SmartDoctor and Gamer OSD (which were installed by default with my initial graphic card CD). People also said that when they uninstalled these programs, they got major preformance improvements. So, I did the same and it worked for me.

Out out curiosity, I loaded up GTA IV once again to see did the solution fix this as well, and my problem is gone! Running on max settings (except for the details etc., they're at 50) and at steady 50-60 FPS. Thanks to everyone who tried to help.
!