Sign in with
Sign up | Sign in
Your question

Skyrim using Integrated Graphics on Laptop

Last response: in Video Games
Share
October 22, 2012 12:27:29 AM

Hi I have a Samsung Laptop. Skyrim is choppy for me even in lowest settings. In Skyrim options, it only shows my Intel HD 3000 as a graphics adapter. It does not show my AMD Radeon HD 6490M. I've tried setting all my power settings to high performance in Catalyst Control Center and Windows. The settings still do not show my dedicated gpu and my game is still choppy. I couldn't find anything related to graphics in the BIOS. I tried disabling the integrated graphics in device manager, but that just blacked out my display. How do I get Skyrim to show my dedicated GPU?

Specs:
Intel® Core™ i7 Processor 2675QM
8GB RAM
AMD Radeon HD 6490M 512MB
October 22, 2012 1:58:27 PM

try going to advanced in BIOS. and you should see something like a multi monitor intergrated gpu or whatever that is called. turn that OFF. and then use main gpu as PCI-E. MAKE SURE U SET IT TO PCI-E. If you cannot find it, maybe your motherboard does not support that but i do not think so. But I am 100% sure that the thing is under ADVANCED tab.
m
0
l
a b D Laptop
October 22, 2012 2:11:03 PM

Oldmangamer_73 said:
You're not going to be able to play Skyrim on a laptop with an integrated GPU. You need a high end gaming laptop, or just buy a desktop with a dedicated GPU.


Did you even read what the OP asked?

ThatsMyNameDude said:
try going to advanced in BIOS. and you should see something like a multi monitor intergrated gpu or whatever that is called. turn that OFF. and then use main gpu as PCI-E. MAKE SURE U SET IT TO PCI-E. If you cannot find it, maybe your motherboard does not support that but i do not think so. But I am 100% sure that the thing is under ADVANCED tab.


He's using a laptop, so BIOS will not have that option.

@OP: I am not really sure how to help you, but if everything else fails, reinstalling windows should do the trick.
m
0
l
!