Sign in with
Sign up | Sign in
Your question

FPS Lag in every game

Last response: in Video Games
Share
October 24, 2012 3:36:14 PM

Hi, a few weeks ago my FPS rate dropped extremely to about 5-15 FPS. I have virtually no open applications in the background, although a bunch of processes.

Screenshots of GPU Z while playing about 10-15 minutes of Assassin's Creed: Revelations
https://dl.dropbox.com/u/49460192/gpuusage1.png
https://dl.dropbox.com/u/49460192/gpuusage2.png

Screenshots of the Nvidia Control Panel for AC:R
https://dl.dropbox.com/u/49460192/screens/171103697.png
https://dl.dropbox.com/u/49460192/screens/171219524.png
https://dl.dropbox.com/u/49460192/screens/171229436.png
https://dl.dropbox.com/u/49460192/screens/171236381.png

GPU Usage while idle
https://dl.dropbox.com/u/49460192/gpuusageidle2.gif
https://dl.dropbox.com/u/49460192/gpuusageidle1.gif

Screenshots of current processes running
https://dl.dropbox.com/u/49460192/screens/172708664.png
https://dl.dropbox.com/u/49460192/screens/172715862.png
https://dl.dropbox.com/u/49460192/screens/172720052.png

Specs
http://i.imm.io/J2Fd.png

Hope you can help me.

And yes, it is a laptop.

More about : fps lag game

October 24, 2012 5:54:52 PM

Have you tried defragging the folder of which ac is located in? What about reinstalling the game(because there could be corrupted files of such). Are your drivers up to date? If you have this game on steam then try verifying the chache integrity by right clicking the game on steam; go to properties, third tab is local files and you cand defrag, verify the integrity from there.

Hope this helps in one way or another!
October 24, 2012 6:02:19 PM

Oh an i forgot to mention, have a try and run some benchmarking tool like 3dmark and instead of using the settings through nvidia have a try using the in game options to see if it makes any kind of differnce.
October 24, 2012 6:13:43 PM

Thanks for your response, I am currently downloading the current drivers for my graphics card (I have an extremely slow internet connection). I'll also try defragging that folder. Thanks.
!