Sign in with
Sign up | Sign in
Your question

No Hard Drive detected on Ultimate x64 install

Last response: in Windows 7
Share
October 20, 2009 11:26:00 PM

im trying to do a clean install of Windows 7 Ultimate x64 on my dad's HTPC. disk boots fine and everything loads right until it asks me where to install Windows. no drives show up. i've tried 2 different 320GB Western Digital HDDs that work and are recognized by the system's BIOS. i even formatted them before the install. i've tried playing with the AHCI/IDE/SATA settings. also tried changing SATA ports but nothing makes a difference. the thing i can think of is that the DVD drive is connected by an IDE cable and the HDD is SATA. but i have done that on other computers and it wasn't an issue. anyone else having this issue? my exhaustive Googling has come up empty.

EDIT: just noticed that the HDD shows up when i browse for drivers. so Windows knows it is there but for some reason won't let me install to it.
October 21, 2009 6:40:25 PM

I installed on a new HD and it worked fine. All my drives are Sata. The only thing I can think of is maybe the HDs are formatted in a way that windows can't install to. Like maybe windows won't install to a FAT32 drive. Maybe you can try unformatting them on another computer. Wipe out all the partitions or something like that.
m
0
l
October 21, 2009 7:37:08 PM

before even putting the drive in the computer i formatted it as NTFS. i even took it out yesterday and double checked.
m
0
l
Related resources
October 21, 2009 7:47:38 PM

Disable AHCI or install the Driver from your MB disk.

From my MB Manual:

Making a SATA RAID/AHCI Driver Diskette
(Required for AHCI and RAID Mode)
To successfully install operating system onto SATA hard drive(s) that is/are configured to RAID/AHCI
mode, you need to install the SATA controller driver during the OS installation. Without the driver, the
hard drive may not be recognized during the Windows setup process. First of all, copy the driver for
the SATA controller from the motherboard driver disk to a floppy disk. For installing Windows Vista, you
first have to copy the SATA controller driver from the motherboard driver disk to your USB flash drive
and then extract it (see instructions on the next page). See the instructions below about how to copy the
driver in MS-DOS mode(Note). Prepare a startup disk that has CD-ROM support and a blank formatted
floppy disk.
Step 1: Insert the prepared startup disk and motherboard driver disk in your system. Boot from the
startup disk. Once at the A:\> prompt, change to your optical drive (example: D:\>). At the D:\> prompt,
type the following two commands. Press <Enter> after each command (Figure 1):
cd bootdrv
menu
Step 2: When the controller menu (Figure 2) appears, remove the startup disk and insert the blank
formatted disk. Select the controller driver by pressing the corresponding letter from the menu. For
example, from the menu in Figure 2:
• For Intel ICH10R1 SATA controllers, select 7) Intel Matrix Storage Manager 32 bit for Windows
32-bit operating system or 8) Intel Matrix Storage Manager 64 bit for Windows 64-bit.
• For GIGABYTE SATA2 SATA controller, select E) GIGABYTE SATA-RAID Driver 32Bit for
Windows 32-bit operating system or F) GIGABYTE SATA-RAID Driver 64Bit for Windows 64-bit.
Your system will then automatically zip and transfer this driver file to the floppy disk. Press <0> to exit
when finished.
m
0
l
October 21, 2009 8:28:55 PM

i've tried the motherboard's driver disk and it says no drivers were found. but like i said i can search the HDD i want to install to for drivers. so Windows recognizes the drive. it just won't let me install to it. and yes it is NTFS
m
0
l
October 21, 2009 8:41:54 PM

Disable ACHI and ACHI/RAID



m
0
l
October 22, 2009 4:00:16 AM

unfortunately the BIOS on this Intel board sucks are there really is no clear way to do that. when i go into "Drive Options" these are my options:

Use Automatic Mode (Enable/Disable)
Use Serial ATA (Enable/Disable)
ATA/IDE (Legacy/Native)
S.M.A.R.T. (Enable/Disable)

i have browsed through every option in the BIOS and there is no clear AHCI setting. i've tried switching ATA/IDE between Legacy and Native but no luck.
m
0
l
!