Sign in with
Sign up | Sign in
Your question

Crysis 3 MP Alpha question

Last response: in Video Games
Share
November 2, 2012 9:16:03 AM

Hey guys I'm pretty new to alpha testing but I am in the Closed Crysis 3 mp alpha.
I have a problem with loading textures.
The textures in-game are VERY VERY VERY LOW RES even though I have selected High res textures.
I tried graphics on high , very high , low , medium , etc. but same problem.
I just wanted to know whether others were having this problem.
Also is the the problem of the alpha version of the game and will be fixed later or is it a problem with my PC ?

More about : crysis alpha question

Anonymous
November 2, 2012 12:41:25 PM

Same here.. the textures looks like an ATARI Game

PC Specs:
GTX 570 @ 800/1600/1800
i5 2400 @ 3,8ghz
4GB RAM 1600mhz
Win7 32bit (bcdedit /set ..... userva 3072) works fine on any other game.
m
0
l
November 2, 2012 4:30:17 PM

So its not only me , thank god.
m
0
l
Related resources
November 2, 2012 6:37:21 PM

Weird.. Even though I am in low, the textures look really good. But don't expect much, it's just alpha. Expect nothing to work.
m
0
l
November 2, 2012 8:18:09 PM

I have the same problem :/  had this problem in RAGE also.. i have a geforce gtx 550 ti graphics card... :/ 
m
0
l
Anonymous
November 2, 2012 9:24:22 PM

dunno why but its only in Crysis 3... na if anyone knows how to fix this bug please let us know.
m
0
l
November 3, 2012 1:53:28 AM

gamingboy said:
Weird.. Even though I am in low, the textures look really good. But don't expect much, it's just alpha. Expect nothing to work.

What are ur PC specs?
m
0
l
November 13, 2012 12:28:41 AM

Best answer selected by ZakX11.
m
0
l
!