Sign in with
Sign up | Sign in
Your question

Problems running 2012 Need for speed Most wanted

Last response: in Video Games
Share
November 10, 2012 4:40:27 PM

Hi guys,

I am new to pc gaming and am having some difficulties pin pointing my problem.

Problem: When running Need for speed most wanted 2012 the entry scene of the game displays perfect however as soon as it switches to game play my colors get all distorted (mainly displaying red,green and black).. this does not happen all the time, when i drive through a tunnel the colors briefly go back to normal only until i exit the tunnel.

System Specs:
Intel i5 2320 3.0ghz, 64 bit, 1 Tb hd, p8B75-m/csm motherboard, 4 Gb ram, 350w psu, geforce gt530 1gb ddr3 (I am aware that is a entry level card, I have played skrim, max payne 3, darksiders 2, just cause 2 on medium settings without an issue)..

I concluded that my gpu must need an upgrade but cant seem to understand why it can play the games listed, so here I am wondering if someone can shed some light?

Thanks in advance for any help


P.s I do have the latest drivers installed.

November 11, 2012 7:14:41 AM

gamernewbie said:
Hi guys,

I am new to pc gaming and am having some difficulties pin pointing my problem.

Problem: When running Need for speed most wanted 2012 the entry scene of the game displays perfect however as soon as it switches to game play my colors get all distorted (mainly displaying red,green and black).. this does not happen all the time, when i drive through a tunnel the colors briefly go back to normal only until i exit the tunnel.

System Specs:
Intel i5 2320 3.0ghz, 64 bit, 1 Tb hd, p8B75-m/csm motherboard, 4 Gb ram, 350w psu, geforce gt530 1gb ddr3 (I am aware that is a entry level card, I have played skrim, max payne 3, darksiders 2, just cause 2 on medium settings without an issue)..

I concluded that my gpu must need an upgrade but cant seem to understand why it can play the games listed, so here I am wondering if someone can shed some light?

Thanks in advance for any help


P.s I do have the latest drivers installed.



In this case, the scenario for the setup seems to be under powered. What might be happening is the graphics card is being called to do an incredible amount of calculations, requiring more of your power supply, and at 350 watts, you probably going to have the artifacting that you are currently experiencing, and I would recommend something stronger power wise to at least keep your machine stable and not start malfunctioning or something worse. When it comes to a gaming pc, even for low to mid range, you should usually stick around the 500w mark, and if you want to see about replacing the existing power supply, try using something with less +12v rails, and more amps. (example: www.newegg.com/Product/Product.aspx?Item=N82E1681713902... a power supply that will power the components of your system and future parts of that setup adequately and its only 60 bucks or so)
m
0
l
November 11, 2012 7:17:43 AM

also the only tweaking I have even came across for that game is in "my documents/criteriongames and you find a file name config.nfs13save which can be modified to unlock the framrate and other things.

one more thing to consider is the graphics card might not have the adequate shaders or level of shader models to execute the game correclty, although im pretty sure you shold be good. if all else fails lower every thing detail wise, and keep the same resolution.
m
0
l
Related resources
November 13, 2012 12:48:03 AM

name_not_taken said:
also the only tweaking I have even came across for that game is in "my documents/criteriongames and you find a file name config.nfs13save which can be modified to unlock the framrate and other things.

one more thing to consider is the graphics card might not have the adequate shaders or level of shader models to execute the game correclty, although im pretty sure you shold be good. if all else fails lower every thing detail wise, and keep the same resolution.



Hi,

Thank you for the response.. I purchased a 750w Thermaltake psu in the event that I would have to upgrade my card. As soon as I get a minute, I will throw it in and see if it makes a different.

I believe the card requires 300w and 22 amps and has 96 shader processing units (not exactly sure what that means).. I am not exactly sure how to modify so that I can unlock the framerate either.

Something new to add, not sure if it is helpful or not but if I let the game sit without pressing anything the picture does clear up to where the distorted colors are mainly in the car.

thanks for your input and I will update when I have upgraded my psu..
m
0
l
November 13, 2012 1:34:34 AM

I couldn't wait, ended up throwing in the new psu.. Unfortunately there was no results. Any other suggestions ?

Thanks again!
m
0
l
April 25, 2013 10:44:00 PM

the solution is very simple ..disable 3d in the nvidia control panel .. and your problem will be solved ..

this happened cause by default 3d stays activated
m
0
l
April 24, 2014 2:19:14 AM

name_not_taken said:
gamernewbie said:
Hi guys,

I am new to pc gaming and am having some difficulties pin pointing my problem.

Problem: When running Need for speed most wanted 2012 the entry scene of the game displays perfect however as soon as it switches to game play my colors get all distorted (mainly displaying red,green and black).. this does not happen all the time, when i drive through a tunnel the colors briefly go back to normal only until i exit the tunnel.

System Specs:
Intel i5 2320 3.0ghz, 64 bit, 1 Tb hd, p8B75-m/csm motherboard, 4 Gb ram, 350w psu, geforce gt530 1gb ddr3 (I am aware that is a entry level card, I have played skrim, max payne 3, darksiders 2, just cause 2 on medium settings without an issue)..

I concluded that my gpu must need an upgrade but cant seem to understand why it can play the games listed, so here I am wondering if someone can shed some light?

Thanks in advance for any help


P.s I do have the latest drivers installed.



In this case, the scenario for the setup seems to be under powered. What might be happening is the graphics card is being called to do an incredible amount of calculations, requiring more of your power supply, and at 350 watts, you probably going to have the artifacting that you are currently experiencing, and I would recommend something stronger power wise to at least keep your machine stable and not start malfunctioning or something worse. When it comes to a gaming pc, even for low to mid range, you should usually stick around the 500w mark, and if you want to see about replacing the existing power supply, try using something with less +12v rails, and more amps. (example: www.newegg.com/Product/Product.aspx?Item=N82E1681713902... a power supply that will power the components of your system and future parts of that setup adequately and its only 60 bucks or so)


hey guys ive actually been through that problem it just got wrose some how here is what i did i reinstalled the game and when it started everything was normal and perfect but when it came to the Aston martin that is the point where you start to drive evryting changes i mean the the sound strats to response very slowly and the game goes very slow in a suctucky type mode when i accelerate there are breaks in the sound half of it is heard could you please help me!! thank you
m
0
l
!