I can't max Crysis? Really?

I'm shocked that this new system I've built can't play Crysis on the highest settings (no AA) with constant smooth framerates. I just put two EVGA GTX 660 Ti cards in for Sli, and I STILL can't max it. Really?!

Here are my parts:

- COOLER MASTER HAF 932 Advanced
- Nvidia EVGA GTX 660 Ti (1 of 2)
- Nvidia EVGA GTX 660 Ti (2 of 2)
- GIGABYTE GA-990FXA-UD3 AM3+ AMD 990FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
- CORSAIR HX Series HX750 750W
- AMD Phenom II X4 955 Black Edition Deneb 3.2GHz (Overclocked to 4.0GHz w/ Corsair H100)
- Corsair H100 liquid cooling
- Corsair Vengeance 8GB DDR3 RAM 1600
- LITE-ON Black 12X Blu-ray Burner
- COOLER MASTER R4-L2S-122B-GP 120mm 4 Blue LED Case Fan (x3)


Am I just doing something wrong, or am I just never going to be able to run it smoothly? It will run smoothly when facing certain directions, but when I am in large areas such as the Korean Village, or facing such an area, the frame rate drops horribly.

If anymore information is needed, I'd be happy to provide it. I also do plan on switching my Gigabyte motherboard for an ASUS board, and switching my AMD processor for an Intel unlocked Ivy Bridge Core i5 next month.
7 answers Last reply
More about crysis really
  1. Why would you switch your processor?

    The i5 2500k (Sandybridge, I know) is only 25% faster than the 965. Double the price, too.

    Try only using one card with Crysis.

    Try updating your drivers.

    Check if you have AA enabled in your NVidia's equivalent of the CCC.

    Try setting Crysis to only use 3 and/or 2 cores.

    Try de-fragging.

    Try closing down any unnecessary processes.


    Though, to be honest, it sounds like a driver issue, or that Crysis doesn't support SLI.
  2. MajinCry said:
    Why would you switch your processor?

    The i5 2500k (Sandybridge, I know) is only 25% faster than the 965. Double the price, too.

    Try only using one card with Crysis.

    Try updating your drivers.

    Check if you have AA enabled in your NVidia's equivalent of the CCC.

    Try setting Crysis to only use 3 and/or 2 cores.

    Try de-fragging.

    Try closing down any unnecessary processes.


    Though, to be honest, it sounds like a driver issue, or that Crysis doesn't support SLI.


    Thank you for your reply. Here's the processor I would be upgrading to if I did:

    http://www.newegg.com/Product/Product.aspx?Item=N82E16819116504

    I know Crysis supports Sli because on a single card, it's actually worse..

    How can I set it to use fewer cores?

    And I've tried the other things.

    Thanks again.
  3. Your CPU is a bit weak for crysis (since crysis is a bit poorly coded unfortunatelly).

    First of all, set physx to be run on the GPU! Withouth this, your CPU is dead meat, esecially when there is action going on (by any chance does frame rate drop more often then? :D).

    Also, you might want to lower sound settings in crysis, as those do have issues sometimes, and since you dont mention it, are you running on "onboard" audio? That regulary takes some CPU power as well.
  4. what frame rate are you getting?

    enter this command into the console

    r_DisplayInfo = 1

    I have an i7 with 2 570's and couldn't max it, its just a poorly made game like Metro
  5. cats_Paw said:


    First of all, set physx to be run on the GPU! Withouth this, your CPU is dead meat, esecially when there is action going on (by any chance does frame rate drop more often then? :D).

    Also, you might want to lower sound settings in crysis, as those do have issues sometimes, and since you dont mention it, are you running on "onboard" audio? That regulary takes some CPU power as well.


    Physx is set to run on the second GPU.

    I have onboard audio, but I run my sound from a Creative USB sound card.

    Thanks for the reply.

    cats_Paw said:


    Darnit.

    Anonymous said:
    what frame rate are you getting?

    enter this command into the console

    r_DisplayInfo = 1

    I have an i7 with 2 570's and couldn't max it, its just a poorly made game like Metro


    I play with Vsync on, otherwise I get a ton of tearing, and it's really distracting.

    I get 50FPS normally, and once I'm in the Korean village, I get anywhere between 30-45FPS, but it usually hangs around 30-35 frames. I know most might say that 30FPS is perfectly okay. But given that I'm used to 50+ frames on all of my other games (Witcher 2, Metro 2033, etc), it's very noticeable for me.

    When the Koreans start looking for me in the village when the tanks are about, it drops to 20-25 frames! To me, that's just unwatchable.

    I can actually play Metro maxed out on DX11 with 50+ frames all of the time.
  6. To change affinity, use task manager, find Crysis' process, right-click "Set Affinity", tick the boxes.

    If you find that works or that Crysis crashes after launching task manager, get PriFinitty, it'll do it automatically for you.
Ask a new question

Read More

PC gaming Video Games Product