Sign-in / Sign-up
Your question

Weird lan problem in C&C Generals, any ideas?

Tags:
  • PC gaming
  • LAN
  • Games
  • Video Games
Last response: in PC Gaming
November 12, 2012 10:47:45 AM

I picked up copies of CC Generals (the one that comes with Zero Hour) to introduce my wife to RTS on the lan. I used to play this one a ton years ago.
Everything seems to go fine over the lan. I can create a game in the lobby, she can join and accept. I see it count down to start on both screens. Then it launches the loading screen with the two bars that fill up before the game beings. I notice on her computer, both bars fill up and the game starts. On mine, only my bar fills up and it won't start. It doesn't matter if she hosts the game, or I do. Same result.
I've tried it using wireless, and directly wired to the router. I've forwarded my ports, shut down windows firewall, shut down antivirus, etc. No luck. Any ideas or suggestions?

Would using something like Hamachi help?

More about : weird lan problem generals ideas

November 12, 2012 3:50:41 PM

if you have an actual LAN at home, there's no reason to bother with hamachi.

Have you tried reinstalling the game on your machine?

Can you load a single player game? does it load fine?
m
0
l
November 12, 2012 9:09:11 PM

I didn't know if hamachi got around any issues better. I've reinstalled on both machines, and yes both can play single player. It loads fine, and other games work over the lan.
Would a direct crossover cable get around anything causing it or is it the same as the lan? I've tried disabling everything I can think of.
m
0
l
November 17, 2012 1:58:49 AM

Okay, disabling the wireless card worked, I got the suggestion on another forum but wanted to post here in case anyone is ever looking for a solution. (Her's is a laptop, we connected with a cable). BUT, the weird thing is, I tried unhooking the cable and re enabling the wireless. (Just to confirm that was it.) Now, it works over wireless. Go figure. It must have lined out something.
m
0
l