Sign-in / Sign-up
Your question

Black Ops 2 Lag

Tags:
  • PC gaming
  • Lag
  • Games
  • Video Games
Last response: in PC Gaming
November 13, 2012 1:19:15 AM

Hello all,

So i have black ops 2 and i really enjoy it, however every single game i get lag. Sometimes i get 1 spike sometimes the whole game is laggy. I'm sure it has something to do with my internet as my pc is high end. I'm using a wireless adapter instead of a ethernet cable but this does not happen with any other game i have like BF3, Call of duty mw3 etc. Anyone know what may be the problem? should i try run an ethernet cable? My pc specs are i7 2600k, 8gb Ram, nVidia gtx 560, win 7 pro. Any help would be appreciated.

Thanks in advance.

More about : black ops lag

November 13, 2012 3:50:35 AM

If you're running BF3 and MW3, it can't really be a PC or a net issue, since both those games require a good connection and good PC specs. Your specs seem fine. Check the settings of Black Ops 2 and see if something isn't right. Also, check your anti virus and firewall. While Black Ops 2 may not be blocked, it still may be scanned. Some anti virus softwares constantly scan and monitor incoming and outgoing connections of certain applications. If this is happening for Black Ops 2, it'll definitely lag.
But besides this, it doesn't sound like it's a problem on your end. Check the servers you're connecting to. Make sure you connect to servers in your region, for lag free games. If you're in the States and connect to a Chinese server, it can lag a lot. All this will be in your game settings, I told you earlier about. Take a look. :) 
m
0
l
November 13, 2012 3:18:35 PM

Are you talking about lag as in you can move and look around, or the entire thing frezes for a little while where you can't do anything what so ever?
m
0
l
Related resources
Can't find your answer ? Ask !
November 13, 2012 11:45:06 PM

try turning down your graphic settings. that's the obvious one. also check your background applications/processes and end the ones that aren't necessary. you can also set black ops 2's priority higher in task manager
m
0
l
Anonymous
November 17, 2012 6:33:35 AM

oabornezo said:
Hello all,

So i have black ops 2 and i really enjoy it, however every single game i get lag. Sometimes i get 1 spike sometimes the whole game is laggy. I'm sure it has something to do with my internet as my pc is high end. I'm using a wireless adapter instead of a ethernet cable but this does not happen with any other game i have like BF3, Call of duty mw3 etc. Anyone know what may be the problem? should i try run an ethernet cable? My pc specs are i7 2600k, 8gb Ram, nVidia gtx 560, win 7 pro. Any help would be appreciated.

Thanks in advance.

hallo guys, i have the same problem as the oabornezo.... i am really disappointed and i don't know what to do... any idea? i saw something for the task manager can you please explain how to do that?

Thnaks guys
m
0
l
November 17, 2012 11:07:09 AM

press ctrl+alt+del and go to start task manager. Go to processes and see what else is running that's using up a lot of memory.
m
0
l
December 14, 2012 11:02:18 PM

I got almost the same pc specs as u, though better, and at first i had some similar lag

what i did to fix that was turning depth of field to low, ambient oclussion to off, AA 2x MSAA, fxaa to off, but high textures, and well the rest is up to u. i personally like to set most things to med/low even though i got a very good system.
also consider setting an fps limit (a good one is either 90 or 125), u can do that in options.


(might also wanna update nvidia drivers as well http://www.nvidia.com/Download/index.aspx?lang=en-us)

if that doesnt help, check maybe ur pc is overheating, google pc temperature
good temp while in game: cpu ~40 - max 65/70*C, GPU 60-80*C (my sli 560ti reach 80*C sometimes)

if it is connection lag, then u might wanna go to find game and when u have to pick a gametype, press S or some other key, i dont really remember now, it will bring up connection type preferences, set it to Best.

good luck fixing ur lag.
m
0
l
April 12, 2013 8:08:14 AM

You can try Gamebooster for shutting down unnecessary background programs.
m
0
l
April 12, 2013 8:45:45 AM

go into the games settings and turn off shader warming (may have to go into the config file for this 1) and in the games options select textures and set them manually to native rather than extra. you should easily be able to max out the games settings with a 560 ti and still get 100+fps. so its unlikely that its your pc but rather the ingame settings letting you down.
m
0
l