Closed

(Micro) Stutter in almost every game!

So im getting pretty frustrated with this problem ive been having for months now: In almost all new games and some older, i get this jidder/judder close to microstutter almost constantly. I know microstutter only occurs with multiple GPUs and since im only running a single GPU setup its not the correct term, but my problem and M-S looks very alike. Ive tried many things to fix it, with no solutions. Ive replaced my GPU with a new identical model, same with motherboard, and RAM as last solutions and the problem still persist. Please, i really need some advice!

Thanks in advance!

GTX 680
I7 2600k @ 3,4Ghz
16GB DDR3 RAM
MSI z77MA-G45 MB
Corsair TX850 PSUU
22 answers Last reply
More about micro stutter game
  1. Might be worth adding that its NOT an fps problem. I get +60 fps in all games.
  2. You might want to check your ram. One stick at a time if needed. I've seen people getting these problems with bad ram.
  3. bystander said:
    You might want to check your ram. One stick at a time if needed. I've seen people getting these problems with bad ram.


    Already did that twice, and replaced them, just to be sure.
  4. Does this microstutter only appear when you are turning your view? Perhaps there is nothing wrong with your FPS, and everything is running smooth, but your mouse movements come across as jerky, which might mean you have a mouse that tracks horribly and/or has a low polling rate.
  5. You've probably done this, but, delete and update all drivers with the latest?
  6. no mention of your hdd. if its a low end 7200rpm or has lots of partitions then that can slow down your pc also make sure you try your games with vsync enabled. it will often stop micro stutter although i doubt thats what your suffering as its a description of the delay caused when you use 2 gfx cards. when 1 card is used its fps lag, or fps stutter. it can look the same as micro stutter but because its only 1 gfx card it named differently.

    if you have a spare hdd of the same make and model ( always wise to pair like with like) consider a clean format and then setup a raid 0 . this will speed up game texture load times dramatically and can also stop fps instability.
  7. If it is an hdd problem, you'll be experiencing these events as stutters every few seconds or more. It won't be a constant stuttering. If this is what you are experiencing, a new hdd may help.

    As far as 7200rpm goes, don't be afraid of that rpm. Most good hdd's are also 7200rpm's, but that doesn't mean its a good hdd either.
  8. Hello! Thaks for all your replies! Ive been fiddling about with the nvidia control panel and for some reason, the stutter is almost gone if i turn on adaptive vsync, but only if i select the "Half update rate" which luckily is 60 because of my monitor, but at some point i really hope it will be fixed by drivers, cuz i dont like the occasional screen tearing of A-vsync
  9. If v-sync is doing it to you, and a-vsyinc isn't. it sounds as if you are noticing the differences between when your monitor gets the same image twice in a row and every refresh.

    This sounds like your FPS were dipping below 60 FPS with v-sync on, and when they did, your graphics card was alternating between sending images every other refresh and sending it every refresh. This creates a microstuttering type of experience.
  10. Yeah i often get dips in like Skyrim it swings from 57-60 (and oddly sometimes 61) all the time and genereally just wont keep steady..
  11. it's a frame rate issue, and high end systems get it too, which it why it is often recommended to set say 60 even though you system can do over 100 but stutters nonetheless. use the frame rate cap
  12. If you have a powerful gaming rig just like me (powerful and healthy parts CPU, MOBO, GPU, RAM, PSU, SPU, HDD), and you still have micro-stuttering despite having high fps, I suggest you to check if you are experiencing input lag by USB keyboard/mouse.
    Go to device manager and disable HID for mouse, keyboard and for everything else having HID that you see there, you should still be able to use your keyboard and mouse but, all the special keys in your keyboard and mouse will be disabled like volume control, quick access to calculator, quick access to web browser, etc.
    Next step is to make sure you only have one language installed in your keyboard, you probably have english as default but, you might also have russian or something else, make sure its only one.
    Try your games and see if they stutter again.

    I was having a very weird and random micro-stuttering issue in almost every game, I went crazy trying to figure out what would case those annoying micro-stutters till I figured out it was just the input lag.
  13. For anyone who has this problem in the future; I had the same problem with ALL my games and I tried nearly EVERYTHING.

    Here's what was causing the issue: F.lux
    It's a program that dims your screen with the sunset.

    If you have f.lux, this could be the cause of your micro-stutter. Saved me from tearing face off.
  14. Not sure if this has been answered already, but many micro stutters are monitor related (even more, TV related if you use a TV instead of a monitor).
    V-Sync will partially solve the problem and here is why:

    If your PC sends more frames than your monitor is able to refresh, the FPS might be constant for the GPU, but will not be for the Monitor/TV.
    This issue is also responsible partially for screen tearing.
    In most cases, if you are running games at 30-40 frames, those problems wont appear, since the tv/monitor can handle the load VERY easy, and your brain adjusts to that frame speed.

    If the frames remain stable, you will feel it like fluent gameplay.
    On the flipside, if you are running at say 100 fps, and the monitor can manage 60, it will NOT manage always 60 (electornics in this term are not that precise).

    It will unfortunately, sometimes repeat a frame, and sometimes get a new one (and in some cases, even give a frame, tear the screen since it updates the next frame is too fast, and then repeat the second frame, creating micro stuttering).

    If this is the problem you are having, try to increase your Anti aliasing or your in game settings until your max frames stay under 60 (this is the most common monitor/tv speed).
    Bare in mind that LED based monitors and tvs refresh frames from top to bottom, making these issues appear more pronounced (thats why i bought a plasma tv, even if image retention can be a bitch for gaming if you are not very, very careful about it).

    Let me know if this is the problem or if not, then we will see what can be the cause.

    Kind Regards,
    The cat.
  15. i have exactly the same problem, this problem occur when i upgraded my GPU last week from r7 260x to gtx 960, enabling vsync seems fix my problem but i still curious what exactly caused this problem because i never had this problem with my old GPU, one day i try to use my old r7 260x but... BOOM! the microstutter still exist even with my old gpu, i never had this problem before...
  16. nullcakes said:
    For anyone who has this problem in the future; I had the same problem with ALL my games and I tried nearly EVERYTHING.

    Here's what was causing the issue: F.lux
    It's a program that dims your screen with the sunset.

    If you have f.lux, this could be the cause of your micro-stutter. Saved me from tearing face off.


    YOU! Thank you! I was about to tear my face off and then I read your post. Wow!! Everything works great!! Steam big picture is a little fluttery at times but I figure it's cause I frequently push big picture mode to the tv which is 60hz and my monitor is 144hz, figure the gpu's get confused? Anyhow thanks again!!! Game on...
  17. Hey guys, maybe it helps, I was having the same problems and it was the Hard Drive, I moved some games to my SSD and the stutter went away.

    I hope it works for you too.

    Ciao!
  18. Pablo_4 said:
    Hey guys, maybe it helps, I was having the same problems and it was the Hard Drive, I moved some games to my SSD and the stutter went away.

    I hope it works for you too.

    Ciao!

    That sounds like your HDD is/was dying. It shouldn't have that issue on a good HDD, though an SSD is certainly better.
  19. Oddly enough, I was having the exact same problem as you and I came to the conclusion that my computer wasn't getting enough power and that was what caused me to have the micro stutters, just something to think about.
  20. bystander said:
    Does this microstutter only appear when you are turning your view? Perhaps there is nothing wrong with your FPS, and everything is running smooth, but your mouse movements come across as jerky, which might mean you have a mouse that tracks horribly and/or has a low polling rate.

    you my friend are aa god amongst men! IT FUCKING WORKED!~
  21. Thumper_ said:
    Oddly enough, I was having the exact same problem as you and I came to the conclusion that my computer wasn't getting enough power and that was what caused me to have the micro stutters, just something to think about.


    Quite possible the OP hasn't found a solution even though this thread is nearly 4 years old! However I found a solution that worked for me and it is just a slight modification of the Nvidia global settings (although I believe it should work on AMD cards).

    I'm currently running a GTX 1070 and it's fed by a i7 6700K! So definitely no bottleneck there! I like to game with V-sync on because my eyes can't handle tearing, even at high frame rates. I set detail in game so my GPU has plenty of headroom when the action gets intense. One of my favorite games since it came out is Crysis 3. I set CPU and GPU of the game to HIGH settings and AA mode to FXAA as it's the least GPU demanding. Monitoring with Afterburner while playing the game I noticed the FPS was jumping up and down between 59 and 61 FPS. Now I know that's not much but to sensitive eyes it's perceived as jitter! Moving through the scene it wasn't that noticeable. But when the action got intense or turning (panning) quickly with the mouse it was clearly evident!

    So what fixed my issue? Simply by changing a Global setting in the Manage 3D Settings in the Nvidia Control Panel! All I did was change the "Maximum pre-rendered frames" to 1. From my understanding the GPU is getting out of sync because the CPU has prepared too many frames for the GPU to render and it can't do so in the given time-frame! So perhaps the extra frame is rushed or dropped! As an added bonus by lowering the Maximum pre-rendered frames setting to 1, I noticed my GPU temp went down about 5 degrees C. So lowering this global setting also lowered my GPU usage and made my 1070 run more efficiently. Now Crysis 3 runs at a solid 60 FPS and no jitter!

    In regards to "Maximum pre-rendered frames" Nvidia says "Reduce this value if you experience a delay in response to input devices such as a mouse, gamepad, or keyboard while playing games".

    I hope this helps someone!
  22. old thread, but for FALLOUT 4 I had massive, unplayable "judder" even though:
    a) GTX1080 + i7-3770K@4.2GHz + 16GB + W10, and

    b) Settings for F4 set to LOWEST to troubleshoot

    I eventually set to 60.7FPS using NVInspector and things went almost butter smooth.

    (May not help others, as there some may be some MONITOR involvement? Also, if I drop below 60/61FPS I get MASSIVE STUTTERING which is the same issue I had with Fallout 3 so obviously Bethesda is still just F'D up when it comes to something as simple as VSYNC.

    Apparently their physics and other things possibly are based on the FPS so hopefully this is the last Fallout/Elder Scrolls game for this engine.)

    Still NOT ideal due to the massive stutter at times, but I'll tweak the settings to raise average FPS (drops to about 45FPS sometimes which should be okay, but is not).
Ask a new question

Read More

PC gaming GPUs Games Video Games