Sign in with
Sign up | Sign in
Your question

Black Ops II MP stutter, CPU bottleneck?

Last response: in Video Games
Share
November 20, 2012 9:48:29 PM

Just got Black Ops II for PC and it plays well for the most part, except it stutters. I'm wondering if this stutter is caused by my Pentium Dual Core E6700@3.2ghz. It's 60fps, but it's stuttery. When I exit the game, I notice that it's using 100% CPU. As optimized was apparently supposed to be for MP, I'm surprised there's a stutter.

My GPU is the HD 7750(880 mhz).

lol I might seriously go back to console gaming because of this stuff.
November 21, 2012 3:44:20 AM

I'm having the same problem, I think it's the games fault.
I'm always having 60+FPS, yet it's stuttering every few seconds.
My GPU is the GTX 660ti OC edition from asus, my cpu the Intel core I52500k.



m
0
l
a c 112 à CPUs
November 21, 2012 10:27:10 AM

the game just isnt playing rite on a lot of pc configs. it looks like activision are seriously trying to Pee off the pc consumer
the game is obviously not finished and was rushed to get out for november 11-13th release. they have already removed nuke town from the rotation and theres no word on whether it will be back or not. some say its because its causing server side issues while others say it was a launch weekend gimmick and wont be returning.
m
0
l
Related resources
November 21, 2012 11:04:59 AM

HEXiT said:
the game just isnt playing rite on a lot of pc configs. it looks like activision are seriously trying to Pee off the pc consumer
the game is obviously not finished and was rushed to get out for november 11-13th release. they have already removed nuke town from the rotation and theres no word on whether it will be back or not. some say its because its causing server side issues while others say it was a launch weekend gimmick and wont be returning.

Yeah it's weird. Even in single player this happens. More often then stuttering are just slowdowns. Like the game will be running at 60fps and slowdown into the 40's.

This weird because even on an outdated CPU like this, I get a stable 30fps during BF3 on ultra during single player. It doesn't make sense why I can't get a stable 60fps in a game that looks much worse.

I smell console port because even intense games like BF3 don't slowdown during single player.
m
0
l
November 21, 2012 1:58:38 PM

mike2012 said:
Yeah it's weird. Even in single player this happens. More often then stuttering are just slowdowns. Like the game will be running at 60fps and slowdown into the 40's.

This weird because even on an outdated CPU like this, I get a stable 30fps during BF3 on ultra during single player. It doesn't make sense why I can't get a stable 60fps in a game that looks much worse.

I smell console port because even intense games like BF3 don't slowdown during single player.

Well, CoD games are always console ports. and to be honest, BF3 is a console port too. It's a good one, but it is a console port.
But yea, the game seems to be having a lot of problems. I used to have the stuttering in MP and SP, now it's gone in MP (For how long?) but it persits in SP.
m
0
l
November 21, 2012 2:06:37 PM

I don't have any stuttering problems. I had major FPS drops while aiming down sights though. It was bad, 60FPS to high 20's while aiming. I just had to drop the Field of View Depth to Low and that cleared up.

My issue is the looooooong load times in MP. It takes so long for me to actually get into the game my team has already capped our spawn flag and is moving towards B.
m
0
l
November 21, 2012 3:18:49 PM

dscudella said:
I don't have any stuttering problems. I had major FPS drops while aiming down sights though. It was bad, 60FPS to high 20's while aiming. I just had to drop the Field of View Depth to Low and that cleared up.

You don't need to turn the DoF down, just Alt-Tab and enter the game again. Worked fine for me.
m
0
l
December 16, 2012 5:06:31 PM

mike2012 said:
Just got Black Ops II for PC and it plays well for the most part, except it stutters. I'm wondering if this stutter is caused by my Pentium Dual Core E6700@3.2ghz. It's 60fps, but it's stuttery. When I exit the game, I notice that it's using 100% CPU. As optimized was apparently supposed to be for MP, I'm surprised there's a stutter.

My GPU is the HD 7750(880 mhz).

lol I might seriously go back to console gaming because of this stuff.


Try disabling HyperThreading in your BIOS.

No joke.
m
0
l
December 31, 2012 11:13:01 AM

vhaz said:
Try disabling HyperThreading in your BIOS.

No joke.


Pentium Dual Core CPUs do NOT support HyperThreading anyway.... so that couldn't make a difference.

Personally, this game runs smooth as silk with everything on Extra in singleplayer. But multiplayer, while maintaining 120fps will constantly stutter, irritating...
My hunch is this is a networking issue, what's causing it I'm not sure.
m
0
l
December 31, 2012 5:07:38 PM

Heres a fix
Its a fix you have to do every time though
Open task manager, and set the T6MP to High
right click that process , and set it to High cpu usage

go back to game, enjoy without stutter xD
You have to do it everytime you run T6MP or T6ZM
m
0
l
February 1, 2013 7:39:43 AM

try both of these 2 options: 1. in the start menu, view advanced system settings, advanced, setting, visual effects, adjust for best performance
2. use the Game Booster software
if these two options doesnt work, then its your hardware problem and ur hardware (cpu, graphic ....) should be promoted.
m
0
l
February 1, 2013 7:40:06 AM

try both of these 2 options: 1. in the start menu, view advanced system settings, advanced, setting, visual effects, adjust for best performance
2. use the Game Booster software
if these two options doesnt work, then its your hardware problem and ur hardware (cpu, graphic ....) should be promoted.
m
0
l
March 10, 2013 1:06:35 PM

http://www.youtube.com/watch?v=JcAQtD2QaiU

Change t6mp.exe affinity to run on different cores than everything else.
Then disable Windows 7 AERO.
This is a 100% Fix if you have 4 or more cores at your displosal.

If you have just 2 I dont think you can run this game smoothly.

For 4 Cores I recommend:

t6mp.exe cores: 0,1,2
everything else: 3

For 8 Cores, tho untested:

t6mp.exe cores: 0,1,2,3,4,5
everything else: 6,7
m
0
l
March 10, 2013 3:26:17 PM

ghoulpl said:
http://www.youtube.com/watch?v=JcAQtD2QaiU

Change t6mp.exe affinity to run on different cores than everything else.
Then disable Windows 7 AERO.
This is a 100% Fix if you have 4 or more cores at your displosal.

If you have just 2 I dont think you can run this game smoothly.

For 4 Cores I recommend:

t6mp.exe cores: 0,1,2
everything else: 3

For 8 Cores, tho untested:

t6mp.exe cores: 0,1,2,3,4,5
everything else: 6,7


BO2 runs smooth on old dual core cpu's. My i3-2100 was barely taxed and my i5 even less so. It's all in the graphics which, again, isn't very taxing.
m
0
l
March 19, 2013 7:19:22 PM

@dscudella

I can definitely say BO2 does NOT run smooth on old dual cores at all... I have an AMD x2 255 paired with an AMD 7750 and its choppier than any of my other games. I mean BF3 is stuttering less from what it feels like. I play BO2 @ 60 fps+ with AA disabled and it stutters bad with my CPU maxed out @100%. Now yours may be barely taxed because its a hyper-threaded dual core, mine isn't. This game is not like any other CoD it will actually use multiple cores in MP if you give them to it.
m
0
l
!