Sign in with
Sign up | Sign in
Your question

Nvstor64 issues a reset to device and freezes computer again

Last response: in Windows 7
Share
October 29, 2010 3:42:46 AM

This is the short version as this issue gets a big long:

4 months ago, I started experiencing the same random freeze issues with Nvstor64 issuing a reset to device (seen in event log). I tried a lot of things to fix it back then, and I didn’t really figure out what exactly caused it but in the end after I updated my motherboard drivers to the latest (nForce 15.53) the freezing stopped. Right now I still have the 15.53’s installed, and they are the newest, and I the issue has come back and I need some advice and how to go about trying to fix it again, or figure out what is causing it.

Details:

So about 3 Weeks ago I had another nvstor64 caused freeze, and then today I just had one while in the middle of a starcraft game , which is what prompted me to need to fix this issue again. After just the one 3 weeks ago I hoped it was just really random. But now I’m worried that it’s back and striking for no reason again.

Basically what happens each time is the computer is booted into windows 7, and I can be doing anything like web browsing in firefox, or in a word document, or in a reasonably intensive game like starcraft 2, and then windows will freeze for about 1-2 minutes, then it unfreezes and sometimes returns to normal.

When It froze during starcraft 2 today for the usual 1-2 minutes, it then returned to normal for about 10 seconds, then completely froze the computer and I had to hit the reset button. Then it got even weirder, as the bios loaded after the reset, one of the hard drives names in the bios was replaced with some random non-alphabetic characters, and the computer just hung at the bios.

Then I hit the rest button again, and it still stopped at the initial bios screen, and this time it said System in Safe Mode, Please reset CPU or memory frequency in the CMOS. I think this weird bios booting hanging is just from it crashing as after I fully turned it off and then booted it was fine.

These are the specific of what the event log shows:




Right before the freeze, Event log show this as a Warning from nvstor64:
>>>
Reset to device, \Device\RaidPort1, was issued
<<<

Then right as the computer froze, this error from nvstor64 occurred:
>>>
This device has been removed from the system.

Device: \Device\RaidPort1
Model: TSSTcorp CDDVDW SH-S203N
Firmware Version: SB01
Serial Number:
Port: 1
<<<

After the PC Unfreezes this is the next event log entry, and there doesn’t appear to be anything else important after this:

>>> The Windows Error Reporting Service service entered the running state. <<<

The TSSTcorp is the only optical drive I have attached, which is connected to the Motherboard using sata, and I checked it after the computer unfroze, and it was still there and working fine, despite event log saying that it was “removed” from the system.

I’m really at a loss now as what to do to troubleshoot this, please give me some ideas.

Original thread on the issue from 4 months ago:
http://www.tomshardware.com/forum/7468-63-reset-raidpor...

System Info:
MoBo: Evga Nvidia nForce 680i
CPU: Intel Core 2 Duo E6700 @ 2.66Ghz
GFX: Evga GTX 260 Core 216 896MB
RAM: OCZ 2x2GB DDR2 1066 [PC2 8500]
PSU: SilverStone ST75F 750W [4x +12V@ 18A each]
HD: WD 500GB 7200RPM SATA HD
OS: Windows 7 Ultimate x64s
a b $ Windows 7
October 29, 2010 5:31:52 AM

The fact that you cured the problem by updating the drivers and then after some time the problem came back would indicate to me that your problem is a hardware problem. The first suspect by a mile is a faulty deteriorating power supply. The second suspect would be faulty capacitors on the graphics card.
m
0
l
October 29, 2010 4:30:38 PM

That is a good point, I hadn't really thought that it was the hardware, I guess that is a possibility. It does seem weird tho, that it just this nvstor64 causing the freeze, and that it doesn't even totally crash the computer it often comes back, and then it works for weeks at a time. Is there anything else I can do to test the power supply, sort of just switch it for another PSU
m
0
l
Related resources
November 7, 2010 1:50:36 PM

endoftheline2 said:
That is a good point, I hadn't really thought that it was the hardware, I guess that is a possibility. It does seem weird tho, that it just this nvstor64 causing the freeze, and that it doesn't even totally crash the computer it often comes back, and then it works for weeks at a time. Is there anything else I can do to test the power supply, sort of just switch it for another PSU


I have had the same problem and the issue is all over nVidia's forums for the last few years. There is no fix as of yet. It isn't your graphics card or your power supply...it is the motherboard.

The only "fix" people have been successful with is changing the motherboard out to a different one...preferably a non-nvida board.

m
0
l
November 10, 2010 1:37:48 AM

I would like to chime in on this one.

I have been having this issue for about a month now. First suspect, power supply. I replaced it with a 1000W jobby. Didnt fix it.

Tried about 10 different os installs with XP, 7, vista, and even an evaluation of Server 08 R2, all showed this same problem, so I go back to hardware. I beleive that it is my motherboards Nvidia controller going out.

Here is the weird thing, I tried a fresh install of W7. I installed everything one by one then ran the windows Experience index, as this was a quick way to replicate the event, and it started showing up when I enabled SLI. huh. I know what gives. An after further testing, I can install whatever drivers, OS, BIOS whatever and when I have SLI enabled this error shows.

Any thoughts on this? Bad video card? Bad Northbridge?

When I take one of the video cards out this issue is gone. But it doesnt matter which one. This makes me think they are fine.
m
0
l
November 11, 2010 4:13:39 PM


I just talked to nvidia they said to update the bios on the motherboard, then installed the newest chipset drivers again. Not exaclty a soluton, but I don't think I have the newest bios for my 680i right now,
m
0
l
November 11, 2010 8:24:17 PM

Done all that, didn't help. I tried to revert back to an old bios as well, no love. What is so weird is this exact settup worked fine for three years, then all the sudden this started showing up, what gives. Of course my m2n32 SLI deluxes waranty expired about three weeks ago.
m
0
l
November 11, 2010 9:10:58 PM

Well I just updated my bios and I haven't had the problem yet, so I will see if it makes a difference. I assume you've tried different chipset drivers, like the newest and some older ones.
m
0
l
November 12, 2010 11:41:43 AM

Ive tried every driver I could find for everything. I triend an old 86 version of forceware graphics drivers, generic drivers, XP drivers, I a pretty well convinced at this point that my motherboard is done. Ill tell you this I used to be a big fan of nvidia, but I will never buy an Nvidia chipset again. This M2N32 is an awesome motherboard, and with the latest bios I was going to upgrade to a Phenom 940, and a new video card would have brought his board back to life, but now its not worth spending a dollar on, all because of a crappy nvidia controller.
m
0
l
January 24, 2011 8:04:01 PM

I'm on a M57SLI-S4 having the same problems. Almost exact, minus having dvd sata and SLI. I just spent an ass load to get this computer back up to par, and now this.. I'm still not convinced it's the motherboard going out though... Just setup RAID, so thought it may have been refurb HD's, but they pass all tests; even in linux. Thought it may have been RAM, so got new ram and it passes all memtest. The funny thing is I'm getting BSOD's whenever I bump my desk, and have replicated it many many times over. I'm thinking something's not sittin right. I'm also getting the CPU frequency message after certain BSOD's that results in a continuous repeating long beep bios code til I power off for a minute or so and then will randomly boot up. The weirdest thing about it, is that the BSOD's and random 2 minute freezes aren't from graphic/cpu intensive programs. It'll be something like scrolling through a webpage, but then I can start editing in 3D for hours on end and it doesn't skip a beat... So strange..

I'm also getting some of these warnings/errors:

Initialization of the High Precision Event Timer failed due to a BIOS configuration problem.
The operating system will use another available platform timer in lieu of the High Precision Event Timer.

The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

An error was detected on device \Device\Harddisk1\DR1 during a paging operation.

The driver detected a controller error on \Device\CdRom0.

I also try to transfer files from old HD and new HD's, and when it's a lot of files it'll just stop and won't transfer or go away until I force reboot. Might be old hard drive starting to fail? That could explain the vibrations causing the BSOD's.

PLEASE PLEASE PLEASE RESPOND if you find out anymore, and I'll do the same. Cause this problems not gonna fix itself, but it doesn't feel like my comps bout to go kaput either.

Sorry for not correcting grammar/typos running on little sleep, and just dont care to spend anymore time on this problem. Thanks for at least confirming I'm not the only one with this problem!
m
0
l
March 28, 2011 7:35:45 PM

Hey guys, a bit late to the party here but I thought I would try my luck. I have also just started to have this problem and thought I would throw in my two cents.

I just upgraded my graphics card from a 9800GTX+ to a GTX 550 Ti (Both EVGA) and now I am frequently bombarded by nvstor64 errors.

I can almost 100% replicate this problem on my machine while playing the game Rift. As i ramp up the graphics the chance of the error happening increases. While running the game maxed out I will almost instantaneously get nvstor64 errors which freeze the system for 10+ seconds (I have once seen 64 nvstor64 warnings in concurrently completely locking my system for 4 minutes after which the game crashed)

I have searched high and low for a solution to this problem and have found one thing in common with everyone reporting this error - damn nVidia chipset drivers. I'm running on a P5NT-Deluxe mobo from ASUS (780i chipset) so it seems to be that the only total solution is to out the mobo as the chipset just seems to be faulty.

I have completely uninstalled all nVidia drivers from my computer (chipset/ethernet/graphics) and then booted into safe mode, used a driver cleaner to remove all traces of them, restarted into safe mode AGAIN and used the tool AGAIN, then booted up normally and reinstalled everything - this didn't have any effect on the problem.

As to people saying disabling Event Queuing in the device manager - I tried that and it offers a semi-solution in that the nvstor64 errors are less frequent (although still system crippling for gaming) and change from error code 8 to error code 129 and 3.

The error code 8's show this:

A request to this device has been cancelled.

Device: \Device\RaidPort0
Model: WDC WD6401AALS-00L3B2
Firmware Version: 01.0
Serial Number: WD-WCASY5664683
Port: 1

Whereas the error code 129 shows:

Reset to device, \Device\RaidPort0, was issued.

And the code 3 shows:

Data error on device.

Device: \Device\RaidPort0
Model: WDC WD6401AALS-00L3B2
Firmware Version: 01.0
Serial Number: WD-WCASY5664683
Port: 1


So, I don't know if anyone has found any solutions or ideas that fix the problem. but that's my observations. Still running a crippled system right now, but I'm thinking of getting a new mobo and seeing if that eliminates the problem.

Also, the mobos BIOS freezes 50% of the time i try to use it which people have pointed at power supply and memory issues but i have a 750 watt supply which i have tested with a multi-meter for over an hour through assorted uses and seen no unexpected power drops and run memtest on my ram for over 12 hours with no issue so this also just points to more mobo issues in my mind. Granted I am a basement tinkerer and have no formal computer tech training :/ 
m
0
l
April 3, 2011 12:07:14 AM

I believe I have solved this issue as it's directly related to a (rather nasty) bug in the latest nForce SATA controller drivers. I was experiencing this exact problem on my Dell Studio XPS13 laptop (nForce 730i chipset).

After reading as many threads as I could on this and performing through testing on each revision of the nForce SATA driver that was reported to solve this issue, I've come to the conclusion that (At least for me) the 20.08 nForce driver package with the 11.1.0.33 SATA driver did not trigger this bug. My nvstor64 ID 129 event could be reproduced just by increasing the disk I/O to a medium to high level (Benchmarks work well, so does installing Visual Studio apparently. It took 3 hours).

I'm sure this is subjective as the nvstor64 event ID 129 is a warning indicating a drive reset was initiated (This is what causes the freeze. If you notice, everything that was in memory still works, like your mouse pointer. It's a symptom of the disk drive resetting, not a cause). The problem is the driver and/or controller having problems and issuing the ATA reset command when it's probably not supposed to (or can't handle an error condition, or perhaps can't handle the large amount of disk I/O at the time).

I have extensive notes and benchmarks on my testing if you all would like to see them I can paste them in this thread)
m
0
l
April 3, 2011 5:03:03 AM

Thanks for your input EvilGrid. I have tried the 20.08 nForce driver package as you suggested and it has seemed to fix the issue for me so far. I have heard there is also a way to make SATA drivers show up as IDE drives which will also cause the computer to ignore the faulty SATA drivers, thought i am not sure how to do that. Anyways, I will report back if the issue crops back up again, but so far so good!

Thanks again!
m
0
l
April 4, 2011 1:21:02 AM

Sweet! I'm glad it worked for you! The only other option is to roll back to the Microsoft driver, which through my testing shows no difference in performance.

The only downside to the 20.08 package is that S.M.A.R.T. data is unavailable (Drive health diagnostics) and you cant set the AAM (Automatic Acoustics Management) settings. Seems to me this driver is a bit incomplete, but at least it works!
m
0
l
April 4, 2011 6:20:45 PM

Hey, just me checking in again. Although the 20.08 drivers have definitely helped the issue, it is still present :(  nvstor64 errors pop up infrequently though they do happen 3-6 times a day or so it seems. The errors now always crash whatever program seemingly induced them instead of resuming after 15~ seconds but I suppose overall it is an improvement.

Thanks for the help, I guess I'll just have to purchase a non-nForce MOBO once some money rolls in.
m
0
l
!