Sign in with
Sign up | Sign in
Your question

Far Cry 3 stuttering/freezing

Last response: in Video Games
Share
November 30, 2012 10:52:36 AM

I got problems when trying to play Far Cry 3. It stutters really badly, like for a second the fps go down to 10 and back up. I dont know if its lag or stuttering, but atleast its not playable enough.

Tried low settings, still stutter, tried vertical sync, still stuter. Tried all settings, still stutter. Even with direct x 9. Also tried windows, bordered and fullscreen. I can even take the game down to 800x600 resolution and it still lags...!

I got two xfx 6950's, i5 2500k and 16gb ram, so I shouldnt really be struggling this much with FC3. The systemrequirementslab.com shows that my pc are over recommended to run far cry 3.

My ATI driver is up to date, and so is the redist c++ and direct x..Help.

November 30, 2012 11:08:16 AM

Have you tried disabling XF or removing one graphics card?
November 30, 2012 11:10:28 AM

disable crossfire. the drivers needed havent been released yet so the game is officially unsupported.
use 1 card and then select the optimal settings which will be slightly higher than medium. the game should then run at 30-60 fps and be pretty smooth. it looks good regardless of settings on a dx11 machine so dont be to worried abut maxing it out till you get the new drivers. currently the most recent drivers that are none beta are 12.10

Related resources
November 30, 2012 11:25:59 AM

Thanks for ur replies! Will try this, ill get back to you
November 30, 2012 11:59:45 AM

HEXiT said:
disable crossfire. the drivers needed havent been released yet so the game is officially unsupported.
use 1 card and then select the optimal settings which will be slightly higher than medium. the game should then run at 30-60 fps and be pretty smooth. it looks good regardless of settings on a dx11 machine so dont be to worried abut maxing it out till you get the new drivers. currently the most recent drivers that are none beta are 12.10


This worked!!:)  the game got much smoother without crossfire! Lets just wait for the new drivers:) 
December 5, 2012 2:47:41 AM

I'm having the same issue. Do you have to actually disable crossfire in control center? Or just not force it into crossfire mode?
December 6, 2012 8:08:38 AM

Yeah I just disable it in catalyst.

I still got some stutter, want to fix this..anyone know a new solution? It's like I drop massively in fps for 0,005 then I get back up in fps. So this makes it stutter..

So far ive:

-Updated to newest version of Far cry 3
-Updated to newest version of my GPU (Radeon HD 6000 series)
-Turned off postFX
-Tried with directx9
-Tried every graphic settings, from ultra to low, same stutter.
-Turned of ULPS so the 2nd card is also working 100 % (or what the hell ULPS does, people atleast said I should turn it off)

Anyone got ANY new solution for me here? Would be greatly appreciated
December 6, 2012 7:16:07 PM



Yeah DEFFO worth the try. I run far cry 3 with everything maxed out with ZEEERO lag. With 1 6950 card! I just disabled crossfire 1 more time with the new amd patch u linked, it runs like a CHARM!!! So thank u so much!
December 7, 2012 6:35:51 AM

kusetjuv said:
Yeah DEFFO worth the try. I run far cry 3 with everything maxed out with ZEEERO lag. With 1 6950 card! I just disabled crossfire 1 more time with the new amd patch u linked, it runs like a CHARM!!! So thank u so much!

No worries! Always worth keeping an eye on beta drivers for new games!
December 11, 2012 7:39:03 AM

The only way I can get crossfire to work (6950s) is to start the game - toggle to the desktop and change something, anything in ccc - then change it back if you like. When you toggle back into Far Cry 3 crossfire will work - 50/60 FPS, MSAA x2, Ultra settings (I have post fx set to low). This only seems to work with 12.11 drivers. I did try 12.10 but not working. If you choose to exit the game then restart the game then crossfire seems to work fine - if you restart PC then start game then you have to repeat above. Any ideas? Cheers.
March 4, 2013 2:22:17 PM

Hi.I'm having similar problems I bought Far Cry 3 recently off steam and started it up.Not much lag in opening cinematic but after that when Vaas is talking to you i get really bad stuttering.i have tried lots of different things but they dont seem to help and i saw you guys talking about disabling crossfire can you tell me what that does and how i do it i really just want to play my game.(I'm not great with computers sorry i may be confused if you answer)
!