Sign in with
Sign up | Sign in
Your question

Far Cry 3, Low FPS

Last response: in Video Games
Share
December 1, 2012 8:21:51 PM

Hey guys!

Lets start with my specs so I don't get asked:

i7 ivy bridge
16GB RAM
Radeon Hd 7970

After the menu in far cry 3 it has a kind of intro all 2d images and text and I'm getting around 2-5 fps
When I turn the settings down I (right down even 800x600 o.O) I get 20ish

I did how ever get it working to get through the first tutorial part and I got FPS I should of got in the first place but I can't seem to get it working again.

Would be really appreciated if I could get some help on this :) 

- Not trying to be an asshole but please don't reply with same, me too and other comments along those lines it helps no one :) 

I have looked around and can't seem to find the route of this problem, even if you don't have a real fix although this would be great throwing a list of ideas would be cool too :) 

Thanks for reading.

More about : cry low fps

December 1, 2012 8:51:43 PM

Which driver version are you running?
December 1, 2012 8:53:43 PM

The Very latest beta as of 20 minuits ago
Related resources
December 2, 2012 2:02:44 PM

demonitrax said:
Not trying to be an asshole but please don't reply with same, me too and other comments along those lines it helps no one :) .

Actually me too have this kind of problem, and it looks quite strange...but damn the game is very very demanding.
December 2, 2012 2:23:57 PM

Try this, set everything on very high with only MSAA to 4 and SSAO Method to HBAO

I tried setting SSAO to HBAO and I got 30 FPS in the Intro video.
December 2, 2012 8:48:16 PM

I'm on an HD6970, and get about 40-60fps by setting "everything" to ULTRA, HDAO but no AA, what's your problem? It's most likely a driver issue, due to the simple fact that this is jet another shitty console-port ported by Ubisoft's incompetent crew, and since there are no "never settle drivers" (like Nvidias specially issued BETA drivers "310.64" for Far Cry 3) out as of now, the stutters shall go on for a few months, if not more, not to mention that my stock graphics card will go haywire unless I play it with (V-Sync 1-frames), it's sad really.

Please note that I play all my games with 1920x1080p with the latest AMD Catalyst 12.11 BETA8 drivers.
A quick side note for both AMD and Ubisoft: "Sort ya foooin' life out mate!"
December 2, 2012 9:39:24 PM

Right click on desktop and go to AMD control center or catalyst etc. Then go to gaming, graphics, system, etc and increase the apporiate sliders to max. Your video card is probably set to low.
December 3, 2012 1:00:01 AM

go into the video settings and make sure the game isnt storing extra frames... they need to be set to 1 for amd cards.
run the latest 12.10 drivers not the beta 1s
make sure your running on 4 cores with hyperthreading turned off.(via bios)
i finished it this afternoon on my sig system. (about 10 hours just playing main missions) and got an average of 40fps with x2 msaa @1080p on recommended settings with some ultra for things like mesh quality and textures. i also tried hbao and hdao shading and it had little impact on shadows. also used enhanced alpha filter...
minimum was about 35 fps max 70+ i played with vsync on and got a pleasant surprise. very little impact on frame rates with no tearing.
December 5, 2012 9:26:49 AM

In video quality options turn "Post FX" to low. Made a massive difference in performance to me.

I narrowed it down to that single option really messing up most peoples FPS. Not sure if it's a bug or not. Hope this works!
December 6, 2012 11:14:55 AM

Where are you guys seeing the actual frame rate in game ?
December 9, 2012 10:16:14 PM

Are you running a program like the ATI Tray Tool? I noticed my frames dropped drastically when using that tool, it could be that I had a wrong setting somewhere but I got tired of messing with it so I uninstalled it and went with the default Catalyst Control Center settings. Once I did that my frames returned to normal. I too have a HD 7970 by Gigabyte and I run at 2560x1440 all on Ultra and High settings and still get around 55 fps.

demonitrax said:
Hey guys!

Lets start with my specs so I don't get asked:

i7 ivy bridge
16GB RAM
Radeon Hd 7970

After the menu in far cry 3 it has a kind of intro all 2d images and text and I'm getting around 2-5 fps
When I turn the settings down I (right down even 800x600 o.O) I get 20ish

I did how ever get it working to get through the first tutorial part and I got FPS I should of got in the first place but I can't seem to get it working again.

Would be really appreciated if I could get some help on this :) 

- Not trying to be an asshole but please don't reply with same, me too and other comments along those lines it helps no one :) 

I have looked around and can't seem to find the route of this problem, even if you don't have a real fix although this would be great throwing a list of ideas would be cool too :) 

Thanks for reading.

January 10, 2013 9:00:07 PM

I KNOW! :D  I had this happen to me, there is a setting called Post FX.... the higher I had it, my FPS would drop SIGNIFICANTLY! After I switched it from high to medium, the frames are so much better. (Truthfully I can't tell what it does to the settings at all..) I think it might be a bug

Intel i7 3770K

16GB Ram

Nvidia GTX 670 EVGA 4GB

January 11, 2013 12:24:23 AM

if you want to see what post fx does then turn it off... pretty simple idea but it works...
you will immediately see the image is much sharper. the haze around the outside of the screen is lessened with every step and the center of the screen becomes sharper.
!