Sign in with
Sign up | Sign in
Your question
Solved

Far Cry 3 scope no crosshair.

Last response: in Video Games
Share
December 4, 2012 3:27:46 AM

I know that it has many other threads about this issue but I tried most of them and the problem is still persist. So I post my spec on here hopefully to get this fixed. When I zoom in with the bow or the sniper rifles I don't have any crosshairs on the scopes. Like the red dot on the bow for example, has no red dot there. Its just a transparent piece of glass, which makes the aiming impossible. Especially with the sniper rifles, because its like firing from the hip, but without the crosshair lines which at least indicate where the middle of the screen is. So yeah- its like trying to aim through a magnifying glass.
A solution to fix this would be great.
Thank you.

I would attach my Dxdiag on but it doesn't have the option to so Imma post a screenshot of it. (I'm using AMD 7850 Stock clock)

http://imgur.com/vyC5l

http://imgur.com/mwEEK

http://imgur.com/NmpvV

http://i.imgur.com/zLawo.jpg

http://i.imgur.com/isjHy.jpg

More about : cry scope crosshair

Best solution

December 4, 2012 10:02:23 AM

hi alankevis.

This is usually an anti aliasing problem.

First you need to go to you AMD Vision Engine control panel, and set all options to application controlled.

Next you need to be sure you are loading the game with the Farcry3_d3d11.exe file, and not the Farcry3.exe file, otherwise you will be playing the game in DX9 mode on your DX11 card. Farcry3_d3d11.exe can be found in the same directory as Farcry.exe.

You should then be able to change all you AA settings in game to however you like them.

I am pretty confident this should fix it. I have the same problem, but I have a DX10 vid card, so not much I can do really.

Good luck
Share
December 4, 2012 10:06:23 AM

Best answer selected by alankevis.
m
0
l
Related resources
December 4, 2012 10:07:13 AM

werrywerry said:
hi alankevis.

This is usually an anti aliasing problem.

First you need to go to you AMD Vision Engine control panel, and set all options to application controlled.

Next you need to be sure you are loading the game with the Farcry3_d3d11.exe file, and not the Farcry3.exe file, otherwise you will be playing the game in DX9 mode on your DX11 card. Farcry3_d3d11.exe can be found in the same directory as Farcry.exe.

You should then be able to change all you AA settings in game to however you like them.

I am pretty confident this should fix it. I have the same problem, but I have a DX10 vid card, so not much I can do really.

Good luck


OMG, one simple thing and I didn't do it. Playing using Farcry3_d3d11.exe totally fixed it!!!!

THank you very much!
m
0
l
December 4, 2012 9:10:56 PM

werrywerry said:
hi alankevis.

This is usually an anti aliasing problem.

First you need to go to you AMD Vision Engine control panel, and set all options to application controlled.

Next you need to be sure you are loading the game with the Farcry3_d3d11.exe file, and not the Farcry3.exe file, otherwise you will be playing the game in DX9 mode on your DX11 card. Farcry3_d3d11.exe can be found in the same directory as Farcry.exe.

You should then be able to change all you AA settings in game to however you like them.

I am pretty confident this should fix it. I have the same problem, but I have a DX10 vid card, so not much I can do really.

Good luck


Are you still having this problem with your dx10 card? I have the same problem, but fixed it somehow, if you are using ATI card, and use ccc, use these settings for farcry3.exe in your ccc :

Anti-aliasing :
use application settings
I have filter set on box and AA on 2x

Antisotropic filtering:
2x


Catalyst AI:
standard

minimap :
high quality

Wait for vertical refresh:
off, unless application specifies

And the rest is unchecked

I don't know wich setting did it but that worked for me...

Good luck!

m
0
l
December 5, 2012 8:25:41 AM

Alankevis said:
I know that it has many other threads about this issue but I tried most of them and the problem is still persist. So I post my spec on here hopefully to get this fixed. When I zoom in with the bow or the sniper rifles I don't have any crosshairs on the scopes. Like the red dot on the bow for example, has no red dot there. Its just a transparent piece of glass, which makes the aiming impossible. Especially with the sniper rifles, because its like firing from the hip, but without the crosshair lines which at least indicate where the middle of the screen is. So yeah- its like trying to aim through a magnifying glass.
A solution to fix this would be great.
Thank you.

I would attach my Dxdiag on but it doesn't have the option to so Imma post a screenshot of it. (I'm using AMD 7850 Stock clock)

http://imgur.com/vyC5l

http://imgur.com/mwEEK

http://imgur.com/NmpvV

http://i.imgur.com/zLawo.jpg

http://i.imgur.com/isjHy.jpg


I have an answer for u, its the reason of having "letterbox" enabled, when u disable it, its fixed, u still got your crosshair then.
m
0
l
December 15, 2012 8:15:18 PM

werrywerry said:
hi alankevis.

This is usually an anti aliasing problem.

First you need to go to you AMD Vision Engine control panel, and set all options to application controlled.

Next you need to be sure you are loading the game with the Farcry3_d3d11.exe file, and not the Farcry3.exe file, otherwise you will be playing the game in DX9 mode on your DX11 card. Farcry3_d3d11.exe can be found in the same directory as Farcry.exe.

You should then be able to change all you AA settings in game to however you like them.

I am pretty confident this should fix it. I have the same problem, but I have a DX10 vid card, so not much I can do really.

Good luck



How do I get to AMD Vision Engine and also I tried launching the Farcry3_d3d11.exe file but it wouldn't open??
m
0
l
Anonymous
January 5, 2013 7:54:41 PM

werrywerry said:
hi alankevis.

This is usually an anti aliasing problem.

First you need to go to you AMD Vision Engine control panel, and set all options to application controlled.

Next you need to be sure you are loading the game with the Farcry3_d3d11.exe file, and not the Farcry3.exe file, otherwise you will be playing the game in DX9 mode on your DX11 card. Farcry3_d3d11.exe can be found in the same directory as Farcry.exe.

You should then be able to change all you AA settings in game to however you like them.

I am pretty confident this should fix it. I have the same problem, but I have a DX10 vid card, so not much I can do really.

Good luck


Im unable to do this, as Uplay needs a new CD Code, and it wont let me use my current one. In other words, this cant work for me, simple as that.
m
0
l
May 15, 2013 10:03:54 PM

Just update video card driver worked for me and im using HD Graphics family intel
m
0
l
!