Sign in with
Sign up | Sign in
Your question
Solved

Far Cry 3 massive framerate drops when looking out to the sea

Last response: in Video Games
Share
December 5, 2012 1:25:57 AM

Hey guys,

Far Cry 3 runs fine with my i5 2400 and Radeon 6870 except when I look out to the ocean. The frames immediately drop from around 30-50 to single digits. I have the latest drivers installed, 12.11 CAP 2 and the latest game patch. I tried lowering the settings but there is always that extremely annoying fps drop.

Any help will be greatly appreciated,
Thanks
December 5, 2012 2:21:31 AM

Was this always a problem? Or did it suddenly start?
m
0
l
December 5, 2012 6:56:32 AM

it was always a problem, I just bought the game today.
m
0
l
Related resources
December 5, 2012 7:53:03 AM

Can you turn down the water quality ?? I haven't bought Far Cry 3 yet, but I'd start with that or reflections to see what happens.
m
0
l
December 5, 2012 7:58:46 AM

I think the water might be using DX11 Tessellation, which is usually pretty ok but this game isn't optimised too well so Tessellation can have a great effect on performance. Not much you can do except turn down the water quality.
m
0
l

Best solution

December 5, 2012 9:28:39 AM

In video quality options turn "Post FX" to low. Made a massive overall difference in performance to me.

After much aggravation narrowed it down to that single option really messing up most peoples FPS issues. Not sure if it's a bug or not.

Hope this works!
Share
December 6, 2012 1:49:21 AM

Best answer selected by xl-caliber.
m
0
l
December 6, 2012 1:50:01 AM

thanks, as soon as i turned post fx to low it made a world of difference :) 
m
0
l
May 23, 2013 11:03:34 AM

You can fix fps drop during camera motion by install HiAlgoBoost. Try it from hialgo.com
m
0
l
!