Sign in with
Sign up | Sign in
Your question

Lagging on all games

Last response: in Video Games
Share
December 8, 2012 4:44:37 PM

I recently bought a pc with no hard drive,ram,or graphics card.
I bought 8 gigs of ddr3 Crossair Vengence 1600mh ram and i bought 2 hd4870x2 for a whopping 4 gigs of video memory. the hard drive i pulled out out of a laptop(although I did not reformat it thinks its a levano)
here are my specs
MOBO- Asus px658d premium
Ram- 8 gig crossair vengence 1600mhz
graphics card- 2 hd4780x2 4gig total
cpu-intel i7 920
power supply- 1000w

the problem I am haveing is i am lagging on every resolution at pretty much all settings...Is this because i simply popped in the hdd without a fresh install????

also how do i line up the ram? i have 2 sticks 4 gigs each...Do i put them in the blue slots??? or side by side




pleae help

More about : lagging games

December 8, 2012 4:50:28 PM

Probably the OS on the HDD had laptop software installed that limits performance to save power.Also there must be a driver mixture in there that lags everything.
Format it and install a clean new OS and see if it improves.
Getting the latest AMD drivers might help also.
December 8, 2012 4:53:28 PM

blacknemesist said:
Probably the OS on the HDD had laptop software installed that limits performance to save power.Also there must be a driver mixture in there that lags everything.
Format it and install a clean new OS and see if it improves.
Getting the latest AMD drivers might help also.

Thats what im hoping the problem is. seems these cards are not working to their full potential..i figured i could run bf3 on ultra but only on story mode. I updated all the drivers i could hopefully a reinstall is all thats needed
Related resources
December 8, 2012 4:55:52 PM

Before you do that, try getting fancy cache, and setting 3GB of RAM to be used as cache. I noticed no stuttering in games that used to have it heavily, like Fallout 3 and Skyrim, when using this program.
December 8, 2012 4:57:30 PM

MajinCry said:
Before you do that, try getting fancy cache, and setting 3GB of RAM to be used as cache. I noticed no stuttering in games that used to have it heavily, like Fallout 3 and Skyrim, when using this program.

it is at 3 gigs in cache :( 
December 8, 2012 5:16:42 PM

...Funky.

See if you can make a partition, then put your games on there, get FancyCache for Volume, then point it at the new partition?

OH! Before you do that, though, get Auslogics' Disk Defrag. Select your hard drive, choose 'Defrag & Optimize.*
a c 290 U Graphics card
December 8, 2012 7:21:16 PM

Reinstall windows. Before you do that, it's pointless trying to help you.
!