Sign in with
Sign up | Sign in
Your question

For everyone with stuttering problems in Far cry 3

Last response: in Video Games
Share
December 9, 2012 5:03:36 AM

Hello everyone,

As many of you have realized, even at high fps, the game still seems to have excessive stuttering issues.
Im sure a lot of people here already found a cure for the annoying stuttering issues found in far cry 3, however ill just post this up anyway for those who haven't.

Firstly my system specs are as follows:
cpu: i7 950 @ 4.5ghz
Ram: 2000mhz 12gb
Gpu: 6950 1gb

i know many of you did this, but it didnt work for me: install latest updates, patches, edited my catalyst control center settings, lowered all my details, and i still got stuttering, even at high fps my gameplay was still rubbish.

So the cure? i downloaded Dxtory 2.0 and limited my frames to 40(obviously if your using a higher end card, limit it to around 60). I also turned off vsync in the game and enabled triple buffering. This eliminated 80% of the stuttering. At the moment the game runs at a constant 40 even at ultra settings with direct x 11 enabled. Msaa still at 0 (higher end card might be able to run smoothly with msaa enabled, but as i am using a 1gb 6950, my card is maxxed out).

After reading few threads and forums, a lot of cards (including 680s, 7970s, 590s etc) are struggling to hit ultra settings at 1080p even with msaa turned off, dxtory has fixed it for me. I was quite puzzled when i saw the gpu recommended was a 6870, and my 6950 struggled even at the lowest setting, so it was obvious that its a software problem. Ive read a few people being disappointed in their 680s, and felt their cards to be insignificant however it is the game problem and not the card, so yea hopefully this helps.

Just a clarification, this doesnt increase fps, it eliminates stuttering found at higher detailed settings and results in a much fluent game play even at 30 fps. 30 fps without stuttering is better than 60+ fps with constant stuttering.
December 11, 2012 2:40:17 AM

Hey, I was have the EXACT same problem. I have an HD 6850, wondering what the hell was going on. This program works like a charm. I appreciate finding the fix and sharing it. I was just about the lose hope too. Haha.
December 11, 2012 3:18:45 AM

i heard this game is a bit problematic. luckily i haven't had those stutter problem with my cards. at least that is what i'm aware of when i play the game with my setup though i did use nvidia latest beta which has specific improvement for the game AO. also i heard weird issue with the game anti aliasing. for geforce user you can get better performance if you force the AA through driver instead using the in game option. some people reporting as much as 20 FPS increase when forcing the AA through the driver instead of using the in game option.
Related resources
December 11, 2012 4:14:32 AM

Amazing...this completely fixed it. And I have an old HD 5970. Running most things on High or Medium and its beautiful with none, or very little stutter. Since Dxtory is a trial I dunno if I will have to eventually buy it, but for now it fixes it. Nice work azed3000.
December 11, 2012 7:22:43 AM

Not a problem guys, I guess its mainly the amd cards that experience this issue, hopefully it runs beyond the trial period.

@renz469: Yea ive heard that as well, Msaa is just terrible in game, adaptive anti aliasing solved the issue for the nvidia cards, sadly amds dont have that feature.
December 15, 2012 4:52:00 PM

I'm not sure how to actually implement the Dxtory fix... I go to advanced (trial version) and cap video fps to 40 but i'm monitering in game fps with afterburner and its still fluxuating from 30-70 and stuttering a lot.
December 16, 2012 12:19:19 PM

r4mmr0d said:
I'm not sure how to actually implement the Dxtory fix... I go to advanced (trial version) and cap video fps to 40 but i'm monitering in game fps with afterburner and its still fluxuating from 30-70 and stuttering a lot.


Make sure the "limit fps video" check box is ticked before and after you start the game, sometimes dxtory resets to default when opening a new application. Just alt tab and check limit video fps again. Hopefully this works.

December 16, 2012 1:37:20 PM

I did something else that allowed me to stay at 60 FPS smooth without any outside programs. All I had to do was set the v-sync in game to 1 frame AND force V-sync in the CCC. When I tried each v-sync setting individually it still stuttered like crazy, but with both turned on most of the stutter went away(main town still has issues). Everything else in the CCC is set to "let application decide" and NONE of the additional check boxes are checked like morphological filtering, surface format optimization, or triple buffering. As for the ingame settings, I have AA turned off, post processing set to very high, and coverage(i think) set to normal instead of enhanced. I may of turned this option back to enhanced after I got rid of the stuttering. Oh and I'm running at 1920x1080(1080p).

Hope this works for other people too, because 60fps smooth is alot better than 30. My system is in my sig if anyone wants to know what I am running.
December 16, 2012 6:51:27 PM

i found a lot of people who suffer stutter have turned off the ingame reder ahead and set it to 0. the game is a lot smoother if its set to 1.
January 11, 2013 12:36:39 AM

For me, my computer specs were well above the recommended specs for far cry 3 and it was jerky even in the lowest settings

I am operating on:
Intel i5 150 @ 2.66Ghz
Win8 X64 bit
8gb ram
GTX 660

While i have attempted to set Vsync to 1, updated video card drivers and updated the game to its latest version, All that was to no avail. The game remained jerky as hell....

It was then i realized that my game was a 32bit version, whilst i'm running on a 64bit OS. So i reinstalled my game on Win7 X86 OS.

To my ultimate surprise, the game ran extremely smoothly and i can set the game to the highest settings without any stuttering!

So for those who has run out of all available options and realized that their FC3 is a 32bit version running on a 64 bit OS, you could try this out! Install the game on a 32 bit system instead and see if it works better


January 11, 2013 12:38:00 AM

For me, my computer specs were well above what was recommended for far cry 3 and it was still jerky as hell even in the lowest settings

I am operating on:
Intel i5 150 @ 2.66Ghz
Win8 X64 bit
8gb ram
GTX 660

While i have attempted to set Vsync to 1, updated video card drivers and updated the game to its latest version, All that was to no avail. The game remained jerky as hell....

It was then i realized that my game was a 32bit version, whilst i'm running on a 64bit OS. So i reinstalled my game on Win7 X86 OS.

To my ultimate surprise, the game ran extremely smoothly and i can set the game to the highest settings without any stuttering!

So for those who has run out of all available options and realized that their FC3 is a 32bit version running on a 64 bit OS, you could try this out! Install the game on a 32 bit system instead and see if it works better
January 28, 2013 2:33:50 PM

32-bit and 64-bit:

If anyone's still there...

Notes:
1. All games are 32-bit with very few exceptions. Why would they limit the install base to 64-bit Windows only? (eventually this will change but slowly)

2. 32-bit Windows supports 4GB memory total. This includes the System RAM and Video RAM and a few other things.

*The above guy has a 2GB Video Card, but he can only access under 2GB of his 8GB of System RAM if he uses 32-bit Windows. He won't have as much RAM as he normally would for Far Cry 3.

3. I'm not sure why FC3 ran better on 32-bit Windows but I doubt it's actually due to Windows itself. Probably a driver or other software issue that reinstalling Windows solved. Likely a fresh 64-bit Windows install would accomplish the same thing and improved performance a little by having sufficient System RAM.

SUMMARY:
Over 99% of games are 32-bit. This is the norm. The best Operating System is 64-bit Windows Vista/7 or 8. The differences between the three are minor for gaming. There's no advantage to 32-bit Window for gamers that I'm aware of.
January 28, 2013 6:44:19 PM

I'll post this here as this is the top result on Google.

I managed to solve all of my FPS drops by running the farcry3_d3d11.exe in the bin folder instead of the normal executable. Before this I had massive frame rate drops (around 60+fps down to single figures) any time I was driving a vehicle or climbing a tower. Now I'm getting a steady 50+fps on a GTX550ti.

:bounce: 
March 23, 2013 8:55:44 AM

This worked like a charm! For Steam players, the CD key wont work if you run farcry3_d3d11.exe but you can just rename it to farcry3.exe

Did notice however that when I'm on top of a tower, it's a lot more choppy than running in standard mode.


Agent_X_2_0 said:
I'll post this here as this is the top result on Google.

I managed to solve all of my FPS drops by running the farcry3_d3d11.exe in the bin folder instead of the normal executable. Before this I had massive frame rate drops (around 60+fps down to single figures) any time I was driving a vehicle or climbing a tower. Now I'm getting a steady 50+fps on a GTX550ti.

:bounce: 


!