Sign in with
Sign up | Sign in
Your question
Solved

BattleField 3 Lag/Stutter

Last response: in Video Games
Share
December 13, 2012 10:05:51 PM

So I have a new pc I just made in the past week.

Asus P8Z77-V LK
Intel i5 3570K
EVGA GTX 550 TI 2GB 192 bit GDDR5
2 x 4GB G.SKill Ripjaws Series
SSD Samsung 840 Series
WD Black 1TB Hard Drive (Running game with it)
Corsair TX650 Enthusiast Series

http://www.youtube.com/watch?v=L30OmOT2HSE

I've been playing BattleField 3 for a few days now without problems at all. Today I just started and for some reason I've been lagging when I move around.
It happens more often when I'm running then when I'm walking normally but still happens a lot regardless. Other people move around on my screen just fine. I'm running it on high/ultra but even on low it does it. My health when healing skips as well. I can shoot just fine. There isn't a time gap from bullets to start spraying from when I click the button.

When I should be moving forward it sort of moves up a little and pulls me back. You can see around 1:28 seconds when I should be moving forward but it doesn't. I checked and my video card is up to date.

Best solution

December 14, 2012 2:49:46 AM

xTheNewGuyx said:
So I have a new pc I just made in the past week.

Asus P8Z77-V LK
Intel i5 3570K
EVGA GTX 550 TI 2GB 192 bit GDDR5
2 x 4GB G.SKill Ripjaws Series
SSD Samsung 840 Series
WD Black 1TB Hard Drive (Running game with it)
Corsair TX650 Enthusiast Series

http://www.youtube.com/watch?v=L30OmOT2HSE

I've been playing BattleField 3 for a few days now without problems at all. Today I just started and for some reason I've been lagging when I move around.
It happens more often when I'm running then when I'm walking normally but still happens a lot regardless. Other people move around on my screen just fine. I'm running it on high/ultra but even on low it does it. My health when healing skips as well. I can shoot just fine. There isn't a time gap from bullets to start spraying from when I click the button.

When I should be moving forward it sort of moves up a little and pulls me back. You can see around 1:28 seconds when I should be moving forward but it doesn't. I checked and my video card is up to date.


Open up Nvidia Control Panel (Download it if you do not have it already).
Then go to Manage 3D Settigns, and make sure Battlefield 3 exe is added to the list.
Change Maximum Pre-Rendered Frames to "1".

I had same issue with my GTX 550 Ti, and this fixed things I think.
Share
December 14, 2012 3:12:58 AM

Interesting I would not have guessed DragonClaws fix, but give it a try for sure.
Personally that sounds like an internet lag problem, hows your ping?
m
0
l
Related resources
December 14, 2012 4:34:33 AM

DragonClaw said:
Open up Nvidia Control Panel (Download it if you do not have it already).
Then go to Manage 3D Settigns, and make sure Battlefield 3 exe is added to the list.
Change Maximum Pre-Rendered Frames to "1".

I had same issue with my GTX 550 Ti, and this fixed things I think.

I just did this and played a match. It seems to have fixed it. I'll test out more matches when I get time maybe tonight or tomorrow. Seemed good to go though. Thanx!
m
0
l
December 14, 2012 8:22:30 AM

Also, while playing on Ultra, make sure to Motion Blur "Off", and change Ambient Occlusion to SSAO, rather than HBAO.
m
0
l
December 14, 2012 8:31:30 AM

Rubberbanding is internet lag rather than anything else. Might have just been a heavy bandwidth day.
m
0
l
December 14, 2012 8:41:05 AM

darth pravus said:
Rubberbanding is internet lag rather than anything else. Might have just been a heavy bandwidth day.

But it happened with me while playing BF3 Single Player. The game was "Stuttering". FRAPS showed 40 to 50 FPS, but yet it was stuttering. And I could get over the problem by limiting pre-rendered frames to 1.
m
0
l
December 14, 2012 8:55:31 AM

Rubberbanding wont happen. as it getting massively pulled back.

Was anything overclocked?
m
0
l
December 14, 2012 11:28:21 PM

Best answer selected by xTheNewGuyx.
m
0
l
December 14, 2012 11:42:44 PM

I haven't overclocked anything and it wasn't regular internet lag because I was downloading torrents yesterday for around 2MB/s when I quit playing.

Thanx for help people!
m
0
l
December 15, 2012 8:50:20 AM

Bandwidth doesn't make lag, ping does.
m
0
l
December 15, 2012 6:18:36 PM

My ping is fine. 40 to 120 depending on which servers I played. It wasn't normal lag as I proved in the video with everybody else moving and me shooting normally.This stuttering problem is solved. Thanx.
m
0
l
!