Sign in with
Sign up | Sign in
Your question
Closed

Far Cry 3, Low FPS

Last response: in Video Games
Share
December 18, 2012 11:37:13 AM

I have an Alienware M14X with:

1G Nvidia Geforce GT 650M
i5-3210M @ 2.5 GHz
6G of DD3 ram

I read the system reqs. for Far Cry 3 and bought it because my settings seemed to fit in the "recommended" section.

Even on the absolute lowest settings, I cap out at 30 fps (according the fraps) looking at the ground.

Medium settings at a capped resolution (1366x768) I sit at 15-20 fps, not playable.

Does my new laptop suck that much it cant even run new games, is there something I am missing here?

Thanks, I really know very little about computers, but I do know this laptop is not cheap.

More about : cry low fps

December 18, 2012 11:50:34 AM

Actually, you barely reach minimum system requirements. Minimum stated is 8800 GTX, which has very similar speed to your GT 650M. The recommended is GTX 480, which is at least 4 times faster.

Anyway, are you playing on medium settings preset? Or did you configure it manually? According to notebookcheck.net, it should be playable on medium settings preset with little AF and no AA.

Just for future reference: laptops aren't really good at gaming. No matter how much you pay for it, a similarly priced desktop will be anywhere from 6 to 10 times faster.
Score
0
December 18, 2012 11:52:17 AM

Even on low, as is everything is turned off I get about 20 fps running around.
Score
0
Related resources
December 18, 2012 11:56:10 AM

Ok, something is wrong.

Download MSI afterburner from http://event.msi.com/vga/afterburner/overview.htm and install it. Launch the game, let it start lagging. Then, minimize the game, turn on MSI afterburner. Following that, go back to the game, run around for ~30 seconds. Finally, minimize the game and take a screenshot of MSI afterburner window. Upload that screenshot to www.imageshack.us (make sure to select "Do not resize" option!) and post the link to it here.
Score
0
December 18, 2012 12:37:18 PM

Ok, download is moving slowly, give me a minute. Thanks for your help.
Score
0
December 18, 2012 12:40:57 PM

No problem. Just post the screenshot when you're available. There's no rush :) .
Score
0
December 18, 2012 12:47:21 PM

I have the msi afterburner program running, but no data is appearing on the window, I must doing something wrong.

It is probably worth noting, I am getting these black squares in the game. They are transparent, but indicate a video issue I assume?
Score
0
December 18, 2012 12:51:24 PM

3 things you can try (although don't expect miracles here)...

1 - Install the Far Cry 3 beta drivers. They've been optimized the that game specifically. Link here: http://www.nvidia.com/Download/Find.aspx?lang=en-us

2 - Disregard this comment if you're using STEAM and auto-update. Make sure you have the latest Far Cry 3 patch installed. It makes a pretty good difference.

3 - Check out tweak guides. They'll tell you the usual stuff about which settings take more/less performance. Things like: Turn off VSync, lower AA, lower textures if you don't have enough VRAM memory, etc.

Hope this helped.

Alex
Score
0
December 18, 2012 1:12:23 PM

I think the driver update may be the problem (which would tie in with the strange video issue I am having)

The installer keeps failing when installing the new drivers. When I was installing Far Cry 3 through steam, towards the end of the installation I got a pop-up for a new video card update.

The installation gets all the way at the end, but I get an error message indicating:

Nvidia Installer failed

Nvidia Update 1.11.3 .... Not installed
PhysX System Software 9.12.1031 .... Failed
HD Audio Driver 1.3.18.0 .... Installed
Graphics Driver 310.70 .... Installed
3D Vision Driver 310.70 .... Not installed

Now that I type this all out in front of me, if the graphics driver was installed, would this make the installation successful for my purposes?
Score
0

Best solution

December 18, 2012 1:36:22 PM

It's successful. Could you try run the game by right clicking on its icon, and selecting the option to run using high performance nvidia graphics adapter (should be worded similarly, may not be exact phrase)?
Share
December 18, 2012 1:52:16 PM

That option is not available when right clicking, I have the game on steam, and even with a desktop shortcut the option is not available. Not to mention, the game actually launches from uplay, which again, not available from launch.

Are you getting at the game could be playing from my integrated chipset? I noticed there was a Intel (R) HD Graphics 4000 display driver in the device manager.
Score
0
December 18, 2012 2:04:08 PM

Yes. That's exactly what I'm thinking what is going on.
Score
0
December 18, 2012 2:11:16 PM

SOLVED:

For those with the same issue, here was my solution:

Right click on any other game (I used Diablo 3) select run with graphics processor -> Change default graphics processor..

From here you can choose which programs use the nvidia GPU, and those using the integrated chipset. I selected steam from my list of programs on my computer, but not 100% sure this applies to all steam games, or just the steam app itself.

From here, just "add" the steam game you want to be playing off the high performance processor.

C: > programs files > steam > steamapp > common > far cry 3 > bin

from here I just added everything onto the high performance processor (the menu is ALOT smoother)

Sitting at 30-50 fps at capped resolution for my laptop and medium settings.

Thanks Sunius!
Score
0
December 18, 2012 2:11:30 PM

Best answer selected by atari101.
Score
0
December 18, 2012 2:22:52 PM

I'm glad I was able to help you :) .
Score
0
!