Sign in with
Sign up | Sign in
Your question

USB Audio problems

Last response: in Windows 7
Share
November 1, 2010 9:36:30 AM

This is purely informative as I formatted already but wondering if anyone else has this problem and if there is a working solution for the problem.

Ok so I have a Logitech Clear chat comfort usb headset.
On my one system windows7 64 the headset works fine for like 2 months then it just stopped working...
I looked for a reason why and couldnt find anything wrong, windows recognized it as being there, said drivers were installed and it was working ok(So they say!)
Tried different ports etc.

I tried it on other systems including another win7 64 bit system and the headset works fine there.

I can not set it as default or disable my hdmi audio on my ati hd5670 either.
I tried enabling/disabling none of that worked. Eventually sound stopped working completely. Yuck!

After much research seems to be a bug with usb audio that has been there since windows vista with the fix being to replace the driver with one from XP.
I dont have 64bit xp to get a driver from so I ended up formatting and reinstalling.

So my question is for future reference. Reinstalling is a real hassle and I would prefer not to repeat :/ 

More about : usb audio problems

a b $ Windows 7
November 1, 2010 10:48:44 AM

When you get all your software reinstalled create a restore point or a disk image of where you are at. Then next time restore from the restore point or rewrite the entire drive using the disk image.
m
0
l
November 8, 2010 12:25:46 AM

I wish it was that easy.
It was over a month before I noticed the problem, either that or system restore did not resolve the issue, I went as far back as a month and no go.
Normally I just play hooked up to my 7.1 receiver so I failed to notice the problem for a while.

No one else has had this problem ?

I saw on the web other people having this problem but the only solution was to replace the usbaudio.sys from windows XP and since this is the 64bit version I would need a 64bit xp version of usbaudio.sys which I do not have.

There must be another way of fixing this problem.
m
0
l
!