Sign in with
Sign up | Sign in
Your question

Far Cry 3 stutter/lag spikes! Please help!

Last response: in Video Games
Share
December 24, 2012 7:41:50 AM

Just what the title says, I'm getting stuttering and lag spikes while playing Far Cry 3 even though my PC can run BF3 on ultra without any issues. :( 

PC specs:
Intel i7 2700k
GTX 670 sli (x2)
16GB Ram
Windows 7 64bit

P.S I'm also running the latest Nvidia driver (310.70)

Please help I would really like to have the stutter free Far Cry 3 experience.

More about : cry stutter lag spikes

December 24, 2012 7:44:41 AM

Have you tried disabling SLI?

Also, you say the latest drivers, are they the latest beta drivers?
m
0
l
December 24, 2012 7:50:57 AM

Everybody is having this. Your system is almost identical to mine. Have a look at this thread, which I started.

https://forums.geforce.com/default/topic/525875/pc-game...

Basically the problems are as you describe, terrible and inconsistent performance. Low frame rates when enemies appear.

The game just runs badly, although there is little consensus on whether the game or nVidia's drivers are at fault. There's a tendency to suggest that it's the game because AMD users are having similar issues.

In terms of the problems themselves, the SLI profile doesn't work properly, MSAA in game is broken and shadows result in excessive CPU load.

Various solutions have been found to help.

Load the custom SLI profile that's been knocking around (google it). Load it in NVInspector.

Disabling SLI results in more consistent, although not better performance.

Turn off in game MSAA and over-ride the game's anti-aliasing from within NV control panel.

Turn shadows down to medium.

Write to Ubi Soft and tell them that you don't appreciate them launching games with beta code.

Good luck
m
0
l
Related resources
December 24, 2012 8:28:37 AM

Thanks for the quick replies, I will try those solutions as soon as possible.
And also, no I am not running the beta drivers.
m
0
l
December 26, 2012 3:30:42 AM

I've tried all the suggestions above and my game play has improved significantly, but none have actually fixed the stuttering. Has anyone completely managed to eliminate the stuttering?

P.S I've also tried playing on a lower setting and this is just disappointing, considering I have one of the higher end cards. :( 
m
0
l
September 30, 2013 10:27:55 PM

Try HiAlgoBoost or HiAlgoSwithc... It should remove your lag spikes.

HiAlgo SWITCH v0.1 released. What it does: toggles resolution with a click of a button. Works for DX9 games.

Verified so far (on an AMD Graphics card):
m
0
l
October 1, 2013 2:11:13 AM

This is why i dont buy games from big studios anymore. no battlefield 3 or 4 for me, no farcry 4 no crysis 2 or 3....

Those games are terrible when it comes to optimizations (console ports, etc, etc).

Since I dont think you can actually sue them for this, I decided to simply stop buying their games.

Im quite sure sooner or later someone will make a hotfix or a mod to improve it, but im afraid for now you are stuck with that.
m
0
l
October 1, 2013 2:19:09 AM

WEll, far cry 3*
m
0
l
November 11, 2013 2:36:29 AM

cats_Paw said:
WEll, far cry 3*


SHUDH DESI ROMANCE
m
0
l
January 10, 2014 7:29:17 AM

Has anybody tried Hialgoboost for Far Cry 3 to increase fps?
m
0
l
January 17, 2014 10:41:22 AM

Alexander Tsodikov said:
Has anybody tried Hialgoboost for Far Cry 3 to increase fps?


Just gave Hialgoboost a test run, it increases fps on the fly by destroying image quality, and in fact lowered my fps 85fps without, 72fps with....
m
0
l
January 17, 2014 2:04:09 PM

@Marlonius What is your PC spec? Is't GPU limited system?
m
0
l
January 17, 2014 6:48:00 PM

Alexander Tsodikov said:
@Marlonius What is your PC spec? Is't GPU limited system?


AMD FX4100 @ 4.4Ghz, 8GB DDR3 @ 1866, ASUS 7770Ghz @ 1120mhz Core & 1650mhz on the GDDR5, dont really need that program just thought I'd give it a whirl. I wasnt joking tho, it kills the image quality to achieve its supposed performance gains.. much better off dropping the resolution a bit and dropping post processing, shadow and object quality down, at least then you still have something half decent looking.

m
0
l
March 10, 2014 3:18:32 AM

Have you done this: go into AFTERBURNER and enable the frame limiter at 60 FPS then ENABLE IN GAME VYSNC in game and its buttery smooth, this is what used to be done in Elder Scrolls Skyrim to get that to work perfectly.

Or:

Changing D3D11MultithreadedRendering="1" to D3D11MultithreadedRendering="0" in the GamerProfile.xml file

i bet this will help because it solve my issue gtx 770 sli i m getting constant 80-90 with stutter free
m
0
l
March 10, 2014 12:55:26 PM

How does this thread just keep on going?!
m
0
l
March 11, 2014 2:38:44 AM

Because people want a batter gmaing expirience from their game? :D .

I think Khan might be up to something usefull here :D .
m
0
l
March 11, 2014 6:01:06 AM

cats_Paw said:
Because people want a batter gmaing expirience from their game? :D .

I think Khan might be up to something usefull here :D .


Thanks for Appreciate Me :ange: 
m
0
l
March 11, 2014 1:18:20 PM

cats_Paw said:
Because people want a batter gmaing expirience from their game? :D .

I think Khan might be up to something usefull here :D .


My point is that this thread is 15 months old!
m
0
l
!