Sign in with
Sign up | Sign in
Your question

Swtor fps help

Last response: in Video Games
Share
December 29, 2012 4:44:07 AM

Hey, wondering if anyone can help with a problem i have been having with my game,

System Specs: AMD FX 6 core @ 3.30 Ghz 8GB of ram Radeon HD 7750 with 1 gb of ram. Windows 7 64 bit 12.10 amd drivers

I got black ops2 for Christmas and couldn't play it after finding out the problem was a BIOS that needed an update now i can play black ops perfectly at high settings, now i cant play SW at all, the game takes 4 mins or more to load and 4 mins or so on each load screen when i get in game even with settings turned to the lowest i only get 30 FPS on my ship and 1-10 FPS in Ops, rendering the game virtually unplayable. i have take the computer apart and put it back tested all of the hardware (functioning properly) and rolled back drivers on the video card to 12.8 and up to 12.11 beta nothing works. even reformatted the hard drive and re installed windows. this whole time i am able to play black ops with out any load times and high settings. i tired almost all of the fixes i can find on the forums, checking to make sure the game is suing my processors, all of the video setting are where they are suppose to be. before black ops and the BIOS update i could play star wars beautifully 30 sec or so load times and high settings no FPS lag what so ever, could do ops on high settings and not have a problem, I've exhausted all of my know how to fix the issue and it still exists, i don't think that it is a hardware problem (or i wouldn't be able to still play black ops 2) any help or suggestions would be useful. i have also used the repairer to try and repair SW to no avail

More about : swtor fps

December 29, 2012 6:44:10 AM

First, a bit of advice about posting: It would be nice if you could separate big paragraphs you write in the future, into smaller chunks so they're easier to read ;)  .

Now onto your problem. Did you check you had the latest patches of both games before taking apart the hardware of your machine? Maybe Black Ops 2 or SWTOR has a bug in it which is causing the problem.

Why would you need to do a BIOS update to run Ops?? What would happen when you tried to run the game before updating? What error message did you get?
December 29, 2012 8:13:55 AM

Sorry was typing on my phone, black ops was causing a timing error and a bsod, something in the old BIOS wasn't allong it to run properly.

Yup had all of the latest patches
Related resources
December 29, 2012 8:18:59 AM

A CPU Timing error if I remember right
December 29, 2012 11:30:25 AM

And then after you did the update, SWTOR wasn't running correctly, am I right? Was it just getting stuck/freezing or not running at all?
December 29, 2012 11:40:29 AM

After the update swtor will run but at extremly low fps, makin it unplayable
December 29, 2012 11:41:26 AM

Very long load times also
December 29, 2012 12:33:04 PM

Tried changing around the video settings?
December 29, 2012 12:44:34 PM

Yeah I get the same performance at high or low setting virtually no changes (game looks better standing still) but still the same problem
December 30, 2012 2:25:08 AM

Really, I'm not sure what to do then. Try contacting SWTOR support.
!