Sign in with
Sign up | Sign in
Your question
Solved

La noire character cant stop running

Last response: in Video Games
Share
December 29, 2012 6:59:42 AM

Just got LA Noire Complete on Steam, and I have 0 problems with any other Steam game (or any game that I play, including GTA IV) but for some reason, when I try to move in any direction, my character won't Stop Running until he runs into a wall or other large object. He gets stuck in spots in the alley, still trying to run mind you, and I can't get him out and have to start over when that happens. I'm still stuck in the first alley where the game starts, and yes I have been hit by a car because of the whole out-of-control running thing. Any help would be greatly appreciated. I'm running Windows 7 64bit Home Premium, I7 980X, ATI 5870, etc.
December 29, 2012 7:33:30 AM

Are you using any controllers like Xbox 360 controller or steering wheels?
m
0
l
December 29, 2012 8:34:39 AM

i've had that problem with my gamepad..but not sure why it happens..
m
0
l
Related resources
Can't find your answer ? Ask !

Best solution

December 29, 2012 8:49:53 AM

With certain controllers connected to the PC (e.g. Wheel or Flight pedals) a bug can occur whereby even with controller set to disabled in the game menus the game still tries to accept controller input for some game controls and ignores keyboard input. Most notably this occurs when trying to drive cars. You will be unable to drive forward or backward as long as the problem controller is plugged in to the personal computer.

Fix Force controller Detection To Be a Default USB Device

Open the game launcher.
Click Options.
At the bottom where it says "Command Line", add -joysticktype 1
Click OK.

Quoted from pcgaming wiki.:) 
Share
December 29, 2012 5:32:29 PM

absxiith said:
With certain controllers connected to the PC (e.g. Wheel or Flight pedals) a bug can occur whereby even with controller set to disabled in the game menus the game still tries to accept controller input for some game controls and ignores keyboard input. Most notably this occurs when trying to drive cars. You will be unable to drive forward or backward as long as the problem controller is plugged in to the personal computer.

Fix Force controller Detection To Be a Default USB Device

Open the game launcher.
Click Options.
At the bottom where it says "Command Line", add -joysticktype 1
Click OK.

Quoted from pcgaming wiki.:) 


I'm not using any other controllers. I have a Microsoft Ergonomic Media keyboard and a Logitech MMO mouse (the one with the 12 key keypad on the thumb side). :( 
m
0
l
December 29, 2012 8:03:40 PM

Update: I thought I had unplugged my joystick and throttle a good while ago (X52 Pro Saitek) but hadn't, and it was indeed interfering with the keyboard controls even though I had joystick off etc in the settings of the game. Thanks for the help, the game runs just fine now and is a lot of fun :) 
m
0
l
December 29, 2012 8:12:42 PM

vidharr said:
Update: I thought I had unplugged my joystick and throttle a good while ago (X52 Pro Saitek) but hadn't, and it was indeed interfering with the keyboard controls even though I had joystick off etc in the settings of the game. Thanks for the help, the game runs just fine now and is a lot of fun :) 

glad your problem was solved..you can select absxiith's answer as best answer
m
0
l
December 29, 2012 8:26:51 PM

Best answer selected by vidharr.
m
0
l
December 30, 2012 5:40:55 AM

Thank you,vidharr!:)  I too have a gaming wheel and faced the same problem when I installed L.A.Noire -the complete edition (disc version)...Glad I could help.:) 
m
0
l
!