Sign in with
Sign up | Sign in
Your question

My PC games are lagging. Why?

Last response: in Video Games
Share
December 31, 2012 3:53:29 AM

So this one game, assassin's creed revelations, is lagging and I'm wondering why. I have an Intel Core i3-2120 CPU @ 3.30 GHz, 6gb of ram, 64-bit operating system, an ATI radeon HD 6850 video card, and windows 7 operating system. I went on game debate and systemrequirementslab to see if I can run it. Both sites said I can run it very well at the highest settings. I put it to the highest settings and it lags. So why does it lag?

More about : games lagging

December 31, 2012 9:50:59 PM

Try updating your AMD drivers maybe?
m
0
l
December 31, 2012 10:25:14 PM

I doubt very much your system is up to the challenge of the highest settings at 1080p. Maybe at 720p, but not 1080p. People often get over zealous in their idea of what is playable. For some, people consider 20 FPS playable, but most people don't find anything but 40+ playable. I personally need 60+ to limit nausea and 80+ to remove it.

Looking around, it would appear you may have average FPS that make it playable with that setup, but it will have minimum FPS in the 20's, which is not and will feel like lagging.

I'd suggest dropping AA to 2x or 4x and see how it goes. 8x MSAA is a huge waste of power.

m
0
l
Related resources
January 2, 2013 1:36:10 AM

A 6850 can't max out AC: Revelations. You need to lower the settings. CYRI and GameDebate both just kind of roughly estimate. CYRI said my old laptop could run GTA IV, and it most certainly couldn't. It had an AMD Athlon II 1.8GHz and ATI Radeon Mobility 3100. CYRI said I was tiny bit below recommended. It seems to base the entire GPU score on amount of VRAM.
m
0
l
January 2, 2013 8:19:05 AM

dont hope to much from a suggestion on internet about your hardware can play a game and he is right about jealousity i play it on 20 FPS and its okay for me!

and you can lower the ressolution and frustate about tiny screen?? you can change option in the desktop,change the center to scratch or you can do some experiment yourself...
m
0
l
October 22, 2013 10:18:59 AM

try some software and tricks
application
advanced system care software download install run scan and in turbo boost menu try the new gaming mode and use asc power mode
some useful tricks
1.go to task manager turn off unnecessary processes
2.go to start>run type msconfig.exe>hit enter
in start up tab disable apps u use frequently
in service tab click the box hide microsoft services and then disable services also
3.defragment your disk regularly
(optional)try ready boost go to the link http://windows.microsoft.com/en-us/windows7/products/fe...
this will help you
m
0
l
!