Minecraft Multiplayer Server Problem

I've recently built a rig and me and my brother wanted to play minecraft together but the problem is when I create a server I can login to it without a problem, but when my brother tries to connect it gives "refused to connect" error.. We don't have a router so there's no need to forward ports right? correct me if I'm wrong.. By the way he is using a laptop and a dsl line is hooked up on it and we used connectify to share the internet.

I am using usb tether to make my android phone as a wifi dongle.. is that causing the problem? But if I make the server on hamachi, we can play but it has a delay like I can move but on his screen my player is just standing, after a few minutes it's working but after a few minutes again it comes back to the delay problem.. I'm also running a similar problem with warcraft 3, my brother can't see the game I've hosted.. any Ideas??
9 answers Last reply Best Answer
More about minecraft multiplayer server problem
  1. By the way he is using a laptop and a dsl line is hooked up on it.
    - If you're using a xDSL service then you will need to forward ports.

    Tell your brother to host the server and forward the ports on his DSL 'combo router'.

    If Hamachi resolves it (sort of) then the problem is almost definitely a port forwarding issue.

    A cell phones processor isn't designed for use as an Internet router, so I wouldn't even consider that as a 'workable' option.
  2. What's an xDSL? as I've said we have no router so the connection is telephone line>modem>laptop>connectify.

    I'm not using my phone as an Internet Router but as a wifi adapter.
  3. is your config file set up to accept non-local connections? it is always by default set to not accept incoming so make sure that is changed.
  4. how do I change that? sorry for the noob question..
  5. Best answer
    ill have to check my config when i get home, but normally there there is a config file in the main directory of the server files where you open with notepad and you look for a line that has something about incoming connections and you will have to change the default setting, i think it is set to true and needs to be false, but again ill have to double check in the morning when i get home
  6. there is no allow incoming connections, are you referring to online mode?
  7. that could possibly what im thinking of. still havent had a chance to check, I work midnight shifts and normally am sleeping throughout the day, barely have a chance to glance at my PC
  8. Ohh that's ok, I've managed to make it work but the server is on the laptop not on my desktop. Still have delays though.. Don't know if bug or because my phone can't transfer connections fast.. I'll maybe just buy an usb wifi dongle if I have the money and test if it works. Thanks anyway!
  9. Best answer selected by ziLaO.
Ask a new question

Read More

PC gaming Minecraft Servers Video Games