Sign in with
Sign up | Sign in
Your question

Gameplay Lag

Last response: in Windows 7
Share
October 22, 2009 12:30:19 AM

So, I won't waste your time with filler except to tell the guys that have taken their time to look at this thank you. My problem is that whenever I play a game in Win 7, any game except for Halo 1, I get gameplay lag. By that, I mean that when I move my mouse, the game mouse will move in real time. But if I were rotating the screen, the screen would actually rotate half a second later or more after I had moved the mouse. This occurs with my touch pad and my wired Logitech MX518 mouse. The same goes for my keyboard. If I press the key to move up, my character responds half a second or more later. In Halo 2 and other games without a visible cursor, the cross-hairs move with the same delay. This problem only occurs when my FPS<30, which is almost all of the time, and sometimes even when my FPS is in the 40's, 50's, or 60's. It get's worse as FPS decreases. It has made all of my games unplayable, except for Halo 1 and World of Goo. This problem only occurs in Win 7 and Win Vista (no longer installed). It did not occur in Win XP (also no longer installed) regardless of what display driver version I used, at a time I even had two different mouse drivers on XP and still experienced no lag. I don't intend to go back to XP.

I have tried many different display driver versions including Vista versions, including version 167.58 for Vista (this version was the optimum one for my XP instillation), and Win 7/Vista. I have tried no mouse driver installed, and have tried changing the USB Mouse polling rate. I have tried using Nvidia Control Panel and RivaTuner to set pre-rendered frames to 0, added RAM to store textures, checked the option to "limit the maximum number of queued blits to the frame buffer," VSYNC is disabled, antialiasing and anisotropy are off. Essentially, all driver options are set to performance and not to pre-render anything, all to no avail. I believe the problem lies within Win 7 or the driver settings, but nothing I do seems to work.

Here is my relevant computer info:

Video Card: Geforce Go 7200 (GPU Clock - 580 MHz, Mem Clock - 720, 64MB dedicated) - ForceWare 179.67
CPU: AMD Turion 64 X2 TL-60 @2.00 GHz (I have even tried using the dual-core optimizer)
Computer Model: HP Pavilion dv6400a ("Entertainment PC" my butt)
RAM: 3GB DDR2 single channel @667 MHz

Ask for anything else you need from me (except for SSN or Credit card numbers :ange: ).

As a side note, this computer came pre-installed with Win Vista and this problem has been there since they day I had it.

More about : gameplay lag

October 26, 2009 1:29:07 PM

Changing from Win 7 x32 to x64 helped tremendously. However, there is still lag when the fps dips below 30, and it isn't too bad until it gets below 25. Any suggestions?
October 26, 2009 2:41:38 PM

I think you can try different driver version and see if it fix problem.
Related resources
October 28, 2009 1:26:27 PM

I'm using Dox's Customized Driver 185.85 and they helped completely eliminate mouse lag in most of my games, and in all of my games, I no longer get lag above 29 fps. However, there is a slight lag in some of my games, not all anymore, when the fps dips below 29. Mirror's Edge, it's still playable, DMC4, and sometimes in Cabal Online, although it is rare now. I haven't played Halo 2 or GoW in a while, so I haven't checked those ones.
October 28, 2009 2:54:39 PM

take a look at the card your using.

7200.

Not exactly a monster.
October 29, 2009 12:15:35 AM

Well, no, but I'm not looking for great quality. Most of the games I play are on their lowest settings (except for Halo, but it doesn't demand much), and the only reason why I'm posting this is because the problem is not the card (this problem does not happen in Win XP), the problem lies in drivers for Win 7, and I'm trying to figure out exactly what that problem is.
October 29, 2009 2:34:53 AM

Found the fix, if anyone else is having this problem, read this easy solution.

I read this on a forum somewhere that multi-cores may be the cause of the problem. Essentially, the game executable is passed from core to core, causing extra overhead. This is not a problem if your CPU is fast enough, but apparently, mine isn't.

How I fixed it: I set the process affinity to 1 core, I chose the second core (Core 1, I have a dual-core), as this core has less traffic than the first. Upon playing the game, I get absolutely no lag, none. It's even better than in Windows XP. Some of you may consider that troublesome to do every time you start a game, I don't care. I have zero lag and I'm happy.

To change process affinity, just open task manager, right click on the game process, and click "Set Affinity" and set the core(s) you want the process on.

Problem solved. :D 

Edit:

Problem partially solved. Capcom games (SF4 and DMC4 still have lag, even when running above 30 fps). I haven't tried any other games yet, but this is turning into a conundrum.

Edit Edit:

Turning off threaded optimization in the NVIDIA Control Panel under "Manage 3D Settings" helped so much. So far, no lag above 29 fps. No lag whatsoever in some games. Still have lag in DMC4 and SF4 under 30 fps, no matter what I do to my processors, so I suppose that's a graphics card issue. I do recall having lag in DMC4 in Win XP, but I don't remember to what extent. It's no biggie, DMC4 rarely goes below 30 and SF4 never (unless I increase the resolution) goes below 30. I haven't tried Halo 2 yet :( . That'll be the real acid test because Halo 2 was pretty much lag-less in Win XP even at 13 fps (yes, I know my gfx card sucks, I'm getting a new one within the year).

Edit Edit Edit:
Gears of War is lagless, even at 15 fps (which it rarely gets to, but is nice because my aim doesn't suffer too much except from the jittering at lower fps). It's even better than in Win XP. Haven't tried Halo 2 yet, but I don't expect any lag at this point.

Final Edit:
Halo 2 still lags in the same way DMC4 lags D=. It is a problem in this case because Halo 2 is an fps and it makes it horrible to aim (and impossible to snipe fast moving targets) I'm out of ideas.
November 8, 2009 10:12:35 PM

bump
December 16, 2009 9:23:20 AM

I have this EXACT same problem down to the detail! I've been dealing with this since Vista. It only happens in Vista and Windows 7 for me too, XP is normal. Vsync is forced off in-game and NVIDIA control panel, pre-rendering set to 0-1, and it still has that ANNOYING delay in the mouse and keyboard even at 50+ fps! At 30fps there's probably near a half second delay, and 10fps is like a whole second. I play mostly just Oblivion, but Fallout 3 was 2x worse on the problem even at HIGHER FPS than Oblivion was getting! This has got to be my #1 grudge against both new OS' Vista and 7 - the input/display delay. It makes things either unenjoyable or unplayable.

I just tried your fixes and a bunch of combos of them, and I have both good and bad news. The only thing affecting it for me on Oblivion, is setting the affinity to one core in task manager. The good news is setting it to 1 core has dramatically gotten rid of mouse lag, BUT the bad news is I'm getting 10-20 lower FPS than before, however even at 25 and below fps, there was NO delay! Compared to before at 25fps where it was nearly a second of delay, I think I'd take the lower fps over that. There's more bad news: in certain times in the game, almost reproducable, it seems to jump back into both affinities and delay again for a moment.

With your fix working for me, I'm starting to make some conclusions: I've found out in testing that setting max pre-rendered frames in NVIDIA control panel even to max of 8 makes NO difference in delay (shouldn't it delay horribly?). I'm starting to believe this is an NVIDIA driver bug where that setting is "internally" STUCK at whatever value, I'm assuming a high one judging by the HUGE delay. Is NVIDIA/Microsoft trying to cheat their frame rates by making huge forced delays? I'm thinking it's either that, or something in the way multicore is handled in Vista/7. The pre-rendered frames are done by the CPU, right? I would say we're on to something both ways.

Oh also something similar, Vista and Windows 7's Aero both force v-sync on ALWAYS, even when it's globally forced off in NVIDIA control panel. If Aero is on and you're playing in window mode, expect vsync delays! Turning off Aero (aka desktop composition) will disable the desktop vsync. I'm not completely sure yet, but I think fullscreen applications aren't affected by Aero's vsync, but if in doubt you can try it both on and off and see if you notice any difference.

The way I test for delays is pretty much by watching my mouse hand move, then out of the corner of my eye I can see the screen move a bit after (or a second after, as it can get to be). Keyboard testing works the same way.

CONCLUSIONS:
[MOST LIKELY]
- XP pre-rendering setting works only on the global settings (in 3D settings) tab.
- Vista/7 max-prerendering setting doesn't work at all, possibly "hardcoded" in the driver.
[LESS LIKELY]
- Possibly multicore CPU handling in Vista and 7 are causing delays.


This really bugs me and is the main reason I continue using XP!

EDIT: I did more testing the next day, and I found for Windows XP, the pre-rendering setting doesn't seem to work per-application. You have to set it globally for it to work. Vista and 7's pre-rendering settings don't work no matter what, and it might be a good idea to bring up with NVIDIA. Also, setting pre-rendering in RivaTuner doesn't seem to work in 7 either.

Here's my relevant specs:
Windows XP x86, Windows 7 x64
AMD x2 5000+
Geforce 8600GT (driver is forceware 195.62)
2GB ram
January 9, 2010 8:07:08 PM

I recently built a new computer with a Radeon HD 5770 and AMD Athlon II X4 620. I never get mouse lag even down to the teens in either Windows 7 or Windows XP regardless of quality settings (Crysis is the only thing that brings it down, in case your wondering what could tax a 5770 that much). I guess it has something to do with NVIDIA's drivers, as I can't think of anything else seeing as the processor is from the same company. But, I don't have time to uninstall and install a bunch of different driver versions to find the one that fixes the problem...
January 10, 2010 4:53:48 AM

I'm pretty sure it's the pre-rendering being forced stuck in the NVIDIA driver on Vista/Windows 7. I definitely wouldn't go through the trouble of installing/uninstalling drivers either. The delay has been a problem since Vista, and it's carried on to Windows 7 and still going, so yea. I guess I should try reporting it on NVIDIA forums. I'll link here it if I do.

Well I'm glad ATI doesn't do it, thanks for reporting that. My next card is going to be an ATI, so I'm glad to hear that. Maybe then Windows 7 will be reasonable. :)  My current one, Geforce 8600GT, has popped 3 capacitors (the pop sounds like a BB gun, very loud), and I've been waiting for it to kill itself and become UNVIDIA (a friend came up with that hahaha). The one I had before this was a 7600GT, same thing happened, and both lasted like only a year.
April 17, 2011 11:57:52 PM

Thanks, I'm gonna try these methods rightaway. What I found over the internet is that setting prerendering in nV drivers for WinXP works with both OpenGL and Direct3D games, while in Vista/7 it actually works only with OpenGL. Even though - it still doesn't solve the problem. Setting that option to 1 improves a lot, but not as expected. Setting it to 0 mostly crashes games when performance drops below 60fps.

What's weird is that I got that problem on my Asus 1215n netbook with ION2 platform, which is combination of 2 graphic chipsets:
-Intel GMA900 (or so) which runs great, perfectly lagless, but its performance is crappy.
-GF218M (naming is totally ridiculous) which lags like hell.
So on the same system, two different cards work very different. The strange part is that my previous netbook 1201n with ION (1) didn't make that kind of problems, despite the fact, that it had similar dual core proc with ht (2x2threads), same amount of RAM (2GB) with also Win7 x86 installed.

I guess the problem is some mix of V-Sync, Windows Aero, weak multithreaded CPU, and prerendering limit problems, and ABOVE ALL: CRAPPY NVIDIA DRIVERS. Hope they'll solve the drivers soon enough.
!