Sign in with
Sign up | Sign in
Your question

[PC Gaming] Skyrim is CHOPPY.

Last response: in Video Games
Share
January 2, 2013 6:38:58 PM

Hey guys, I just installed Skyrim, and no watter what, my Y axis is INCREDIBLY choppy when I move, as if I'm running down stairs. Its only slight on the X axis, and even less all around in 3rd person, but its so annoying, it's keeping me from playing the game altogether. I updated, but nothing helped. All my other games run pefectly fine, ultra smooth, great graphics, but Skyrim just doesn't manage. Occasional texture glitches, and this choppyness is just making the game unplayable.

Anyone know a solution for this? please help.

AMD 7870
i5 3550
8gb RAM

More about : gaming skyrim choppy

January 2, 2013 6:51:25 PM

Im using 7970 in Trifire and fps was between 5 - 15. I fixed mine by turning off Morphological in CCC under 3D application settings, also make sure the filter is on standard
m
0
l
January 2, 2013 7:22:35 PM

Metwingie said:
Im using 7970 in Trifire and fps was between 5 - 15. I fixed mine by turning off Morphological in CCC under 3D application settings, also make sure the filter is on standard


My Morphological is already off.
m
0
l
Related resources
January 2, 2013 7:47:06 PM

Limit your fps to 57(or around this area) and stuttering should go.
You can set fps limit with applications like MSI Afterburner.

Also what driver version are you using?
m
0
l
January 3, 2013 3:22:59 AM

Damn, I've heard of this problem before and there was an easy fix for it, but I forgot since it never happened to me. Try researching some more on the problem, I know for a fact that there is a setting you have to tweak (I believe somewhere in config?)
m
0
l
January 3, 2013 7:39:48 AM

Drivers fine, and I can run max settings, I do on all my games. It's just odd, even my ISO cracks are smoother than butter. I've messed around with some aliasing, and got it
Toned down a little smoother, but it's just finer, faster chops.
m
0
l
January 4, 2013 2:14:57 AM

Best answer selected by _s0ap.
m
0
l
January 4, 2013 2:15:47 AM

Quote:
Kind of sounds like micro stuttering. Have you set CCC to default and let apps choose settings? Maybe go onto the nexus website and download this mod: http://skyrim.nexusmods.com/mods/48



It worked!!!! thes just the ever so slightest chop, but i think its the mouse, and I'm getting a new mouse this week. But thank you!!!!!!!!
m
0
l
!