Sign in with
Sign up | Sign in
Your question

Stupid decision

Last response: in Video Games
Share
January 8, 2013 1:38:46 AM

So I was having a problem which I made in an earlier post, but because this is a new error I stupidly made I decided to make a new thread.

My PC was using my intel integrated 4000 HD graphics instead of my Sapphire HD 7970 and was therefore running Skyrim at about 10fps. I was recommended to try disabling Intel graphics in device manager, but upon doing this my monitor just went to power saving mode and will now show nothing. Abosolutely nothing. Other people go into safe mode to fix this but I can't.. Any suggestions?

More about : stupid decision

January 8, 2013 4:46:30 AM

go in to your BIOS and you can disable the integrated graphics from there, this will default the PC to use the add-in GPU.
m
0
l
January 8, 2013 5:33:43 AM

Even when I CAN see my screen It's hard to get into BIOS because it turns on too fast, and even if I did get into BIOS I can't see anything my monitor just goes to power saving mode (black)
m
0
l
Related resources
January 8, 2013 6:14:49 AM

ijohn said:
Even when I CAN see my screen It's hard to get into BIOS because it turns on too fast, and even if I did get into BIOS I can't see anything my monitor just goes to power saving mode (black)


try reseting your BIOS by removing the little battery it has for a couple of minutes, then put it back in and your BIOS settings should be returned as they were in the start.

DON'T DO THIS WHILE THE PC IS ON!!!
m
0
l
January 8, 2013 10:22:05 AM

and don't forget to put the video cable to the card and not to the motherboard video output...
m
0
l
January 8, 2013 11:46:26 AM

^
+1

What Stupido says is true. The only way you could have had that happen if you connected your monitor to the motherboard instead of the graphics card. Connect it to the graphics card and your problems will go away.
m
0
l
January 8, 2013 11:53:12 AM

if the monitor is coming on then going off just after the windows logo then use F8 just after the splash screen to open the boot menu. you can do 1 of 2 things there. boot into safe mode. windows should load up as normal without disabling the onboard gfx. if it doesnt then use last good config to restor the session where the gfx was working.
disabling the cpugpu in bios and setting the gfx card as the primary gfx in bios should also turn your screen back on.
you may have to set the priority to peg 1 mode to select the pci-e slot that the gfx card is in.
and as sunius points out connect to the gfx card not the motherboards gfx output.
m
0
l
January 20, 2013 10:34:55 PM

Just make sure you do 2 things.

1. The Adapter should be connected to the Graphics card not on the Motherboard
2. Make sure that you put the PCI-e as your primary video output and disable the iGPU
m
0
l
!