Sign in with
Sign up | Sign in
Your question
Solved

Games not running well on mid/high system.

Last response: in Video Games
Share
January 11, 2013 11:40:35 AM

SPECS:

MSI GTX 660 Twin Frozr III 2gb
AMD Phenom II X4 965 BE
Seagate Barracuda 500gb hardive 7200rpm 16mb
Coolermaster Elite 500w PSU
ASUS M4A88T-M Motherboard
Windows 7 Pro 64Bit
8gb ripjaws ram


Games tested so Far:

GTA IV = Lag/Stutter
Witcher 2 = Lag on medium to high settings.
Every Bethesda game = Lag when the fps drops at all even by just 1 fps.
Minecraft = Stutter
Dead Island = Weird Stutter even with consistent 60 Fps.
Dark Souls = Runs Perfectly
Dead Space 2 = Seems to run Perfectly
Mass effect 3 = Some lag.
Indie Games run fine.
----------------------------------------------------------------------------------------------------------------------------------------

I have had lag in most games that i have tried and in reality my system should be able to run any game on max settings. I have had this lag since i built my computer and since then i have updated my gpu, ram and cpu and all this did was increase my fps but not fix the lag so in my mind that only leaves the psu or hdd as far i know a mobo doesnt cause bad game performance like that. I have reinstalled windows multiple times, reinstalled drivers multiple times.

I really need help with this cause it is driving me crazy.

Thanks in advance, help in greatly appreciated.


SPECS:

MSI GTX 660 Twin Frozr III 2gb
AMD Phenom II X4 965 BE
Seagate Barracuda 500gb hardive 7200rpm 16mb
Coolermaster Elite 500w PSU
ASUS M4A88T-M Motherboard
Windows 7 Pro 64Bit
8gb ripjaws ram


Games tested so Far:

GTA IV = Lag/Stutter
Witcher 2 = Lag on medium to high settings.
Every Bethesda game = Lag when the fps drops at all even by just 1 fps.
Minecraft = Stutter
Dead Island = Weird Stutter even with consistent 60 Fps.
Dark Souls = Runs Perfectly
Dead Space 2 = Seems to run Perfectly
Mass effect 3 = Some lag.
Indie Games run fine.
----------------------------------------------------------------------------------------------------------------------------------------

I have had lag in most games that i have tried and in reality my system should be able to run any game on max settings. I have had this lag since i built my computer and since then i have updated my gpu, ram and cpu and all this did was increase my fps but not fix the lag so in my mind that only leaves the psu or hdd as far i know a mobo doesnt cause bad game performance like that. I have reinstalled windows multiple times, reinstalled drivers multiple times.

I really need help with this cause it is driving me crazy.

Thanks in advance, help in greatly appreciated.

I Reset my Nvidia Settings.

January 11, 2013 12:07:41 PM

:lol: 

Reset Nvidia settings to default except the VSync. It will fix the lag. You can't set supersampling to 8x and except not to lag!
m
0
l
January 11, 2013 12:15:41 PM

Your settings are too high the first thing i'd do is turn off ambient occlusion it will improve your gaming a lot
m
0
l
Related resources
January 11, 2013 12:19:03 PM

+1 Turn down your NVidia settings. Just reset to default and never touch them again if that what your going to do with them ;) 
m
0
l
January 11, 2013 12:19:22 PM

I literally couldn't figure it out until I saw that
m
0
l
January 11, 2013 12:20:53 PM

Sunius said:
:lol: 

Reset Nvidia settings to default except the VSync. It will fix the lag. You can't set supersampling to 8x and except not to lag!


This has improved performance greatly Skyrim has near enough no lag but there is some weird stuttering issue now i haven't tested other games yet. Also minecraft still stutters and mass effect 3 now lags when turning.
m
0
l
January 11, 2013 12:23:36 PM

Check other games. Make sure adaptive VSync is enabled.
m
0
l
January 11, 2013 12:54:59 PM

I tested

Skyrim
Alan Wake
Minecraft
Dead Space 2
Mass Effect 3
GTA IV
Witcher 2


Alan Wake and Dead Space 2 where the only ones that ran fine.
m
0
l
January 11, 2013 1:05:54 PM

No AA setting in control panel and with adaptive Vsync and latest drivers?
m
0
l
January 11, 2013 1:09:38 PM

darth pravus said:
No AA setting in control panel and with adaptive Vsync and latest drivers?


AA set to Application Controlled
Adaptive Vsync is on
I have the latest drivers
m
0
l
January 11, 2013 1:10:20 PM

Quote:
your cpu is a pos.


I disagree
m
0
l
January 11, 2013 1:19:20 PM

Quote:
the 3570k is mid/high gaming cpu. His outdated cpu is low/mid. I'll reiterate myself. Your cpu is a piece of garbage. Upgrade to fix your fps. Also make sure you're running at your monitor's native resolution.


The phernom II x4 is an extremely popular cpu for gaming i have seen many people using it for gaming for battlefield 3 and far cry 3 with stable 60 fps. Most games use gpu over cpu anyway also my cpu is overclocked to 3.8ghz. Also the problem isnt anything to do with fps im getting good fps but still getting stutter.
m
0
l
January 11, 2013 1:21:35 PM

darth pravus said:
SMART test your HDD


Everything came back green apart from

UltraDMA CRC Errors which had a yellow triangle beside it.
m
0
l
January 11, 2013 1:23:52 PM

Try using another SATA table and another sata port on your motherboard
m
0
l
January 11, 2013 1:25:02 PM

Phenom II is a decent CPU. No need to upgrade.

Could you check your GPU usage during lag?
m
0
l
January 11, 2013 1:32:53 PM

darth pravus said:
Try using another SATA table and another sata port on your motherboard


Didn't change
m
0
l
January 11, 2013 1:40:27 PM

Sunius said:
Phenom II is a decent CPU. No need to upgrade.

Could you check your GPU usage during lag?


Skyrim used around 40 to 60% of my gpu.
m
0
l
January 11, 2013 1:42:31 PM

Quote:
Try doing a clean install of Nvidia

EDIT: is windows up to date?


I have done at least 4 clean installs of nvidia as i recently just upgraded my gpu from an powercolor hd 6850 to a nvidia gtx 660 so had to wipe all my old divers anyway with driver sweeper/fusion.

And i also tried reinstalling windows 7 and have downloaded all the updates again.
m
0
l
January 11, 2013 2:14:38 PM

Quote:
Is the resolution set to your monitor's native resolution? I have the EVGA GTX 660 2GB SC and it is OCed and has none of the problems you're having. Assuming it is a hardware limitation I'm saying its your cpu. I play Skyrim maxed out with HD textures, tons of mods, hi-res models, ect. If I remember correctly Skyrim is CPU hungry.

Even maxing out planet side 2 on my 3570k @ 4.2Ghz the fps will drop to 42fps here and there.


Yes it matches my monitors native resolution. Also Planetside 2 for me runs fine on max settings no lag at all.
m
0
l
January 11, 2013 2:28:54 PM

Antialiasing Transparency = 8x (supersample)

First off, turn of Supersampling. That KILLS performance.
m
0
l
January 11, 2013 2:38:07 PM

gamerk316 said:
Antialiasing Transparency = 8x (supersample)

First off, turn of Supersampling. That KILLS performance.


Already reverted my Nvidia settings to default.
m
0
l
January 11, 2013 2:58:28 PM

Hi mate! Turn off vsync (including adaptive). Download riva tuner v2.24 and install. Once installed go to program files x86 - riva tuner - tools - d3doverrider and create a shortcut to your desktop for the d3doverrider.exe file. You can now force vsync using d3doverrider instead of using NVidia or game vsync and it should sort your issue out. To set d3doverrider to work for your specific game then start the program with the shortcut then once opened click the + button at the bottom left and find the game exe where ever its installed. Force triple buffering setting should be set to on and force vsync setting should be set to on, also application detection level should be set to high.

m
0
l
January 11, 2013 3:15:32 PM

bigirishman said:
Hi mate! Turn off vsync (including adaptive). Download riva tuner v2.24 and install. Once installed go to program files x86 - riva tuner - tools - d3doverrider and create a shortcut to your desktop for the d3doverrider.exe file. You can now force vsync using d3doverrider instead of using NVidia or game vsync and it should sort your issue out. To set d3doverrider to work for your specific game then start the program with the shortcut then once opened click the + button at the bottom left and find the game exe where ever its installed. Force triple buffering setting should be set to on and force vsync setting should be set to on, also application detection level should be set to high.


I have tried this before and it did not work as far as know using the vsync option in the control panel is no different than forcing it in d3doverrider but thanks for the advice.
m
0
l
January 11, 2013 3:39:07 PM

Could you check your CPU usage and if it's high what's using it up? It should be enough for the games, but maybe you're running something in the background that you shouldn't be?
m
0
l
January 11, 2013 3:49:29 PM

Sunius said:
Could you check your CPU usage and if it's high what's using it up? It should be enough for the games, but maybe you're running something in the background that you shouldn't be?


Ive run game booster while playing these games which stops all background processes. Also cpu usage varies from 20% to 40% depending on the game.
m
0
l

Best solution

January 11, 2013 5:38:32 PM

Okay. Let's figure it out 1 by 1 game. Let's start, from say, Witcher 2.

Download MSI Afterburner and launch it. Next, download HWMonitor. Launch it as well. Finally, launch task manager performance tab.

Launch Witcher 2. Play until it lags. Next, minimize the game and screenshot task manager, msi afterburner and HWMonitor. Post images here.

Download links.
HWMonitor: http://www.cpuid.com/softwares/hwmonitor.html
MSI Afterburner: http://event.msi.com/vga/afterburner/overview.htm
Share
January 11, 2013 11:12:44 PM

+1 try what sunius says and its not the CPU I play many of those games on a Phenom x4. It may be worth getting CPUz from the same site as HWMonitor just to check all the numbers look correct.
Also I assume you have a genuine up to date copy of windows and have scanned for viruses.
m
0
l
January 12, 2013 5:51:41 AM

form what i have looked at the guy needs to reset the nvidia panel back to default Antialiasing Transparency = 8x (supersample) means he is running every game with 8xmsaa which will cripple the fps on a gtx 680 never mind a 660.
reset the nvidia panel to default and the problem should be gone...
also make sure the game profiles are the default profiles supplied by nvidia if you have them loaded.
m
0
l
January 12, 2013 7:10:28 AM

Also have to note that fps has nothing to do with this problem. I have really good fps even when i had 8x supersample on. The problem im having is when the fps drops in games by 1 fps its lags so like from 60-59 fps it will lag.

Anyway i dont have Witcher 2 installed anymore but i did the same test with skyrim instead here are the results.



http://i.imgur.com/cGNYP.png
m
0
l
January 12, 2013 9:37:22 AM

Is adaptive VSync on? Did you try non adaptive one?
m
0
l
January 12, 2013 10:14:06 AM

Sunius said:
Is adaptive VSync on? Did you try non adaptive one?


Yeh i have tried both and nothing changed either way.
m
0
l
January 12, 2013 10:29:03 AM

Did you try turning it off at all?
m
0
l
January 12, 2013 10:31:21 AM

Sunius said:
Did you try turning it off at all?


I've tred turning it off, on, adaptive ,application controlled everything.
m
0
l
January 12, 2013 11:25:08 AM

8 times super sample increases the picture by x8 then uses an algorithm to down scale it to fit your screen. this is why most cards will struggle to do it and keep a playable frame rate...
so no mate your fps will crumple. if it doesnt then its being overridden by the programs own AA routine.
adaptive vsync can cause an effect similar to microstutter. if your monitor is running at 59.7-9mhz this could be the cause of your issue. as the game will try to sync a fram to a frequency it cant match. make sure the screen is set to 60hz and it stays set to that... check b4 you play and after.
also if you have msi afterburner enabled make sure its off. completley.
m
0
l
January 12, 2013 12:37:28 PM

HEXiT said:
8 times super sample increases the picture by x8 then uses an algorithm to down scale it to fit your screen. this is why most cards will struggle to do it and keep a playable frame rate...
so no mate your fps will crumple. if it doesnt then its being overridden by the programs own AA routine.
adaptive vsync can cause an effect similar to microstutter. if your monitor is running at 59.7-9mhz this could be the cause of your issue. as the game will try to sync a fram to a frequency it cant match. make sure the screen is set to 60hz and it stays set to that... check b4 you play and after.
also if you have msi afterburner enabled make sure its off. completley.


I don't have super sample enabled anymore. V-sync is set to on not adaptive or application controlled. My screen has always been set to 60hz while playing and while not. Msi Afterburner is always disabled while gaming.
m
0
l
January 12, 2013 1:50:16 PM

Are you using a wireless connection? To me this sounds like a simple connection problem..
m
0
l
January 12, 2013 1:52:28 PM

Nevermind Solved the problem replacing my harddrive seems to have fixed the problem.

Thanks for the help

Problem Solved
m
0
l
January 12, 2013 1:53:00 PM

Best answer selected by zecele.
m
0
l
January 12, 2013 2:33:57 PM

thats odd... unless it was severly fragmented it should have been good enough.
did you have multiple partitions (each partition will slow the drive by 10%) or was it damaged in some way?.
glad you fixed your games btw but it would be nice to know how the hdd was affecting the game because like i say @7200rpm it should have been fast enough.
m
0
l
January 12, 2013 3:21:54 PM

I'm glad you've solved it. Odd indeed.
m
0
l
!