Sign in with
Sign up | Sign in
Your question

Crysis 2 Maximum Edition SUPER LAGGY??

Last response: in Video Games
Share
January 12, 2013 7:42:39 PM

Hi, I have myself a sub $400 gaming pc, which has run all my games very smoothly. I have played Crysis 2 on this build before, but when i upgraded to Crysis 2 Maximum edition, i've seen a tremendous drop in fps and sprites are choppy.

Here are my specs:

Windows 8 Pro WMC Edition
AMD Athlon II x3 450 (stock cooler @3.2Ghz)
Sapphire HD 4850 512MB Grahpics Card (OC @ 700/1100)
4GB DDR3 PNY XLR Series RAM (1600MHz)
Resolution: 1280x1024
Asus M5A78L-M LX Plus Motherboard

I play lots of intensive games: Diablo 3 (Max Settings), Far Cry 3 (Mid Settings), CS:GO, BF3 (Mid Settings), etc.

I just don't understand, i had the regular version of crysis 2 and it ran fine on "Advanced" but once i bought Crysis 2 Maximum Edition (steam sale, was like $5 or $10) it runs like total crap. I can't even start the campaign, it stutters with sounds and fps is like 2...

The current settings with maximum edition are set to full screen mode, 1280x1024, and on High Settings(which is the lowest settings).

Can anyone help me figure out why this is happening? Did the maximum edition get graphics tweaks or something? Thanks in advance.
January 12, 2013 8:13:28 PM

Hi :) 

You NEED a much better graphics card....yours is very LOW END..

All the best Brett :) 
m
0
l
January 12, 2013 8:34:57 PM

he shouldnt the 4850 is above minimum spec for the game as its stronger than the 88gt which is the minimum recomended and gives a rock solid 30 at minimum settings. at least it does on my old 88gt amd 6000+ x2 system that may mate now owns...
go into the settings and make sure its on dx9 mode patched to 1.9(should already be so) and the high rez textures are disabled... they may not be highlight-able as you have a dx10 card
so you may have to edit the config file to disable them. from what i gather they are on by default at shipping.
m
0
l
Related resources
January 12, 2013 8:50:51 PM

Are you sure your monitor is connected to your graphics card rather than your motherboard?
m
0
l
January 12, 2013 10:01:18 PM

Thanks for everybody's help!!! Especially HEXiT, Thanks to your suggestions, I turned off the setting 'DirectX 11 Features'. Thanks for pointing out that the card is only DX10! Runs amazing now, steady 50-60 average fps, 30-40 in the REAL intensive parts.
m
0
l
January 12, 2013 11:43:41 PM

NP thats what we do here...
m
0
l
!