Sign in with
Sign up | Sign in
Your question
Closed

Metro 2033 stutter/lag freeze

Last response: in Video Games
Share
January 17, 2013 1:09:32 AM

I'm getting lag/freeze spikes it's like a short stutter on Metro 2033, the game use to play fine and just one day I opened it and it started doing this and never stopped.
This happens whenever the game is in game mode , doesn't happen in any of the cut scenes and it's about every 5-10 secs but not consistent rhythm, it doesn’t matter if I’m on the graphics menu or on any scene it never changes worst or better. I have windows 7 ultimate x64 SP1,Phenom II x4 965 @ 3.9ghz and HD 3GB 7950 at core1150/mem1575.RAM is 1600mhz 7-8-7-24 GSKILL F3-12800cl7d,MOBO is 890FXA-UD5 REV 3.1 and majesty 1100Wat PSU, boot drive is 128GB SSD SATA II. I recently tried all the fixes at the same time I’ll post: I have tried default clock and voltage of the GPU and CPU then I disabled the windows Aero completely disabled my antivirus/firewall disconnected from the internet , I set DEP for only windows service/processes , I tried changing the CPU-process priority to normal high, high, real-time. I am currently using the 12.11 Beta 11 cap 2. I also tried it without the cap 2 profile , also tried the 12.10 official driver no profile. My system works fine though on all other games , I was playing BF3 max graphics and never stuttered one time as well as Farcry 3 plays like butter as well no stutters or anything not even for a brief moment at anytime in the game and I also play this game with every possible setting on max. I have tested my CPU on these games and the AMD Overdrive with all 4 cores at max, none of the cores make any stutters on the graph. Physics is disabled, I normally played with max graphics, I also tried changing the settings to the lowest with DX9 (DOF off) and the same exact stutters were there. I have also tried reinstalling my physics driver,vcredist_x86_sp1 and the newest DX update, I have all the newest windows updates. I also uninstalled the whole game reinstalled on a different very high performance hard drive WD black edition raid 0 X4 2TB each, and retried all the fixes and no results same consistent issue. BTW when switching drivers I used driver sweeper to make sure there was no driver errors the install logs never showed any errors. I used Diskeeper 2012 to keep all my HD’s in perfect condition(91%free disk space) I don’t defrag my SSD. Can anyone please help me?
January 25, 2013 1:39:08 AM

BUMP..
Score
0
January 26, 2013 11:24:57 PM

OK. just an update i just updated my driver to Catalyst 13.1 and still getting same issue with only Metro 2033 ; please if anyone has just an idea for me to try please pst something, i am baffled by this issue. BTW just tried the new maxpayne 3 game with max settings and runs smoother then silk .

The only Answer i don't want is to reinstall the OS cause i'm using SSD HD, re-installing windows is very hard on it.
Score
0
Related resources
January 26, 2013 11:57:58 PM

if the stuttering is intermittent then make sure the cpu boost is off and your running at stock clocks and voltage on the cpu and gpu. it wont affect the game if your running at 2.6 so dont worry about the oc just yet.
make sure you dont have AAA anti aliasing on and you may want to turn off all the other dx11 features other than tessellation.
if you have recently installed windows have you checked for updates. such as the vcredist and .net framworks.
make sure windows is fully patched to sp1 you may want to check it with sfc/scannow.
Score
0
January 28, 2013 12:55:23 AM

amd PII 965 doesn't have a boost mode , yes i do all the test with stock voltage and clocks , i did try those video settings , my windows 7 is fully updated /w sp1 via windows updates. i have every vcredis and .netframework you can find , i have even unstalled them and reinstalled i also did run after you psted this the SFC/scannow and yeah i'm still having the same issue :( 
Score
0
January 30, 2013 12:18:08 AM

bump
Score
0
!