Sign in with
Sign up | Sign in
Your question

Multiple games constantly lagg

Last response: in Video Games
Share
January 17, 2013 6:32:12 AM

Hello everyone,

I am having an issue with my games. I have built my own computer lately, and it seemed everything worked fine. But when I start playing games, they will start to lagg almost constantly. I have tried 3 games now; Far Cry 3, Saints Row the Third and Portal 2. Portal 2 runs fine, just like I expected (except the outro video, weird enough that started lagging as well). Far Cry 3 runs fine as well (for 5-10 minutes), but at a certain moment that will be turned upside down too, and start lagging and freezing. Saints row the Third is almost unplayable and laggs for about 3-5 seconds, then does good for about 10 seconds till it laggs again, and repeats that way. Haven't played my GTA-series yet, but I will expect the same.

For a while Far Cry 3 just worked fine, but when the first time it freezed I had it in windowed mode and I noticed my nvidia driver said it stopped working and rebooted himself or something. That is probably what caused the freezing, but my driver doesn't say anything when it just laggs.

Because I have two screens I watched my task manager while gaming and couldn't find a problem. My CPU was stable at about 30-40%, my memory did not go over 40% and my disc-rate didn't go all crazy, as well as my internet. I have not overclocked anything. And there are no weird processes taking event when the lagg starts (at least not noticable)

I am running windows 8. That might be an issue, but I doubt it. I did download the games (throughout steam, I love sales :)  ) and I don't know if that could be it. I have 3 discs; one for my system (SSD 128gb), one for my high-end games (SSD 128gb) and one for other games and other stuff (2TB HDD). Steam is originally installed on the games disc.

My specs are:
------------------------------------------
ASROCK Z77 Extreme9
Intel core i7 3770K 3.5 GHz
16gb RAM 1600 MHz
Nvidia GTX 680 4Gb
850W Power supply
2x 128Gb SSD
1x 2TB HDD
Windows 8

I have a solid 20 Mbit/s internet connection with about 10 ms ping
-------------------------------------------
I think my computer can handle these games easily...


I think the issues come from windows 8, steam in combination with the game's location, my GPU (Since I can only think that is the problem. Maybe I didn't place it well enough or something...), or the amount of power my computer gets from my house (don't know how to find out)

I literally don't know what to do anymore. Can someone please help me?

Thanks,
Badbond
January 17, 2013 6:39:14 AM

I use Windows 8 myself but I'm using 7970 Trifire setup with latest Windows 7 Beta drivers.

If your problem continues then try using the drivers before your current one installed from Nvidia or try beta ones and if than doesn't work I suggest trying Win 7 Drivers.

I'm assuming you have Windows updated too?
January 17, 2013 6:42:19 AM

Yes, everything is all up-to-date. Nvidia driver 310.90.

I shall try earlier drives and beta ones soon, I'll let you know
!