Sign in with
Sign up | Sign in
Your question

Games are constantly lagging

Last response: in Video Games
Share
January 17, 2013 6:33:14 AM

Hello everyone,

I am having an issue with my games. I have built my own computer lately, and it seemed everything worked fine. But when I start playing games, they will start to lagg almost constantly. I have tried 3 games now; Far Cry 3, Saints Row the Third and Portal 2. Portal 2 runs fine, just like I expected (except the outro video, weird enough that started lagging as well). Far Cry 3 runs fine as well (for 5-10 minutes), but at a certain moment that will be turned upside down too, and start lagging and freezing. Saints row the Third is almost unplayable and laggs for about 3-5 seconds, then does good for about 10 seconds till it laggs again, and repeats that way. Haven't played my GTA-series yet, but I will expect the same.

For a while Far Cry 3 just worked fine, but when the first time it freezed I had it in windowed mode and I noticed my nvidia driver said it stopped working and rebooted himself or something. That is probably what caused the freezing, but my driver doesn't say anything when it just laggs.

Because I have two screens I watched my task manager while gaming and couldn't find a problem. My CPU was stable at about 30-40%, my memory did not go over 40% and my disc-rate didn't go all crazy, as well as my internet. I have not overclocked anything. And there are no weird processes taking event when the lagg starts (at least not noticable)

I am running windows 8. That might be an issue, but I doubt it. I did download the games (throughout steam, I love sales :)  ) and I don't know if that could be it. I have 3 discs; one for my system (SSD 128gb), one for my high-end games (SSD 128gb) and one for other games and other stuff (2TB HDD). Steam is originally installed on the games disc.

My specs are:
------------------------------------------
ASROCK Z77 Extreme9
Intel core i7 3770K 3.5 GHz
16gb RAM 1600 MHz
Nvidia GTX 680 4Gb
850W Power supply
2x 128Gb SSD
1x 2TB HDD
Windows 8

I have a solid 20 Mbit/s internet connection with about 10 ms ping
-------------------------------------------
I think my computer can handle these games easily...


I think the issues come from windows 8, steam in combination with the game's location, my GPU (Since I can only think that is the problem. Maybe I didn't place it well enough or something...), or the amount of power my computer gets from my house (don't know how to find out)

I literally don't know what to do anymore. Can someone please help me?

Thanks,
Badbond
January 17, 2013 6:36:53 AM

Sorry double post, something went wrong with the sign-in proces.

Said I had to sign in to post it, did but did not have submit button anymore so thought it was gone.. refreshed and posted it again.

Excuses :)  Won't happen again
m
0
l
January 17, 2013 7:11:45 AM

Update your drivers. Or you can try to downgrade too.

Go to Add and Remove and remove the NVidia Driver. Re-boot, and install the drivers again. Preferably a stable version (rather than the beta ones).

Use TechPowerUp GPU-Z to check the load on your GPU. If it is touching 100%, then your CPU might be getting bottle-necked. So you will need to clean your case, implement better cooling, etc.

Also, try playing the games offline, and see if the problem persists.
m
0
l
March 15, 2013 6:08:04 AM

I would try:

- Installing new drivers. :pt1cable: 
- Check if you are running on AHCI as opposed to IDE. Should be AHCI.
- Check if it isn't some program such as a virus scanner locking up your PC.
- Check if you are not maybe overheating the CPU or graphics card and it throttles back.
- Re-install windows and test before installing anything other than the games themselves.
m
0
l
!