Sign in with
Sign up | Sign in
Your question

Sapphire HD 7970 - Low FPS, Low CPU/GPU Usage

Tags:
  • PC gaming
  • GPUs
  • Sapphire
  • HD
  • Video Games
Last response: in Video Games
Share
January 22, 2013 10:39:29 PM

Hi everyone!
I recently upgraded to a Sapphire HD 7970 Vapour-X (Overclocked) from a Sapphire 6950 and have noticed essentially no improvement whatsoever.
I've been playing on Far Cry 3 recently and to get it to a playable level I've had to switch from Direct X 11 to Direct X 9, turn the quality to Low, enable VSync and even then it dips to around 20-25fps in towns. Is this normal or am I expecting too much from this card?
Another thing that's been irritating me is that I've never seen the gpu usage get any higher than about ~50% and the CPU usage ~60%. Surely this can't be right? If I'm getting pretty low FPS surely I should be maxing the GPU or at least bottlenecking the CPU? You'll have to excuse me If I sound like an idiot, I don't really know much about the technical side of things and I could be completely wrong in my understanding of these things.
I know the GPU can reach a higher load as it hits 100% (and performs quite well; much, much better than my 6950) when stress tested so I'm at a loss as to why it performs so poorly in games.
Is there something wrong with my setup, my card or is it simply that Far Cry 3 is poorly optimised?

Also, before anyone mentions it, I've uninstalled the drivers, used driver sweeper and installed the latest 12.11 drivers so I don't think it's a driver issue. I could be wrong though.

Any help would be very much appreciated!
Thanks in advance!

Computer specs:
CPU - AMD Phenom II X4 955 (Overclocked to 4Ghz)
GPU - Sapphire HD 7970 Vapour-X (GPU clock - 1150MHz, Memory Clock - 1500MHz)
PSU - 800Watt (Can't remember make)
Motherboard - Gigabyte GA-990FXA-UD5
RAM - 16gb (4x4)

More about : sapphire 7970 low fps low cpu gpu usage

January 23, 2013 10:06:51 AM

PanicMaster85 said:
no that is not normal, can you please run uningine heaven for me and tell me your final score?
http://unigine.com/products/heaven/download/

max everything out

also are you running any overclocks?


Thanks, downloading now.

Yes, my CPU is overclocked to 4GHz (from 3.2GHz) and my GPU is overclocked slightly (GPU clock - 1150MHz, Memory Clock - 1500MHz).
Related resources
January 23, 2013 10:46:49 AM

Here's the Heaven benchmark results:



GPU load was steady at 100%, temperature maxed out at 59°C and memory usage didn't go much over 1gb.
Everything was maxed out apart from 3D settings and VSync which were disabled.
January 23, 2013 3:07:06 PM

Did you try completely wiping your drivers? Happened to me when I went from a 5970 to a 7970....even after driver sweeper I had alot of issues. Tried trial and error and finally the only thing that worked was a clean install of windows =/

those results are not bad. You are running extreme tessalation and 16x ....
January 23, 2013 3:17:17 PM

envymert said:
Did you try completely wiping your drivers? Happened to me when I went from a 5970 to a 7970....even after driver sweeper I had alot of issues. Tried trial and error and finally the only thing that worked was a clean install of windows =/

those results are not bad. You are running extreme tessalation and 16x ....


I might have to reinstall windows but I was hoping I wouldn't have to. I've cleaned the drivers a few times, removed all NVIDIA drivers that were, for some reason present (Never used a NVIDIA card so I'm not sure where they came from!) but it still hasn't helped.

The benchmarks aren't the problem (at least I know my card isn't faulty!), It's just as soon as I load up Far Cry 3; I have to play it using Direct X9 and everything on Low just to keep it playable and even then it still drops to ~25fps in busy areas. Not sure why, could it have something to do with Steam?
January 23, 2013 3:28:10 PM

Sounds exactly like my previous problem ..... I was wrong I went from Sli'd 570's to the 7970. So Nvidia to AMD. I hate wiping my computer but if you have an SSD youll be back to normal in an hr!
January 23, 2013 7:50:09 PM

yeah I completely agree because your heaven scores a great about the same as my 670 that is overclocked, do you have an overclock on your gpu?

anyways yeah just get your OS reinstalled and keep us poste
January 23, 2013 9:52:10 PM

Cheers guys, I'll do fresh install and let you all know how it goes!
January 29, 2013 9:51:47 PM

Hi everyone, I found a rather strange solution to my problem that I thought people might find useful :) 

After searching Google for hours (I really couldn't be bothered reinstalling Windows!) I found a few people with similar issues and one guy claiming to have fixed his by disabling AMD's "Cool 'n' Quiet" in the BIOS. I didn't really think it would have much effect but, low and behold, after disabling it and running Far Cry 3, I can now run it on Direct X 11 with all settings on Ultra (except for Post FX which I set to low, I think it looks better without it anyway) and maintain a steady ~60fps.
I have no idea if this "Cool 'n' Quiet" disabling is a well known thing or whether mine had broken horrifically or something, but it certainly did the trick!

Anyway, just thought this might be helpful to someone!
Many thanks for all your help guys!
January 29, 2013 10:23:54 PM

awesome :D  glad i could help
!