Sign in with
Sign up | Sign in
Your question

Literally tried everything available with Skyrim...

Last response: in Video Games
Share
January 23, 2013 3:12:46 PM

Hello,
first off, my specs...

AMD FX 4100 x 4, 3.6ghz
8GB DDR3 ram
Windows 7 64bit
ASUS HD 6770 1gb

Now I have quite literally spent my time from Sunday afternoon until typing this message today trying to find a solution that works for me with regards to the lag... I have done numerous Google searches that have returned as many answers as you can shake a stick at and I am yet to find one that has worked..

Things I've tried:
Turned off AA (And the other one in Skyrim options)
SBW
64hz fix mod
Updating drivers
Uninstall/reinstall Skyrim
Deletion of all mods, running vanilla Skyrim
Running RadeonPro with FPS limiter
Running MSI Afterburner with FPS limiter
Running both of the above together!
Lowering settings to high
Lowering settings to medium
Disabling shadows
Lowering particle effects
Changing the mouse acceleration to 0
Changing the FOV
Performance enhancement mods
Raising/Lowering the amount of cells loaded

Nothing I have tried has made a blind bit of difference.. I still have incredible lag when turning/looking around until I complete a full circle and then it seems to be ok until I walk a little ways and then it happens again when I look around... Its always worse when I first enter a town but it keeps doing it after moving a little way (eg/ does it at Whiterun fast travel point, and then again in the market area, again by the tree etc)... I just feel like my PC shouldn't be doing this and yet it is.. I might be wrong and maybe my pc is just crap and you guys will tell me that but I didn't have this problem running Skyrim on 32bit XP a week ago... It ran wonderfully with only 3.25gb ram with a load of mods on medium and rarely had slowdown, maybe the odd jump or two in towns...

Just seems odd to me that I just cant get this working, I have messed with the AMD vision engine settings and quite literally nothing i have tried seems to make a difference... If ANYONE has any idea of other tweaks/changes I can make then I'd be majorly grateful, or maybe I'm just kidding myself that my PC will run it properly??

Anyways, thank you for your time and apologies for another Skyrim thread...

More about : literally skyrim

January 23, 2013 9:23:04 PM

What resolution are you playing at? If you've got it at 1920x1080 try turning that down and play at default medium setting,
I'm afraid the problem is your hardware specs is not a strong gaming machine the graphics card is weak and you may want to research into overclocking your cpu
January 23, 2013 9:36:05 PM

I have tried numerous resolutions and the only one that is giving me any vague improvement is 1280x720... It just seems strange that I could play it on better settings while I was using XP and less RAM... Doesn't make much sense to me.. So would you recommend a near future upgrade for the graphics card? I won't be rushing out immediately to buy one but with money as tight as it is I'll prob only have £100-150 max to spend, any suggestions?

Also, very lame question I know, but I have no idea about overclocking or how it works... Can it damage the system? Cause any problems?

Thanks for your help :) 
Related resources
January 23, 2013 10:39:41 PM

Yeah if overclocking you need an aftermarket cooler for the cpu really, but there is a lot of play on those cpu's and you'll reach 4ghz and more easily.
a 2gb hd7850 is a good performer for the price range you mentioned
http://www.scan.co.uk/products/2gb-gigabyte-radeon-hd-7...
January 24, 2013 12:54:25 AM

Navigate to your skyrim.ini file in the my games folder in your documents and look for a line under display saying:

iPresentInterval=

If it is not there (i cannot remember if i added it or if it is there to begin with) add it and set it to 1, if it is change the 0 to a 1.
It should then look like this:

iPresentInterval=0

What this does is turn off some awful vsync that is integrated into the game. I kept getting lag before i did this even though msi afterburner reported high framerates.
January 24, 2013 1:09:56 AM

the problem your having is skyrim likes to use 2 threads only and because the steamroller ? fx has such poor single threaded performance it cripples games that dont use more than 2. it causes the gfx card to bottleneck and all sorts of other issues... seriously its threading performance is no better than the old amd athlon 6000 which barely had enough grunt to cope with an 8800gt 98gt and at best the 98gtx+/gts250. put anything bigger in and you start bottlenecking on single thread and dual threaded apps.
the 6670 is a just a little stronger than the gts 260 so will be bottlenecking by about 10%... check yout your task manager and you will see 2 cores maxing out to 100% and dropping down only to bounce back up again... this is your bottleneck.
save up and the the 8350 it gives similar performance to the old i7 920-50 on single threads so is much better for gaming.
January 24, 2013 10:51:01 AM

Ok well it looks like I'm going to have to have a dig through the guides, save up some cash and add extra cooling and a new graphics card at some point in the near future... Thank you all for your advice, gives me something to read and work through on my day off!!

Also, HEXiT, is there no way for me to make Skyrim utilize the other cores at all? Apologies but this is all new ground for me!
January 24, 2013 1:16:00 PM

as far as i know no. you ay find something by asking over at the skyrim nexus. there may be a community patch or something. but other than that i doubt it.
January 25, 2013 6:20:23 PM

Ok thanks... Weirdly I loaded up the game yesterday afternoon on medium settings using the iPresentInterval=0 thing posted above and it ran basically perfectly... Exited the game, put it on high graphics and still it ran perfectly...

Today I loaded up the pc, started the game, and the lag was back!! As far as I am aware I didn't change anything, there were no windows 7 installs on exit so nothing changed there, very very confused!!
January 27, 2013 11:28:43 PM

Are you sure that the ipresentinterval=0 is still there. I think skyrim might change the ini file after you change settings however it only reads it once at startup of the game so it didn't affect that session. You may have to set the file as read only after getting the graphics settings you want and re adding it.
!