Sign in with
Sign up | Sign in
Your question

I want to lock Crysis to 30FPS, how can i do that?

Last response: in Video Games
Share
January 25, 2013 1:38:05 PM

I want to lock Crysis to 30FPS, how can i do that? If i keep it locked at 30FPS it will appear smoother because of less framerate deviation. I've tried MSI Afterburner with the framerate lock function but it doesn't work for Crysis or Need For Speed Hot Pursuit. What can i do to lock the framerate? I'm not going to do it just by setting all settings to highest, i want a proper way of doing it.

More about : lock crysis 30fps

January 25, 2013 1:41:06 PM

Use N-Vidia Contorl Panel if you have Ge Force GPU

Add the game to manage 3D settings and change Vertical Sync to Adaptive (Half Refresh Rate)
m
0
l
January 25, 2013 1:44:28 PM

I have an AMD card. I have ATI Tray Tools. My card is capable of getting around 60FPS, so enabling vsync doesn't achieve lockign the framerate to 30. I still want 30FPS because the framerate deviates, and 30FPS for me with motion blur is relatively decent.
m
0
l
Related resources
January 25, 2013 1:52:15 PM

Create autoexec.cfg in main directory, and add "sys_MaxFps=30" to it, and see if it works.
m
0
l
January 25, 2013 2:01:39 PM

Also, you can try to add this (might help solve your problem)...
r_VSync [0,1]
d3d9_TripleBuffering [0,1]

This will enable the normal 60 FPS VSync, and TripleBuffering which might ensure that you do not suffer performance hits with VSync ON.
m
0
l
January 25, 2013 2:02:06 PM

how do i do that, do i have to make it an ini file? Do i just open up a notepad, type that in, with noting else and save it as that?
m
0
l
January 25, 2013 2:10:41 PM

Not ini, cfg

\Program Files\Electronic Arts\Crytek\Crysis, create a new text file, and save it as autoexec.cfg. Add the lines I mentioned and see.
sys_MaxFps=30 will not work mostly, as far as I remember, but it's worth trying out.
The other two will work, but they will not give you lock at 30 FPS. But you should still try. And see if it serves your purpose.
m
0
l
January 25, 2013 2:17:44 PM

will this work for any game version, patched or unpatched?
m
0
l
January 25, 2013 2:36:01 PM

Alrighti have a 30fps cap, but it wasn't what you recommended. Thanks for help though, i think it was "fixed_time_step= -0.03333" in game.cfg, system.cfg or autoexec.cfg.

It was the autoexec.cfg then in main directory, using "fixed_time_step= -0.03333" without " " will give you 30fps so if anyone else wants to cap crysis to 30 then use this. It feels very smooth now.
m
0
l
!