Sign in with
Sign up | Sign in
Your question

Black ops 1 on 6950 frame rate drops

Last response: in Video Games
Share
February 1, 2013 12:39:31 PM

Hey guys, was having a bit of trouble playing Black ops 1 on multiplayer, finding it very hard to get kills due to the sudden drop in frame rates (especially in nuke town). My settings are all maxxed out and i do get 60fps at the start, but then it drops down to 30ish and averages around 45. Now i know you guys are going to suggest to lower the graphical details however, my laptop (G74) Maxxes out this game at 60fps constant, doesnt really drop at all, maybe 1 or two fps in extremly smokey areas however that was it. Settings were identical to the desktop. The latpop uses a GTX 560m 3gb which has half the performance of my 6950.

Also i looked at msi afterburner to see the gpu usage (on the 6950), what i found fascinating was that the gpu usage was actually at 99% which is weird since the gpu usage on my laptop was around 88% constant 60fps. I ran both games playing the same map, it just doesnt make sense. I even overclocked the 6950 and its still not performing better than my laptop. The only thing i can think of is the fact that my 6950 only has 1gb of vram while my laptop has 3gb, but that shouldnt really be an issue, especially for an old game like black ops, i even run battlefield 3 at higher settings =='. Any help would be greatly appreciated.

Ohh btw i also noticed that on my laptop, there was an option to increase AA to 16x but on my desktop it only maxxed out at 8x, wouldnt let me go higher.

Additional info:
Both computers are running at 1080p

Desktop:
12gb 2000mhz ram
6950 1gb oced
i7 950 @ 4.5ghz

Laptop G74:
Ram: 16gb 1333mhz
cpu: i7 2670qm @ 3ghz turbo
gpu: GTX 560m 3GB oced
February 1, 2013 12:47:23 PM

Does it happen only in multiplayer or single player too?
Try disabling you anti-virus and start the game or add the game to ur whitelist.
There were many posts with similar problems in 2010 and disabling the anti-virus worked for many people.
Try toning down your graphics a notch and if you yet have 30ish FPS then obviously it's not your GPU's fault. At least that may eliminate one possibility for sure.
February 1, 2013 12:53:10 PM

ZakX11 said:
Does it happen only in multiplayer or single player too?
Try disabling you anti-virus and start the game or add the game to ur whitelist.
There were many posts with similar problems in 2010 and disabling the anti-virus worked for many people.
Try toning down your graphics a notch and if you yet have 30ish FPS then obviously it's not your GPU's fault. At least that may eliminate one possibility for sure.


It happens mainly in multiplayer, single player is alrightish, however it still performs much better on my laptop. And it still doesnt give me to option to set my aa to 16x. ill try disabling the antivirus and toning down the graphics.
Related resources
February 2, 2013 10:46:19 AM

Just did what you told me to plus more, its still so crap!! its really pissing me off now, ive been playing at 30fps both multiplayer and campaign. I also watched youtube videos of other 6950 owners playing the game at a constant 60fps!. I turned down the settings as low as they would go and it only gave me 2 addition fps. I do get 60fps in closed areas but thats it. So frustrating iuhesfiuhrfeigtheruohgoeuirgn. Im gonna throw this computer out the window in a moment, anyone got any advice on this ridiculous issue =='

Also tried the antivirus and installing the game again, also did a clean install of all my amd drivers and still no luck ==;
February 3, 2013 4:39:33 PM

azed3000 said:
Just did what you told me to plus more, its still so crap!! its really pissing me off now, ive been playing at 30fps both multiplayer and campaign. I also watched youtube videos of other 6950 owners playing the game at a constant 60fps!. I turned down the settings as low as they would go and it only gave me 2 addition fps. I do get 60fps in closed areas but thats it. So frustrating iuhesfiuhrfeigtheruohgoeuirgn. Im gonna throw this computer out the window in a moment, anyone got any advice on this ridiculous issue =='

Also tried the antivirus and installing the game again, also did a clean install of all my amd drivers and still no luck ==;


Is the Vsync on?
Also use MSI Afterburner or GPUz ( http://www.techpowerup.com/gpuz/ ) and see your GPU usage while running the game.
That will prove very helpful.
February 3, 2013 11:46:06 PM

ZakX11 said:
Is the Vsync on?
Also use MSI Afterburner or GPUz ( http://www.techpowerup.com/gpuz/ ) and see your GPU usage while running the game.
That will prove very helpful.

Cheers for your response bro. Yea i used msi afterburner and it says my usage is 99%, overclocking helped a little but still averaging at 40fps during gameplay, if i turn vsync off i get 90fps in closed areas but a massive drop to 20 fps in open battle areas. Dont know why its so terrible.

I saw heaps of videos where peoples 6950s give a constant 60fps without any drops, not even to 59, i also so benchmarks of 6950 averaging 80fps max settings, with their minimums being 61. Look at the link below for proof, it should be the fourth graph.

http://www.bit-tech.net/hardware/2010/12/16/ati-radeon-...

Just dont know why im getting such bad gameplay =[ My laptop with half the performance does better than it.
April 13, 2013 3:34:29 AM

I am searching for answers too, I used to play Blops 1 all the time with 125fps but now after playing black ops 2 I wanted to start playing black ops 1 again and I am having the same FPS drop issue as the OP even though I haven't made any changes to my PC. :/ 
April 13, 2013 9:02:41 AM

AustinBrough said:
I am searching for answers too, I used to play Blops 1 all the time with 125fps but now after playing black ops 2 I wanted to start playing black ops 1 again and I am having the same FPS drop issue as the OP even though I haven't made any changes to my PC. :/ 


Im suspecting it to be the drivers man =/ The new drivers seem more specialized for 7000 series by adding support for older and newer titles while at the same time, makes the 6950 slightly worse for older games. Anyway after running driver sweep and what not, the game was still at 30 -40 fps. ==' I ended up just getting a 7950 (mate was selling) and im getting solid 60fps now vsync on. Try the older drivers, it should solve the problem. Think thats one of the advantages of having nvidia, the support still exists for older generation cards unlike amd who mainly optimize the newer gen cards and just add support for older gen cards for new titles.
July 13, 2013 10:01:58 PM

I have the exact same problem. Used to work great, now its crap....
!