Sign in with
Sign up | Sign in
Your question

Zonealarm and localhost

Tags:
  • Firewalls
  • Performance
  • Localhost
  • Networking
Last response: in Networking
Share
Anonymous
June 17, 2004 8:28:23 PM

Archived from groups: comp.security.firewalls (More info?)

Since the recent "'performance updates" from Zonealarm I have a big problem.

I use my computer to build some website and for that I have some time
consuming PHP procedures that access my local database and filesystem a lot.
With the old version of Zonealarm these procedures took a few minutes, but
with the new "performance improved" version of Zonealarm it takes more than
half an hour. I am more or less forced to switch Zonealarm off while doing
this work.

Is there anything I can do to make my computer faster again.

Thanks,

Wim

More about : zonealarm localhost

Anonymous
June 18, 2004 2:54:13 AM

Archived from groups: comp.security.firewalls (More info?)

"Wim Roffal" <wimroffelplease@nospamm-planet.nl> wrote in
news:cas9oj$jpu$1@reader13.wxs.nl:

> Since the recent "'performance updates" from Zonealarm I have a big
> problem.
>
> I use my computer to build some website and for that I have some time
> consuming PHP procedures that access my local database and filesystem
> a lot. With the old version of Zonealarm these procedures took a few
> minutes, but with the new "performance improved" version of Zonealarm
> it takes more than half an hour. I am more or less forced to switch
> Zonealarm off while doing this work.
>
> Is there anything I can do to make my computer faster again.
>

So, I take it you have an NT-based O/S with Web Services running with a
machine that's directly connected to the Internet?

Duane :) 
Anonymous
June 18, 2004 3:22:23 PM

Archived from groups: comp.security.firewalls (More info?)

"Wim Roffal" <wimroffelplease@nospamm-planet.nl> wrote in news:caua0t$ll3$1
@reader08.wxs.nl:

> No, just a Windows ME machine with Apache on an ADSL connection.
>

IMHO, may be you should invest in a cheap NAT router to protect the
computer with the Web service running in addition to a PFW solution behind
it.

One shouldn't connect a machine with a Web service directly to the
Internet.

What security from an O/S standpoint can be implemented on the Win ME O/S?

Duane :) 
Anonymous
June 19, 2004 8:34:51 PM

Archived from groups: comp.security.firewalls (More info?)

"Wim Roffal" <wimroffelplease@nospamm-planet.nl> wrote in
news:cb1jc9$n5r$1@reader13.wxs.nl:

> Yawn!!!
>
> I ask a question about Zonealarm and I get a stupid discussion about
> how I should handle my safety. This is really totally not interesting
> to me!
>
> Wim
>
>

My advise to you is get behind a cheap NAT router to protect the machine
that cost as much as ZA. That way, you can turn ZA off and still be
protected when doing the Web work using localhost.

Duane :) 
June 20, 2004 1:00:05 AM

Archived from groups: comp.security.firewalls (More info?)

Wim Roffal wrote:
> Since the recent "'performance updates" from Zonealarm I have a big problem.
>
> I use my computer to build some website and for that I have some time
> consuming PHP procedures that access my local database and filesystem a lot.
> With the old version of Zonealarm these procedures took a few minutes, but
> with the new "performance improved" version of Zonealarm it takes more than
> half an hour. I am more or less forced to switch Zonealarm off while doing
> this work.
>
> Is there anything I can do to make my computer faster again.
>
> Thanks,
>
> Wim
>
>
Hello Wim,

I too, develop web sites and use Apache to test my scripts before
sending them up to the server. The "localhost" used by Apache is for
your internal IP address 127.0.0.1 and is supposed to be used internally
only. Your ADSL connection should not be routed to "localhost".

The addition of ZoneAlarm 5.0 or ZA Suite changes some Windows Operating
System files that prevent Apache from serving web pages correctly.
There is nothing you can do with ZA, they do not support server
installations.

However, you can disable the Apache attributes that call on the older
Windows enhanced performance files the ZA changed.

Open your Apache config file and find these attributes and change them
to the following:

EnableSendfile Off
EnableMMAP Off
Win32DisableAcceptex

Depending on which version of Apache you have installed you may not have
the last attribute available. If the first two are, and that does not
fix the problem download the latest version of Apache for win32 and make
all the necessary configuration changes.

Hope this helps,

Michael Gordon
!