Sign in with
Sign up | Sign in
Your question

Far cry 3 slow gameplay issue, please help.

Last response: in Video Games
Share
February 11, 2013 9:27:15 AM

Hi!
I have been having some major issue with Far cry 3, could you try and help?
I bought it recently, installed it and it was running perfectly (my PC is a dell xps 15z, if that helps)
Then I open it up one time and everything was a lot slower, in cutscenes the voices would come a lot earlier than the actual movement and just general slow moving around.
I thought it would just go away if I restarted it, but clearly it didn't. Now I have been google-ing to find a solution to this but I just can't seem to find someone with the same problem...
I have tried with lowering my settings, but that doesn't help in the slightest!
I have tried everything I could think of, but nothing seems to help!!

Please help me, this game is amazing but I don't want to play it in this horrible condition..
February 11, 2013 9:41:57 AM

de-syncing is caused by running the gfx at higher settings than your card can handle. i had the same issue with crysis when it first came out on my old 8800gt.
reduce the gfx to low make sure your render ahead is set to 1 or at the most 2
(if your system has an nvidia card you can need to do this in both the driver game settings and the in game menu.
apply the settings and restart the game...(quite and restart it)
also drop the screen rez to 720p if you have a 1920/1080 screen. the m525 gpu should run the game at minimum but medium may be a stretch, high will cause it to crumple...

February 11, 2013 11:14:39 AM

As HEXit mentions, your laptop can't simply keep up with the game and that makes the sounds occur before the actions.

That is because of the low amount of FPS you're seeing.
February 11, 2013 12:43:08 PM

Wow, I thank you both! I didn't realize that was the case I will try and do something about it.
But it was just strange since it worked perfectly for 2 days and then this suddenly happened...
I will see what I can do, thank you for the help you guys =)
!