Sign in with
Sign up | Sign in
Your question

Dota 2 Keeps crashing!!!!!

Last response: in Video Games
Share
February 13, 2013 11:34:58 PM

About 3 weeks ago Dota 2 started crashing after every match and now it crashes about a minute or two into the menu but it never crashes in game. My temps are very cool. I thought it might be my new motherboard, msi z77a g43 so i replaced it for a new one and i am still having the same problem.

I have

msi z77a g43 motherboard
intel core i5 3570k
nvidia geforce gtx 670
4gb of ram
750w power supply

please help. Been searching for weeks and cant solve problem!

More about : dota crashing

February 14, 2013 12:23:17 AM

Lol always happened to me... Go into Steam > Library > Dota 2 > Right Click Dota 2 > Properties > Local Files > Verify Integrity of Game Cache. It will take about 5 minutes to complete. Then run the game.

What this does is that it looks through your files and finds the missing files to run the game.. When they are missing, the next time you start the game, they reinstall.
m
0
l
February 14, 2013 3:37:57 AM

Hey so i verified the game cache. after it completed I ran the game and after about 1 minute it shut off still. Any ideas?
m
0
l
Related resources
February 14, 2013 9:10:34 PM

Might be youre hard drive. Maybe uninstall it off steam, then install it again.
m
0
l
February 14, 2013 9:24:27 PM

I've tried that before as well. Could it possibly be the psu went bad?
m
0
l
March 28, 2013 11:48:35 PM

Try this guys, START > type MSCONFIG in searchbox > Service > then tick in "Hide all Microsoft service"> Then click Disable All.. Then goto Startup, click "Disable All" > apply > ok >reboot @ restart pc.. i think its the Nvidia software that cause the problem, this only all i can help, try it. its work for me.
m
0
l
April 3, 2013 12:43:57 PM

Remove drivers from integrated graphics.
m
0
l
April 16, 2013 8:22:45 PM

beeding said:
Remove drivers from integrated graphics.

how do i do that ?
m
0
l
April 17, 2013 12:00:23 AM

Dota 2 still in beta status and got few technical problems, i guess that its the driver problems, you need to remove it completely and remove any other graphics integrated drivers using Treexy Driver Fusion and windows uninstallation, clean registries and junk files using Ccleaner and restart your computer in every action you made, download the latest drivers from nvidia.com, if that didnt help, try moving steam folder to any other partition and scan your partitions
m
0
l
April 20, 2013 2:06:36 AM

jili said:
Try this guys, START > type MSCONFIG in searchbox > Service > then tick in "Hide all Microsoft service"> Then click Disable All.. Then goto Startup, click "Disable All" > apply > ok >reboot @ restart pc.. i think its the Nvidia software that cause the problem, this only all i can help, try it. its work for me.


Dude thanks alot for this help. I had tried 3 games so far and god bless, it went smooth. I will try it for couple of days more to see whether is this the solution or it. Appreciate it.
m
0
l
April 20, 2013 2:09:42 AM

jili said:
Try this guys, START > type MSCONFIG in searchbox > Service > then tick in "Hide all Microsoft service"> Then click Disable All.. Then goto Startup, click "Disable All" > apply > ok >reboot @ restart pc.. i think its the Nvidia software that cause the problem, this only all i can help, try it. its work for me.


But i have 1 question. Does your solution affect other software running? Seems like u are disabling the gpu driver. Will it affect other software? Thanks
m
0
l
April 29, 2013 5:13:18 AM

DOTA 2 doesnt crash now :)  And if you have a RAM of 6gb and video card of 1gb then the game will flow smoothly.
m
0
l
April 29, 2013 5:15:24 AM

jili said:
Try this guys, START > type MSCONFIG in searchbox > Service > then tick in "Hide all Microsoft service"> Then click Disable All.. Then goto Startup, click "Disable All" > apply > ok >reboot @ restart pc.. i think its the Nvidia software that cause the problem, this only all i can help, try it. its work for me.


What will happen if disable all of them? I'm scared to try it. hehe.

m
0
l
April 30, 2013 8:02:09 PM

Thanks Jili for the advice, works fine now. do you think it might be a nvidia driver update?
m
0
l
July 21, 2013 3:19:36 AM

jili said:
Try this guys, START > type MSCONFIG in searchbox > Service > then tick in "Hide all Microsoft service"> Then click Disable All.. Then goto Startup, click "Disable All" > apply > ok >reboot @ restart pc.. i think its the Nvidia software that cause the problem, this only all i can help, try it. its work for me.


alicepattinson said:
jili said:
Try this guys, START > type MSCONFIG in searchbox > Service > then tick in "Hide all Microsoft service"> Then click Disable All.. Then goto Startup, click "Disable All" > apply > ok >reboot @ restart pc.. i think its the Nvidia software that cause the problem, this only all i can help, try it. its work for me.


What will happen if disable all of them? I'm scared to try it. hehe.



hey thanks jili this was working for me for about a week then update came and its back to crashing when i get on game to desktop :S. any advice thanks ell
m
0
l
July 31, 2013 4:22:20 PM

I saw an article that it's not safe to Hide all Microsoft service. Is that true? eeee.
m
0
l
!