Skyrim Stuttering

I just started playing skyrim after about a year hiatus and I've noticed that their have been tons of optimizations and it runs way better.But I still have this stuttering problem.When I turn in big areas or a city.But once everything loads it goes away and is smooth as butter.Are their any for sure fixes for this yet? I've tried the Window mode one but that causes screen tearing and disables crossfire.Thanks in advance.

2500k @ 4.5ghz
6870 Crossfire
8GB 1600mhz
11 answers Last reply
More about skyrim stuttering
  1. purple stank said:
    I just started playing skyrim after about a year hiatus and I've noticed that their have been tons of optimizations and it runs way better.But I still have this stuttering problem.When I turn in big areas or a city.But once everything loads it goes away and is smooth as butter.Are their any for sure fixes for this yet? I've tried the Window mode one but that causes screen tearing and disables crossfire.Thanks in advance.

    2500k @ 4.5ghz
    6870 Crossfire
    8GB 1600mhz


    Try disabling Windows Event Logger by searching "msconfig" in the start menu and pressing enter. Then go to services and scroll down until you find Windows Event Logger and disable it. It's known to cause stuttering in some games.
  2. I gave the uGridsToLoad tweak from nvidia's website a try and a put it at 7,it helped quite a bit.But their is still stutter.The delay is shorter and seems smoother but it is still apparent.I'm still looking for a better solution if anyone has one.
  3. purple stank said:
    I gave the uGridsToLoad tweak from nvidia's website a try and a put it at 7,it helped quite a bit.But their is still stutter.The delay is shorter and seems smoother but it is still apparent.I'm still looking for a better solution if anyone has one.


    Try my suggestion.
  4. I don't know to much about it but it seems like a critical windows process.Also doing a quick search just shows people with BSOD and crashing problems in skyrim.That's not the problem I'm experiencing and I'd rather just leave it alone.
  5. try disabling xfire
  6. Tried disabling crossfire and didn't work.It's strange tho cause if I run it in that window mode fix it only runs on 1 GPU and theirs no stutter.I would use it but it causes screen tearing.
  7. Still haven't found a fix for it.
  8. I found the solution! :D
    followed this youtube guide and it worked. I've got some screen tear afterwards but after setting the RenderAheadLimit to 1 the gane is now playable and no stutter. very small screen tears still but i think with more tweaking this could be fixed too. http://

    if the link doesn't work, search: "Skyrim: Permanent Stutter Fix"
  9. Jesper Pedersen said:
    I found the solution! :D
    followed this youtube guide and it worked. I've got some screen tear afterwards but after setting the RenderAheadLimit to 1 the gane is now playable and no stutter. very small screen tears still but i think with more tweaking this could be fixed too. http://

    if the link doesn't work, search: "Skyrim: Permanent Stutter Fix"


    Tried this and it worked out for me. Same situation - haven't touched Skyrim in over a year and had some performance issues. Seems like the updates since I've been gone have been a mixed blessing.
  10. I gave up on it a while back.I partially think it's an AMD related problem.
  11. What worked for me was to play it in windowed mode. Nothing else fixed the stuttering issue but playing in windowed mode presented a significant improvement.
Ask a new question

Read More

PC gaming Crossfire Skyrim Video Games