Sign in with
Sign up | Sign in
Your question

Low FPS all of the sudden...

Last response: in Video Games
Share
February 21, 2013 4:59:19 PM

Hello, I am having a weird problem. Most of the games that I play right now run with lower framerate than usual, but the framerate decereases only when I look at very big places or very far away. If I am in a place with a lot of stuff my framerate is still fine, but not when I look very far away. For example the port in AC3 where my ship is, now runs horribly and it didn't before or in TF2 where I go to a place that reveals a big portion of the map, the FPS goes down and there is stuttering. I tried scanning for viruses with MalwareBytes and Avast - nothing. Temps are also good. The first time I noticed this I was playing Dead Space 3. I realized that the framerate was lower than the day before that when it ran very smooth. After that I notice these weird FPS drops on almost every game I play. Do you guys have any idea what in the world is happening ?
(Sorry for my English)
System specs:
Intel Core i5 480M
Ati Radeon HD 5650M
RAM: 4 GB
HDD: 640 GB
Windows 7 Ultimate 64x

More about : low fps sudden

February 21, 2013 6:15:36 PM

did you change anything or update anything recently?
check your anisotropic filtering settings in the catalyst control settings. (right mouse click on desktop/catalyst control center/gaming/image quality/anisotropic filtering)
if you have it set at at a large per pixel samlples (more than 8X) your performance will decrease when looking at distant places.

ps: also check anti-aliasing settings
February 21, 2013 8:15:04 PM

I remember that I updated my drivers with the 13.2 beta so maybe that is the problem. I will install the previous drivers and I will report back... tomorrow. Too tired now :) 
Related resources
February 23, 2013 9:59:02 AM

Installing older drivers didn't fix the problem at all. What the hell is happening :( 
February 23, 2013 11:26:45 AM

May be some app you installed? Try out any Game booster, as it will help in improving FPS. Also, de-fragment your drives.
And, if you changed any setting in ATI Control Panel, change them back to Application Controlled.
:) 
February 23, 2013 11:34:12 AM

Open CCC, change "Texture Filtering" to performance.

Maybe it was set to High Quality?
February 23, 2013 1:22:38 PM

MajinCry said:
Open CCC, change "Texture Filtering" to performance.

Maybe it was set to High Quality?

There are no more sliders here with the new look and when I click there is only an option for the level...

February 23, 2013 1:41:15 PM

I also noticed that my hard drive light is flashing a lot, even when it's idle...
February 23, 2013 1:50:23 PM

Did you try to De-fragment your drives, clean your registry?
February 23, 2013 2:16:11 PM

DragonClaw said:
Did you try to De-fragment your drives, clean your registry?

Yup :(  Cleaning my registry with CCleaner and defraged my HDD yesterday...
February 23, 2013 2:18:01 PM

My HDD light is flashing every second...
February 23, 2013 3:02:12 PM

And another thing I noticed in Assassin's Creed 3. In cinematics the game runs perfectly and they are not pre-rendered. So I went to the same spot after the cinematic and it started stutter like crazy... Uum ? :D 
December 9, 2013 7:42:36 PM

old thread .... but i may as well coment on it.

You most likely have some background progarm running that is interfering with the games. (ctrl+shift+esc)/(processes)/(all users)/(sort by memory) and look within the top 15 for your culprit...

(I know this is old)
!